Yet more update manager woes!

Hi - I’m running Mint 13kde on my pc and am in the process of setting the same up on a friend’s Toshiba lappy - (ex-XP). I’m attempting to replicate my setup - as near as possible - as he is a complete beginner with Linux so if he hits a snag I should be able to walk him through the processes a little bit easier.

On my rig the update manager appears in the taskbar and is working normally i.e. shows blue when updates are available, green tick when up to date. Clicking on the icon opens the manager screen ok. On the lappy, the icon sometimes appears on startup (not every time) and when clicked, opens the password box. Everything then disappears and the manager box fails to open. I can run updates from the command line on both machines, no problem.

How can I fix this? 1/ where can I find the info in my pc referring to the config of the update manager?
2/ what do I do to replicate this in the lappy’s config?

It’s not too much of an issue for me but he is a long-time Windows user who hadn’t even heard of Linux a month ago so needs his pointy/clicky things! (I’m trying to persuade him to the dark side (or should that be ‘into the light’?)… ;D)

Thanks in advance


Have you tried to run mintupdate from the terminal? It might give some indication of where it fails.
You could also try to reinstall MintUpdate from the Synaptic Package Manager.

Thanks for the reply.

Now this is getting weird! No sign of the taskbar icon on either pc or lappy on boot up this time . Ran mintupdate on both - pc returned this -

QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/xxxxxxx/.config/ibus/bus

but the password box appeared, opened and updated as normal! Ticked icon reappeared in taskbar.

Lappy gave identical output (except name in string) password box appeared, disappeared, no update and added this line to bash -

Fatal IO error 11 (Resource temporarily unavailable) on X server :0. (Got to type lappy output into here manually)

Any thoughts?


What’s the output from:

sudo lshw -C display

Hi Mark - now logged in via the lappy so should make things easier!

sudo lshw -C display
[sudo] password for xxxx:
description: VGA compatible controller
product: RV380/M24C [Mobility Radeon X600 SE]
vendor: Hynix Semiconductor (Hyundai Electronics)
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=radeon latency=0
resources: irq:43 memory:c8000000-cfffffff ioport:3000(size=256) memory:b8100000-b810ffff memory:b8120000-b813ffff

Before doing anything else, make sure you have an active internet connection, then run a full systgem update from the command line:

sudo apt-get update


sudo apt-get upgrade

When done … REBOOT.

Did that fix it ?

If not, I doubt if this will work, but worth a shot…

Go to -

Mint Logo > System Settings > System Administration >. Startup & Shutdown > Autostart

Select “Add Program”

make the entry read

Desktop File: Update Manager
Command: mintupdate
Status: (checked) enabled startup

Then log off/on again


Hi - update/upgrade had no effect - system shows as up to date. 2nd method enabled icon in taskbar on startup (password box also opened automatically) but still disappeared when clicked (no effect when password entered - no updates screen)


This is really bizarre - try:

sudo apt-get install --reinstall mintupdate

Updated - v 4.4.7 installed. No change…as you say, bizarre!

Do you still get this error if you try starting it from the terminal ?

Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Wonder if this is some issue with KDE - have you seen any KDE updates come through recently?

Yes - as per

xxxxx@Home ~ $ QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/xxxxx/.config/ibus/bus Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Possibly so. I don’t really watch closely - I just tend to click and go and let it do its thing! Incidentally, as an addition to the reply above to Mark, I just ran mintupdate in terminal on my pc and got the same message! However, the password box opened ok and the update manager followed and updated as normal. Taskbar icon works fine on pc, also.

It’s seems like a KDE issue (mintupdate being gtk I think) … but it obviously only applies to some systems

Trying to find out more now … there’s bits and bobs about it on the Mint forum, but it appears to be that rare that nobody’s found out the root cause yet.

Thanks everyone for your help on this. I have a week or two’s grace before I hand the lappy back so will try and ‘break’ it a few times to see how it responds! If no solution can be found before then, I’ll have to introduce him to the delights of the terminal a little earlier than planned… :wink:


I'll have to introduce him to the delights of the terminal a little earlier than planned.

No need for the terminal, just use Synaptic Package Manager. Install it if need to.
Then update every once in the while. I doubt you get wast amount of updates for Mint 13 anyway (part of security of course).

Or ditch mintupdate (which I think is dumb anyway) and use update-manager instead.

You won’t get the pretty panel icon … but it will pop up every now and again when there are updates available.

Mintupdate has the nice priorities thing though…

I mean, I don’t use it (apt-get all the way!), but it’s a nice GUI application for the desktop user.

That’s precisely why I don’t like it … since when is a kernel update considered dangerous ?

Surely NOT updating the kernel could be a security risk ?

and if a new kernel breaks things … just boot the earlier version.

I can’t see the need or purpose to the “priorities” … indeed they’ll also likely stop new hardware support being added for the life of the version … just seems dumb to me.

There isn’t a right option, as it all comes down to how stable a system you want to run. If you wanted it fresh off the bat, you’d run Arch or some similar.
The delay Mint are imposing on the kernel updates from Ubuntu are to allow some testing to take place prior to unleashing it on the masses. I believe that Debian do something similar too…? Maybe I’m wrong, but I was under the impression that Debian doesn’t feed kernel updates from Linus immediately, either on Stable or Testing (I think they all go via sid?)

I’m with you personally, but if you look at it from a noob/Windows-convert perspective, then if doing an update totals your system, you won’t be best pleased. I used to get it when I ran Arch, but I took that on the chin. If Mint did it to me, I wouldn’t be best pleased (even though I could fix it). To be running a stable system (i.e. an LTS release) that breaks upon an update, isn’t acceptable.