14.04 frozen

Hello, chaps.

I recently updated from 12.04 to 14.04. Things worked fine for a while, but today… not.

The log in screen comes up as normal (maybe a bit slower than usual), I can log in and the desktop appears as normal apart from no top menu bar and no side launcher. I have a cursor.

I’ve tried the classic ‘turn it off and on again’ several times without success. I tried to reinstall via the command line as advised here, again no success.

Any advice would be greatly appreciated.


Once you’ve booted, and you’ve got the “blank” screen, can you run a terminal (Alt-F2) and run:

dmesg | tail

And post the result file here?

If you can’t Alt-F2, let us know as there’s another way to do this. If you can, you can also use Alt-F2 to run firefox (to get online to post it)

if you can open a terminal with either
then running

Try the following

sudo apt-get install unity-tweak-tool


unity-tweak-tool --reset-unity

then reboot.

As suggested here:

Ok. Tried those and a couple of others from that link. There seems to be a common error that prevents me from progressing:

“Could not resolve ‘gb.archive.ubuntu.com’”

If you hold Shift after turning on the PC … so you’re presented with the GRUB menu.

Are you able to boot if you select either a previos kernel, or recovery mode > safe graphics mode ?

If not … boot to the login screen (but do not log in) then hit Ctrl+Alt+F3 … log in in text mode with your usersname and password, then post the output from:

ls -al ~/.Xauthority

No GRUB menu appeared (though that may be me not hitting shift at the right time)

The latter returns:

-rw------- 1 neil neil 56 Aug 6 15:37 /home/neil/.Xauthority


Turn off your PC … turn on your PC … and immediately hit AND HOLD the shift key, you should be presented with the GRUB menu.

ok, got it… I bottled out too early before :smiley:

Options are:
Advanced options for Ubuntu
Memory test (memtest86+)
Memory test (memtest86+, serial console 115200
Open wormhole to alternative reality.

I made the last one up.

That’s a shame, I was going to recommend it :stuck_out_tongue:

You want the advanced options, then pick a kernel that’s earlier than your current one (a lower number)

Previous kernel produces the same issue.

Not sure what to do in Recovery mode.

Sorry, just occurred to me… I’m online via another laptop. The one with the issue will not connect which. I should have mentioned earlier, but was being thick. :-[

What happens if you log onto the “Guest” account ?

Now sorted the Wifi (somehow had become ‘soft’ blocked).

Doing the above with internet connection completes without the aforementioned error message, but does not resolve my problem.

And a Guest session appears to work normally.

If you now have an internet connection, try running:

sudo apt-get install dconf-tools


dconf reset -f /org/compiz/


setsid unity


unity --reset-icons

Guest session:

unable to change to root: Operation not permitted

You cannot do that in the guest session.

Are you still unable to get an internet connection in the normal account ?

I logged in as ‘me’ and followed your instructions. From the second command line on various warnings, permissions denied and even a few ‘fatals’ were returned.

You’ll have to give us the exact messages returned in the terminal

You might also want to try:

mv ~/.config/compiz-1 ~/.config/broken-compiz-1

then logging off/on again

First command seems fine.

Second command reads:

error: Cannot autolaunch D-Bus without X11 $DISPLAY

dconf reset [-f] PATH

Reset a key or dir. -f is required for dirs.

Path Either a KEY or DIR
Key A key path (starting, but not ending with ‘/’)
DIR A directory path (starting and ending with ‘/’)

Before I continued anyway ::slight_smile: and then came the warnings.

Try running

export DISPLAY=:0

then the previous commands

For clarity

export DISPLAY=:0