A general query about printer head failure - [SOLVED]

My HP printer is fine, thank you, but a friend I help with her Linux installation decided not to take my advice and bought a fancy Kodak printer.
Just as the guarantee expired, so did the black printing. She cleaned the heads several time, changed the half-full cartridge for a new one and tried cleaning heads again, but all to no avail.
As a stop-gap solution I suggested that she print in another colour, so she now sends out blue letters!
As we live 70 miles apart it’s difficult to diagnose by telephone but in the meantime I would like to ask the community if it is common to have one print head apparently die like this.
I am tempted to just buy her another printer and have done with it, but I’m a parsimonious git and would like to solve the problem if possible. I suspect a repair would cost considerably more than a printer.
Any ideas?

Hi Keith

I know this is not much help but oddly enough I also introduced a friend to Linux who has a Kodak AIO printer that’s developed exactly the same problem, I told her to Google the problem and see if she could find a solution online but I’ve no idea how she got on but I’ll ask her and if she found a solution I’ll let you know,

Good luck


Now why didn’t I think of Googling it ?! I shall search elsewhere, too, and report back.
Interesting to hear that you know someone who has experienced the same thing on a Kodak - yes, please do ask what the solution was.

Thanks, Graeme

Does thiis cover her model ?


How do I clean the printhead on my all-in-one printer?

For ESP 3250, 5250, 5210, Office 2150, 2170, 6150, 7250, 9250, C110, C310, and C315 printers:

  1. Press Home on the printer control panel.
  2. Press the down arrow button until Maintenance is selected, then press OK.
  3. Press the down arrow until Clean Printhead is selected, then press OK.

For ESP 5, ESP 7, or ESP 9 printers:

  1. Press Menu to display the Main Menu.
  2. Press the down arrow button until Maintenance is selected, then press OK.
  3. Press the down arrow until Clean Printhead is selected, then press OK.

For the ESP 3 printer:

On the control panel, press and hold Cancel + Copy/Resume simultaneously until the On/Off light flashes.

The On/Off light continues to flash during the cleaning procedure.

The printer my friend has is a Kodak Hero 3.1 the problem in this case is that the printer is reporting no black ink even after installing a new cartridge the procedure for cleaning the printhead is shown here

which looks exactly the same instructions as you posted, I’m not sure at this point if she tried this but if not I’ll get her to give it a try and let you know if it works


If it’s reporting the cartridge as empty (when it isn’t) has she tried cleaning the electrical contacts between the cartridge and the cradle it sits in ?


are they cheap third party cartridges ?

If it's reporting the cartridge as empty (when it isn't) has she tried cleaning the electrical contacts between the cartridge and the cradle it sits in ?


are they cheap third party cartridges ?

Good questions unfortunately I can’t really answer any of them at this point but I will find out now that Keith has the same problem and hopefully find a common solution, to be honest when she first mentioned this problem to me I wasn’t really interested and she never mentioned it again so it just kinda went out of my mind until Keith posted his problem with the same thing

My friend is not at home at present so I can’t verify the model - will check later - but she has succeeded several times in cleaning the print heads.
I shall ask about checking ink levels and report back.

She hasn’t cleaned the cartridge contacts, and by coincidence I have my isopropyl alcohol all ready to take when I visit.

The company she bought the cartridges from sell both original and look-alike cartridges, but I don’t know which she went for. I have tried both types (HP) over many years and never had any problems, but perhaps that’s the issue here. Would you recommend never to buy the cheaper ones? Are some printers more susceptible to ink problems than others?

Couldn’t really answer that, I’ve no real experience with Kodak printers.

I think it’s more a question of the ink and cartridge/print head quality.

I’ve had re-manufactured cartridges that reported as empty, and ones that worked from the same place (even in HP’s) … it’s all a bit of a lottery.

Now this is embarrassing! It turns out that it is an Epson PX720WD. Sorry about that, but your suggestions are still useful.
My friend tells me that she always uses Epson Original cartridges, so that’s a good thing. Your experience with HP compatibles has persuaded me to stick to Originals, too.
She will find out how to read the ink levels and report back (might be tomorrow).

While browsing the Kodak website that you indicated, I found reference to buying/installing new print heads, so if necessary, and if available for Epsons, perhaps that could be a last resort.

I am beginning to think that I am very lucky with my particular HP printer as I have had little difficulty with it, except when I screw up the installation, of course. As one does.

I found some very useful videos on unblocking Epson print heads:

It seems isopropyl alcohol is not the best solvent to use.

Well, that is familiar. I USED to use Epson printers in the past and suffered the dried up ink syndrome (due to infrequent usage).
It seemed that I have used up more ink in the cleaning cycle than in the actual printing.
Solved the problem by buying from other brands. Never looked back.

That’s interesting.
Do you mean other printer brands or other cartridge brands?

Do you mean other printer brands or other cartridge brands?
Sorry I was not clear. I ditched Epson full stop. Now I run (inkjets) HP and Brother. No such problem (not once in the last 3 to 4 years)

Ah! My friend will be pleased!
I guess there is a statistical element to all this and just as some people will be very unlucky with a particular brand, others will be satisfied.
I am due to visit the offending printer on the 14th Dec to clean the jets and shall report the result for our readers.
Thank you for your feedback, SeZo.

Yeah the difference is Epson printers use a different technology than most other makes (piezo print heads)

… their cartridges are purely ink tanks and don’t have the print head built in (that’s a permanent part of the printer) … this tended to make them slightly cheaper but their print heads more prone to blockages, specially with cheap inks.

Another problem was their cartridges contained a chip that marked them as empty after so many uses … nothing to do with actual ink levels.

Some of the re-manufactured cartridges either used duff chips, or didn’t replace/reset the original chips when they were refilled … so they either didn’t work at all, or reached their usage count soon after being installed … even though there was still a ton of ink, the chip had reached its count and reported itself to the printer as empty.

I am not at all familiar with the innards of printers and your post explains why there are so many YouTube videos about how to unclog Epson jets. Once one knows about it, it’s not a problem for the confident user to deal with, but I wonder just how many Epson users have jumped ship, like SeZo, to other brands to avoid the hassle.
The chips that seem to grace all cartridges these days appear to be of dubious usefulness except to those in the upper income bracket.

I’ll find out on the 14th if this particular printer is fixable and report back. Meanwhile: I’m sorry for my initial mistake about the manufacturer and thank you gents for the generic advice. Watch this space.


Just got round to fixing this problem.

I bought the recommended “Magic Bullet” cleaning kit and followed the video.
Re-inserting the cartridges resulted in the warning “Cannot recognise the following cartridges:” and listed all of them.
I assumed that I had got cleaning fluid on the electrical contacts so dried them; even leaving the cover open without the cartridges in place for an hour or so. But to little avail, except that only four are not recognised now.

EDIT 13:30: All but one cartridge recognised now so looks like it’s just cleaner fluid evaporating from the contacts.
EDIT 1345: Yep - that was the problem.

Advice for other Epson users:

  1. If you have to unblock the jets, do ensure that the cleaning fluid doesn’t get onto the closely-spaced contacts just forward of the jets - they are so close together that it takes ages to evaporate. Unlike the video, there appeared to be no fluid being syringed into the jet so I applied more pressure - which is when the pipe came off and sprayed fluid everywhere! I suggest just applying gentle pressure for a couple of minutes.
  2. Whilst waiting for the drying I put plastic covers over the jets so they didn’t dry out.
  3. I thoroughly recommend the “Magic Bullet” cleaning kit (Clean Print Heads with Magic Bullet Print Head Cleaner). The video and customer service are excellent.

Cool … happy to hear it’s fixed :slight_smile:

I never knew about or heard about that magic bullet kit, looks so straightforward in the video, I bet the guy I gave my last epson away to was laughing his head off after he cleaned it out ! I tried cleaning mine with meths but it was dripping it in . . . . . . it never occurred to me to try syringing it and forcing it through . . . . . . . ah well, lesson learned, least I have a shiny new wireless canon to play with now :stuck_out_tongue: