A warning for those of you with rooted Samsung devices.

Hello all, I’d like to talk about a popular topic generally considered to be relevant to rooted Samsung Android devices. Why do I want to talk about this particular topic? Well because I think people should know, as I feel not enough people know about it.

The topic in question is about the /EFS folder which is a hidden folder in the core of your Samsung Android device. Why is this folder important? Well it’s important because this particular folder stores your unique identification files, such as your devices IMEI number, MAC addresses for the radios, ESN numbers, etc. You get the jist.

If you have rooted your Samsung device, PLEASE, back this folder up. This folder is incredibly valuable to the functioning of the phone. If this folder becomes corrupt when flashing ROMs, or installing new recoveries, then your phone turns into an expensive paperweight.

How do I know this? Well, in an unfortunate chain of events, I have had the “joy” of experiencing this. Without a backup of my /EFS folder, my phone, Samsung Galaxy S3, is now a VERY expensive paperweight.

Had I known before about the /EFS folder, I would’ve backed-up. However I didn’t, and as things go, I’m now left without a phone… for now.

I urge you all to back up your /EFS folder. There are many tools on XDA-Developers that can help with this, however you can with Android Terminal Emulator run:

busybox tar -cv -f efs.tar -C /sdcard /efs

Ensure you have Busybox installed when doing this (though you should have busybox installed anyway.)

I hope people can learn from my mistake.

  • BkS.

Thanks bks. I have a note 2 that is rooted and will now follow your advice.

I would also warn people about rooting and Android tablet with Z4Root which I did and since can’t connect to a network unless I set it up for static ip rendering it useless as a portable device

Not so much a brick as a roof slate


Useful bit of info … just sorry to hear it was so expensively learned … thanks for passing it on :slight_smile:

@ Emegra

Have you tried any different firmwares ?

Have you tried any different firmwares ?

I don’t know how and I don’t know what firmware i could use, it doesn’t look like I can root the device anymore but I’m not really sure about that, I’m completely in the dark.

I’ve posted this on least 6 different Android forums and I haven’t had as much as an acknowledgement, looks to me like this is something nobody wants to touch (no pun intended) :slight_smile: