Acer Aspire One and BT Homehub - WiFi with Linpus - WPA problem - SORTED

A word of exlanation for those new to this thread…

My Acer running Linpus would not automatically connect to my replacement BT Homewhub via WPA or WEP, and I had to delete the SSID and reenter the password EVERY time before I could get online >:(

The solution we discovered was to DISABLE BT-FON and BT-Wifi (which I had not realised are factory set ‘enabled’ these days)

After that, all was well.

You may read on if you want to, but it was a rather long story…

My original email…

Hello Mark

Afraid I am still using Linpus. I keep bidding for another netbook on eBay to try Peppermint on, but keep getting outbid!

Anyway, my Acer connects fine to my Homehub using WEP.

The problem is when I switch to WPA…
I put in the 10 char wireless key and it works fine.
BUT when I next power up, it won’t connect, and when I look at the settings the key has bloated to 20-30 (or more) characters!
I key in the correct key and I connect OK, but it is just a bit of a pain having to keep keying it in.

Am I doing something wrong?
Or is it a fault?
Have you any ideas?

Hope you can help

Thanks in advance

BUT when I next power up, it won't connect, and when I look at the settings the key has bloated to 20-30 (or more) characters! I key in the correct key and I connect OK, but it is just a bit of a pain having to keep keying it in.

It looks like you already had a saved password for that connection.

See i you could you try and delete the connection, then reboot.
When it tries to connect to your WPA connection. then key in the password, but do not save it at this time.
See if it connects. If OK then reboot, key in the password and the save it.

Thanks for the suggestion. Maybe I wasn’t clear, but that is what I have been doing.

The saved password just gets bloated to something very very long, so it can’t connect next time

Can you open a terminal and send the output from:

lsmod | grep ath


sudo lshw -C network

Can you also explain the procedure you used for deleting the network profiles.


Thanks for getting back to me Mark.

I delete the profile using Connection Manager

  • I select the network by clicking on it, and then click the Delete option there.

I am not clear when you want me to do the Terminal actions

  • before I connect?, or
  • when I connect successfully?, or
  • when I can’t connect?
  • or all 3?

Actually there is a problem with the last command

  • code select doesn’t work
  • when I put it in by hand it says lshw command not found
    Am I doing something wrong?

Have you tried deleting ALL network connections (as both user and root) from the command line, then setting up your connection again ?

You can delete all network connections (as root) with:

sudo gconftool-2 --recursive-unset /system/networking

Then as user with:

gconftool-2 --recursive-unset /system/networking

BE AWARE … those commands will clear ALL network settings, so you’ll have to set up wireless again.

Those commands MUST be done from a terminal, NOT the “Run” dialog.


Sorry Mark. Can’t do that - I have some 15 networks on here and I can’t rebuild them all!

No need to be sorry, but I don’t think it’s possible to fix this without clearing the network profiles as both user and root … to tell the truth, I can’t guarantee that would fix it anyway but it’s the logical next step.

Mark - Do you never sleep? (says me, getting up at 5.30am)

Thinking about this, I have been having a problem with a connection in London, and looking at the profile it is my only other password protected WPA network, and yes - you guessed, the password has got bloated to 20-30 (or more) characters.

I guess it may be a system fault

Can you explain what you mean by ‘as both user and root’?

Heh … Yes I sleep … but then I’m not known for getting up at 5:30 on a Sunday (or any other) morning :wink:

Reading online suggests Linpus Lite may have a problem with WPA/WPA2 “Enterprise” (RADIUS) … but should be fine with WPA/WPA2 “Personal” (No RADIUS Server).


Ooops … nearly missed the question at the bottom.

Network connections can be created in/by a normal “user” account, but they can also be created in/by the “root” (administrator) account … the connection information is stored in different places for these 2 account types, and I can’t remember where (in Linpus Lite).

The commands I mention will delete them BOTH.


Thanks Mark

Yes, I have Googled and see the issues now - I had only searched this site for solutions.

I will give your suggestion a spin and get back later today

The setting on my BT Homehub 3 that I have had problems with is: WPA & WPA2 (Recommended)

The others are:
WPA2 only
WPA only
WEP (64/40 bits) - which works fine!

No progress I am afraid.
Whatever I set the Homehub to (except WEP) the result is the same - stored password gets bloated on reboot
And even creating a new network via Connection Manager leads to the same conclusion.

Maybe I will pluck up the courage to wipe the data as you suggest, but that will really muck me up as I have no record of any of the passwords :frowning:

Easier to go back to WEP I think!

Afraid it just got worse - it now wouldn’t autoconnect with WEP.
So I deleted all network connections as you suggested and started again.
Sadly still no autoconnect with either WEP or WPA, and that bloated stored password again.
Please don’t tell me to reload the system - that’s what Windows people do! :wink:

You may have no other option …

Normally I’d say reinstall the NetworkManager, and wpa_supplicant … but as the software repos are now closed for Linpus Lite, I don’t think you’ll be able to do this.

A reinstall will probably fix it … INSTALLING PEPPERMINT will definitely fix it :wink:

Other than that I don’t think I can offer much more help … I can’t even remember how to install/uninstall software through the Linpus Lite GUI, and as I’ve said before Linpus Lite refuses to load in a virtual machine, so I have no way of testing it without doing a full install myself … and I aint overwriting Peppermint for anyone :wink:


You are not going to believe this…!

I borrowed a friend’s BT Homehub 3 and got online using WPA with my Linpus Acer after entering the password.

I then disconnected and looked at the stored password - the usual mega string of *s
Reconnected again OK (without having to enter the password again)

I then turned off my Acer
Reconnected again OK (without having to enter the password again)

Went back to WEP and did the same sequence - no problems

I then unearthed my old CnM out and it couldn’t even connect to my BT Homehub 3 with either protocol - although it was happy with my friend’s hub

So it must be something to do with my BT Homehub 3 - but my wife’s laptop has no problems connecting to it.

The settings of both Homehubs look the same. I wonder what is going on?

Is there a setting in the HomeHub 3 for which type of encryption to use ?




if you can’t find anything … send the output from:

iwlist scanning

Hopefully it will be able to see both your and your neighbours routers … and we can see if the encryption type is the same.

Thanks Mark - an interesting tool - will experiment and get back to you

The BT Homehub Router has auto ‘smart’ channel selection to avoid clashes (ho ho)

  • seems to work in that it selects different channel to neighbours

The BT Homehub 3 Router settings are:

  • WPA&WPA2 (recommended)
  • WPA2 only
  • WPA only
  • WEP
  • none

Wireless interface settings:

  • 802.11 b/g/n (recommended)
  • 802.11 n 40Mhz
  • 802.11 b/g

Nothing in the Homhub settings the mentions “TKIP” or “AES” ?

In my Sky router, when I select WPA/WPA2 it then has an option to set the WPA Encryption type … options are:-


Nothing like that in the Homehub ?

Anyway, I’m using AES, which iwconfig shows as:-

Group Cipher : CCMP

Sorry - no.

Check if when you run “iwlist scanning” there’s any difference between the

Group Cipher :
Pairwise Cypher:
Authentication Suites:

Lines for your router, and your neighbours.

Or post the output here … the output doesn’t contain any keys :wink: