Acer Aspire One AOA110L (a.k.a. zg5) - replace SSD with Hard Drive

This info applies ONLY to the Acer Aspire One AOA110L (a.k.a zg5) that come with the 8Gb SSD
(it does NOT apply the Acer Aspire One that comes with a hard drive … they use a standard 2.5" SATA hard drive, the motherboard is different, and the plastic case is slightly larger on the bottom)

I had another SSD failure on one of my AA1’s the other day, and had run out of replacements … the 16Gb Super Talent replacement SSD’s I’ve used previously were all sold out, and the 32Gb version was over £90 which is ridiculous.

Hmm, what to do ? … I had no intention of spending over £90 on an old netbook, that’s more than the damn thing’s worth…

I’d previously seen this tutorial for replacing the SSD with a 1.8" HDD:

but had been seriously put off by the comments where everyone seems to have problems fitting the ZIF ribbon cable into the HDD

I can report the replacement went well, and I now have a 60Gb HDD in one of my AA1’s … it’s faster than the stock SSD, and those annoying I/O pauses are a thing of the past :slight_smile:

The HDD I bought (Samsung HS06THB) from here:
£26 including postage … came 2 days later.

The stock ZIF ribbon cable from the SSD fitted straight in (after some initial effort).

Bit of further info on fitting the ZIF cable -

The ribbon cable goes in with the blue side UP (ie. blue side opposite the HDD’s circuit board)

And here’s where I think most people had problems

a) there’s a black clip that rotates upwards to allow insertion of the ribbon … but unlike the one on the SSD, it’s NOT at the front of the socket (slot side), it’s at the BACK of the socket, as pictured here:


b) the ribbon cable only goes in about 1.5 millimetres

Further pics of ZIF Vs LIF sockets here:

Thanks for the link etc.

Is it still performing ok?

If so, I will be buying one Monday (my son will fit it, because I havn’t a clue)

BTW my SSD is 16 gig, but I presume it will still work ok.

again thanks :smiley:


Still working fine for me, but I’ve only had it a short while so I can’t give any assurances on reliability just yet … it’s your call, and if it fails don’t blame me :wink:

as long as your current SSD is a ZIF socketed 1.3" IDE (PATA) SSD then yes it should be the right one … in other words if it looks similar to this:-

Don’t worry Mark, too far to send the heavy mob, if all goes wrong.

I’ll let you know how I get on, but it might take a couple of weeks.

If you haven’t already ordered one, you might want to wait a while.

I’m starting to hear some odd sounds from the drive, and once if failed to be recognised whilst making a ticking noise.

It’s in one that belongs to my son, so it could be that he’s mistreated it … or it may be symptomatic of an upcoming failure … you might want to wait and see.

Your call.

Is the clicking manifesting when on battery or all the time?
I had a similar problem with the Eeepc where on battey it was clicking every 5 sec or so.
To test you could run:

sudo hdparm -B 254 /dev/sda

To set HDD advanced power management to it’s lowest value.
If that makes it go away then you know what to do.

No, battery isn’t connected.

This isn’t disk power management related, and is highly unlikely to be software at all … it’s doing it in Windows and Linux … and has locked up three times now.

I’m gonna try repositioning the drive tomorrow as they look slightly delicate … it may be being squashed a bit by the way I padded it out.


I did the same, but, after the installation of Debian, I have this errors after the first
apt-get update or installing a package

I am not able to understand if I did an error installing the HDD (ATA error) or if there is a defect on the driver.
It is strange that I able to install OS without issues and they start after

I used a new ZIF cable, since I damaged the original one.

It is possible I used a wrong cable?

Please help me… I spent money to restore my old Aspire One do not trash it!

Thanks and regards!

Dunno what to tell you … I had exactly the same problem, I’m can only assume the HDD’s are incompatible.

It worked for a few days, then I started to get errors all over the place and failed completely … maybe the voltage is wrong or not stable enough, or maybe those 1.8" HDD’s are just shite … dunno.

I do know the AOA150 had the same motherboard but had a standard SATA connector … the SATA controller is still present on the AOA110L motherboard … so it’s not beyond the realms of possibility that you could solder one on.

dmesg | grep ata

clearly shows the SATA controller is present and being assigned resources by the kernel:-

[ 1.293027] ata1: [b]SATA[/b] max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0x60a0 irq 14 [ 1.293035] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x60a8 irq 15

Beyond that I don’t think I can help … sorry.

I bought a zg5 8gssd version in september.

first i bouht an 64gb zif ssd at the local store, it fit in well but did not worked. I took back, they tested it and agreed with me that it was defected, they can’t give a new one because that was the last one, so they gave back the money.

After i bought an zif to msata adapteer on ebay, but on that the ribbon cable was to thick, it did not fit.

Finally i bought this on e-bay
it’s arrived today, and also the ribbon cable is too thick for it :frowning:

Now i ordered a new setof ribbon cable.

I hope i will be able to make it work, i really love this bad boy netbook

Thank you!

So you don’t think it is the cable? I understand that there are ZIF and reversed ZIF, but I didn’t understand clearly the difference.
Do you know what is?

In any case the vendor is sending me a new HDD: he declared compatible with AspireOne.

As I know, voltage are standard.

There are ZIF, Reversed ZIF, LIF, and Reversed LIF

ZIF= Zero Insertion Force
LIF = Low Insertion Force
Reversed = the exposed contacts are on different sides of the cable.
(and there are even ZIF to LIF cables)

It may well be your cable, it may also be the HDD, or it may just be the case (if you’ve closed the case).

the reason I say it may be the case is I’ve just had another look at the AA1 with the Samsung HDD and if I opened the case it started working and stopped making that weird noise.
So I had a look and the HDD was being squashed between the motherboard and a plastic riser on the case (where one of the SSD screws went) squeezing it ever so slightly … I’ve just cut off that riser, bunged it all back together, and it’s now working properly (so far … fingers crossed) :slight_smile:

What you have to bear in mind here is I’m no expert on this … I’ve done this ONCE (with an HDD, MANY times with an SSD), and I’ve had many problems along the way with the HDD

IIRC, at one point I was getting errors similar to yours, and it turned out to be the ZIF cable wasn’t seated properly in the HDD (which is a royal pain to do) … My point is, I’ll try to answer any questions, but don’t expect me to have all the answers here, as It’s still a work in progess even for me :wink:

What’s really p*ssed me off is I’ve just reaalised I’ve put it all back together WITHOUT the RAM expansion … so it’s all gonna have to come apart again … Aaaargh ::slight_smile:

What make and model of HDD are you attempting to fit ?

Thank you for you help.

No problem, I suppose that the scope of the forum is share experience also, not only have the right answer!

The HDD is HS030GB, declared compatible with AspireOne by the seller.
I replaced the original cable and I tried two one with the same bad result. Also the seller of cable declared that are compatible with Samsung HDD.

Only a note: is the difference between reversed are not are only the side of the contact, there is no issue using one or the other, if I connect the cable in the right side of the connector. Correct?

I removed some plastic from the case and I used tape to fix the HDD. Also I added 512 of RAM.

OK, I’ll be pulling mine apart again tomorrow to replace the RAM upgrade … I’ll then post if the contacts on my ribbon cable are on the same side, or opposite sides.

I’ll also let you know if my drive is the same way up as yours with the cable flat (like your picture)

The vendor sent me a new HDD. Now is working!!!

Great news … well done, and thanks for the progress update :slight_smile:

As a post script it is now possible to purchase 32GB ZG5 compatible Super Talent cards for approx £27 and the 64 GB card for £38 although I might have purchased the last one! The cards fit without any case modifications although some might struggle, as I did, to remove the zif cable block from the original SSD as the double sided medium used is very adhesive.

Before emabrking on an SSD / HDD replacement what is the best way to back up the Peppermint OS6 on the old SSD to be restored to the new SSD / HDD without having to reinstall OS6?

That’s handy info … can you post a link to where you can get them please … mine died a while back, but I’d like to rebuild it.

Alas, they are now out of stock of both 64GB and 32GB cards but here’s the link for the 16GB card at £23.17

TVM :slight_smile: