Acer Aspire One Linux - will not boot

I hope someone will be able to assist me with this:

Installed Easy Peasy on my Acer Aspire One (model ZG5) a few months ago and it has been working brilliantly. I’m ok with Windows but know nothing about Linux.

I inadvertently deleted the spreadsheet/word processing software, could not find the trash bin (if there is one) to uninstall it and thought if I reinstalled Easy Peasy I would be able to reinstate the software.

Without choosing to boot from the memory stick in the BIOS, which I now suppose I should have done, I put in the USB memory stick from which I had previously installed Easy Peasy, pressed F2 and the machine booted up normally without booting from the memory stick.

Shut down leaving the memory stick in the USB and tried to boot again and it would not boot up…

When I boot up without the memory stick, it starts up, the fan works, but the screen remains blank (black). Pressing F2 to access the BIOS does nothing. Have tried disconnecting the battery before trying to boot to no avail.

Any ideas please

How exactly did you delete the software ?

Was the AA1 booted at all between deleting the software, and when you started it with the USB stick plugged in… did it boot properly ?

What happens if you hold the Shift key at boot time ? … You should be presented with the GRUB boot menu… similar to this:

Try selecting “(recovery mode)” then "dpkg - repair broken packages"at the next screen:

NOTE: It’s probably best to have a cabled (wired ethernet) connection to the router during this process, as it may need to download some packages and the Wireless may not be active.

Many thanks for your interest:
Yes it booted and worked properly after deleting the software and I am happy that has nothing to do with it not booting up.
Pressing the shift key whilst booting up did not produce anything - it remains a blank screen

I have tried re flashing the BIOS since me original post

and have tried this without any result (the boot light does not even flash)

It is such a shame because I took it away on holiday just recently and it was so small and indispensable

Will it boot from the USB stick ?

I have tried booting EasyPeasy from a Memory Stick and nothing happens -the screen remains blank.

If I could access the BIOS I would be able to change the boot preference but the screen remains blank.

I have looked at the more obvious reasons for the screen remaining blank such as brightness (Fn), External Mnitor (Fn + F5).

I have also tried using the Acer Recovery Disc using an external DVD and no action resulted from that either.

Thanks for you continued interest

Unless you can get the BIOS recovery (flash) to work, I can’t see there’s much more you can do.

You didn’t put the whole folder that comes with the 3309 BIOS on the USB stick did you ?

I’m sorry to say if you cannot get the light to flash, it’s probably buggered, but some people say it can be fiddly to get the timing right, so try it a few times.

Same instructions to yours

Slightly different instructions in some of the postings here:

some from that link don’t mention the second press of the power button as in step 9 of your link.

But I’d be inclined to go with your instructions, as they are the same as the macles.blogspot instructions, and that has long been considered “the place” for AA1 users.

Good new is that I went through the BIOS flashing procedure meticulously ( and realised that there was an ‘i’ in name change ) and it obviously did the job correctly because it’s booting up normally again. Many thanks for you encouragement and help.

As a result of my earlier delete or removal the of the folders shown previously as the spreadsheet and word processing are still not shown, Where are they likely to be so that I can reinstate them. Everything else seems intact as as it was prior to flashing the BIOS so they must be there somewhere. Any idea please?. I’m just not familiar with Linux and have never been tempted to delve any furether because my main computing is done with Windows 7.

How did you remove them ?

Answer this BEFORE moving on to my next post, as it may be a much easier fix depending on what you did.

Read the posting above first.

Linpus Lite Linux (as used on the AA1) is an extremely dumbed down Linux distribution, and a very old one (based on Fedora 8, Fedora are now at 14)… so my best advice would be to ditch it in favour of something like Ubuntu 11.04, which has much more (and newer) software available, and is much more like Windows to use… well more like Mac OSX really, but more closely resembles the “standard Desktop” layout… and it’s free.

But if you Must stick with Linpus…

You’ll need to enable the “Advanced mode”… follow the instructions here:

Then righ-click on the desktop, and go to System > Add/Remove Software, which is the Red Hat/Fedora Packet Manager… hopefully there will be an option to reinstall what you removed in there.

then when you right-click on the desktop, there should be an option to add/remove software.

But under NO CIRCUMSTANCES EVER REMOVE FIREFOX 2… for some reason the developers decided to entwine firefox 2 with the OS… uninstalling it without using the -nodeps switch will kill Linpus Lite unrecoverably (and you’ll have no option other than to wipe the disk and reinstall Linpus Lite or another Linux flavour from scratch).

This DOES NOT mean you can’t install Firefox 4 however… but it’s slightly more awkward than it would be on any other Linux distribution.

A quick Ubuntu 11.04 video if you’re interested:

Ubuntu 11.04 Natty Narwhal Final Released

Thank you for taking so much trouble. It’s very late at night here.

I don’t remember exactly, but on the left hand side of the page there was a heading to do with Office Software and when that was clicked icons for word processing and spreadsheet were revealed. I opened each of these programmes in turn and the documents I wanted to delete were listed. Not knowing the shift/delete method I clicked on something like ‘remove’ expecting there to be confirmation required, but it was instantly removed without a second chance. I then did the same with the other one. I expected to be able t recover them from a trash bin (as in Windows) but could not find one.

I will look at it again in the morning . Good night and thanks.

You’re welcome…

Ooops, sorry I forgot about the time difference between the UK and erm… Cornwall :wink: … this is a UK forum, where did you think I was ? :slight_smile:

Ahh, I see… I thought you meant you’d uninstalled the wordprocessor and spreadsheet applications, not just some documents or shortcuts.

See if they are in the trash… instructions here:

or follow the instructions in my last post in this thread, and you’ll probably find the trash easier to find.

If they ARE in the Trash, you should be able to right-click them and select “Restore”, and they’ll be put back where they came from.

Many thanks.
It IS the the Word Processor and Spreadsheet applications which have disappeared somewhere after my ‘removing’ them. I found the individual documents in ‘documents’ and deleted them using the shift/delete method. They were both Open Office applications. The Open Office Drawing icon is still is still there under the heading Graphics. Under the Ubuntu Software Centre - installed software Open office Spreadsheet and Word Processor are shown. Clicking on them show they are installed, but instead of opening properly they are simply displayed and described. ie: it says 'This package contains the spreadsheet component for Open and similarly for the Word Processor.

More information:

Opened the Open Office Drawing which is under the Graphics heading. Looked for recent documents and found one that had been created in Open Office Writer. Clicking on that opened Open Office Writer and then clicking on ‘new’ allows a new Open Office Writer document to be created. Similarly as regards the spreadsheet. The question is simply how to recreate the icons for Open Office Writer and Spreadsheet so that they can be accessed with one click.

It appears that all I did was remove the icons and not the programs. I suspected it was something like that because there was no great ’ are you sure you want to delete’ performance.

Hope that is clear. Can you assist with recreating the icons please.

OK… I think I know what you’ve done and how to fix it…

Can you open a terminal and enter these 2 commands:

cp /home/user/.config/xfce4/desktop/group-app.xml /home/user/group-app.xml-bak

(note the space after cp and the first xml)


mousepad /home/user/.config/xfce4/desktop/group-app.xml

When mousepad opens, can you copy its contents and post them here.
(be sure not to make any changes at this point)

Also before posting, can you surround the contents with code tags… eg.

put this at the beginning (minus the quotation marks) [“code”]

and this at the end (minus the quotation marks) [“/code”]

And the content I asked for between them.

This will preserve formatting of the text.

I had to include the quotation marks, otherwise the tags wouldn’t display.

BTW, you can open a terminal by hitting Alt+F2 then (in the resulting dialogue box) typing terminal, and clicking Run.

I am ever so grateful to you for working this out, but before embarking on this, do you understand that in reality all I am seeking to do (in Windows term) is to create a shortcut to open Open Office Write and Open Office Spreadsheet?

YES :wink:

In xfce4 as used in Linpus Lite, the application launchers are stored at /usr/share/applications as .desktop files.

But they are referenced for menu display via the (hidden)

So I reckon the entries for -

have been removed… which is why I want the contents of YOUR
file… to check.

BTW, the first command I told you to run, is going to make a backup of the group-app.xml file, called group-app.xml-bak in your home folder… so even if it gets screwed up, we can replace it… though this may require you to create a LiveUSB (probably not)… but I am covering all the bases, “just in case” :wink:

This sounds pretty dumb but my keyboard does not have the symbol shown between group and app (like _ but at the top)

copy and paste.

Someone else mentioned it looked different when viewed on an AA1… it’s just a regular dash (as in minus symbol)

I have typed the command into Terminal very carefully and I get the result cp:cannot start then home/user etc : no such file or directory

Unfortunately cut and paste from your post does not work, but I have tried typing the comand in twice with the same result.

If this was MS Windows which I am quite familiar with, all I would need to do to create a shortcut would be to find the program, right click and create a shortcut to the desktop. Is there no simple was to do this in Linux?.

I hate to impose upon your time any further. Many thanks for your interest

OK, now I know (from chat) we’re talking about EasyPeasy Linux and not Linpus Lite Linux…

On the desktop go to System, then scroll down till you find Main Menu (under Preferences), and click it.

When the menu editor opens… In the LEFT hand pane, click Office.

Click the New Item button.

In the “Create Launcher” box that opens, make the settings:

Type: Application
Name: Word Processor
Command: ooffice -writer %F
Comment: Create and edit text and graphics in letters, reports, documents and Web pages.

Now still in the “Create Launcher” box, click the icon (looks like a springboard top left).

In the window that opens, click the “Type a file name” icon (looks like a magic wand top left).

In the Location: field enter:


hit your Enter key… Click OK

That will have added the Word Processor shortcut… now for Calc (Spreadsheet)

Click the New Item button again, and make the settings:

Type: Application
Name: Spreadsheet
Command: ooffice -calc %F
Comment: Perform calculations, analyse information and manage lists in spreadsheets.

and the icon is:

When you’ve created both launchers, make sure they have ticks next to them in the RIGHT hand pane of the menu editor.… then close the menu editor.

Now reboot (or log off and on again), and your shortcuts should be listed under Office