Acer notebook password

Thank you very much Mark for your help which I think worked, after following your instructions had message ’ authentication tokens updated successfully’, but then I tried to go into settings to change password {to check if it had worked} and put in the password that I had just created, an error message ‘password you typed is invalid’ was shown. Im really confused, is the root password and the password in settings two different things? If so, how do I find what my current password is in settings as I can’t remember ever putting one in. Thanks again if you can help with this one.

I think Mark’s instructions might be specific to your system, but if they don’t seem to work you could try a more generic approach. Try this from your terminal session;

sudo passwd root

Then enter your new password (twice).

Does this make any difference or does it leave you with the same problem?

As Mad Penguin suggests the instructions were specific to an Acer Aspire One (ZG5), but after a bit more research I’ve found another method for the AA1 which seems to work for about half of the people asking this question so maybe there are 2 versions of Linpus going around.

Try this if Mad Penguins suggestion doesn’t work -

First open a terminal… notice that just before the flashing prompt you should see a $ symbol (this signifies you are a regular user)

Try using the sudo su command to enter root user, so, in the terminal, enter:

sudo su

then press enter… The symbol before the flashing prompt should now have changed to an # (this signifies you are now the root user)
If it changed type:

passwd root

then press enter again, this should prompt you for a new password for root user.

REMEMBERYou won’t see anything as you type, but it IS being entered… and it will probably ask you to enter the new password twice.

Also I would either keep using the SAME password, or keep a note of any passwords you enter, in case you end up with a different password for the user and root accounts.

This works only if there is no root password set - which is a default on ‘some’ systems.
(albeit only systems with zero appreciation for the word ‘security’ … :wink: )

You can reset a root password in this way with;

passwd -d root

However as I say … not recommended … :slight_smile:

If non of the above work, can you answer a question for me… Can you get root access in a terminal at all… remembering what I said in my last posting about the $ changing to an # which will tell you whether or not you have root access.

In a terminal do any of these commands make the symbol preceding the flashing prompt change from an $ to an #

sudo su
sudo -su

remember to hit enter after each line… and check if the symbol changed.

or does this command open the mousepad text editor

sudo mousepad

enter… MUST be sudo mousepad, not just mousepad.

or if mousepad isn’t installed, try:

sudo vi

enter… did anything happen? … again MUST be sudo vi, not just vi

thanks again for your help, did as Mad Penguin suggested and got message ‘removing passwrd for user root successful’ but I still cannot use settings to change password.When I am in Terminal, I am successful in changing the prompt to # from $ when using sudo su command.

OK, when you first started your Acer Aspire One it would have asked you to enter a username and password… this would have set up a user account and from what I gather also applied the same password to the root account… from then on, any NEW users added to the system will have had a different password to the root account, but as long as you can become the root user (which you can) there will be nothing you cannot do.

Can you let us know exactly what you are trying to achieve and what the system is asking for and/or any error messages. :slight_smile:

Who’s password are you trying to change (from settings)?.. does the system prompt you for a password when you try?.. can you do other things (that require root access) like start the package manager?

If all you want to do is change a user password, this will be easy to do from the command line but are there any other problems?

Ok, if you’re doing su and geting #, your system is working fine … any other problems you’re having are purely code 18. :wink:

Can you try this;

cat /etc/passwd|grep home|cut -d":" -f1

This should give a reasonable indication of which users you have set up on your system …

Hi again, all I want to do is change my user password, I am the only user so there are no other passwords been set, problem is when I go into settings to change my password it asks for current password, this is what I cannot remember, there are no other problems. When I have followed your instructions to go in via terminal and removed password for user root the message says ‘removing password for user root successful’ and I am able to create new root password but I do not know how this can help me change my current password in the settings section, sorry if Im not explaining very well but not very computer literate hence hysterical!!!Thanks again

To change your user password… first become root

sudo su

hit enter… make sure $ changes to #

then enter

passwd username

replace ‘username’ (in the above command) with whatever your username is… hit enter… you will be prompted for the new password twice.

EXAMPLE - to change user mark password
passwd mark