Adding a wireless connection in Peppermint 3 [SOLVED]

I have just installed Peppermint 3 on a friend’s Dell Inspiron 1501. All went well except that the Connection icon in the system tray (bottom right of screen) says:
Wireless Networks:
Device not ready (firmware missing)

I have added the network via the Network Manager but the message continues to deny that the firmware exists. For the record; the wireless system on this machine worked fine in the previous, Vista installation.

Any ideas?

Hi Keith

Have you checked in “Additional Drivers” to see if there is a proprietory driver available for that chipset, You may have a Broadcom chipset and I’m sure there was some issue with Broadcom drivers not included in the installation of Peppermint 3 for some commercial licensing reasons


if you want to check what wireless chipset you have type in the terminal

lshw -c network

Hi Graeme.
You are absolutely right - the Broadcom driver was missing.
Unfortunately, when I attempted to download it, the system crashed - twice!
This looks like a more difficult problem. Do you have any experience of this?

Just seen your Edit. The output from the lshw command is:
description: Network controller
product: BCM4311 802.11b/g WLAN
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:05:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=b43-pci-bridge latency=0
resources: irq:18 memory:c0200000-c0203fff

The Connection icon no longer lists a wired-connection option at all - not even greyed out, as before.

Sorry Keith

My knowledge and experience is very limited but I think you need to connect your laptop to the router via ethernet then when you have an internet connection type this command into the terminal

sudo apt-get install b43-fwcutter firmware-b43-installer

as per this post

but it may be better to wait till our lord and master (Mark) or someone more savvy comes along to advise you as I wouldn’t want to be responsible for screwing things up for you

Good luck


OK, on the Peppermint3 PC, create a folder on the desktop called b43offline

On another PC

Download the b43-fwcutter_xxx-x_xxxx.deb file for your architecture from one of the mirrors at this link:
and place it in the b43offline directory you created on your desktop)

Once you have the b43-fwcutter_xxx-x_xxxx.deb file in the b43offline directory on your desktop … open a terminal (Ctrl+Alt+T) and run:

cd ~/Desktop/b43offline


sudo dpkg -i b43-fwcutter*

On another PC with internet access … download these 2 (firmware) files:-

and copy them both to the b43offline directory you created on the Peppermint desktop.

Open a terminal, and run these commands in sequence:

cd ~/Desktop/b43offline


tar -xjvf broadcom-wl-


sudo b43-fwcutter -w /lib/firmware broadcom-wl-


sudo b43-fwcutter -w /lib/firmware wl_apsta-


sudo chmod 755 /lib/firmware/b43


sudo chmod 755 /lib/firmware/b43legacy


sudo modprobe -r b43

(don’t worry if that command fails … just carry on below

sudo modprobe b43

Wireless adapters that use the b43 drivers should now spring to life

If that doesn’t work … try changing to the b43legacy driver with:

sudo modprobe -r b43


sudo modprobe b43legacy

Let me know which (if any) of those 2 drivers worked … b43 or b43legacy

inxi -F output:

the first line should tell you if it’s 32 or 64 bit

Thanks, Graeme.

inxi -S

will tell you if it’s 64bit or 32bit without all the other output.

will tell you if it's 64bit or 32bit without all the other output.

I knew that :stuck_out_tongue:


Sorry: I deleted my silly queries before checking that you had both replied - I wasn’t being rude!

And yes - everything sprang into life immediately!
Thank you both very much for your prompt and effective advice. I don’t know what I would do without your help.


Yeah I have to agree Mark was quite helpfull as well :slight_smile:

glad you got it working


Check it survives a reboot.

Ah! Funny you should mention that. It didn’t.
I tried:
sudo modprobe -r b43
sudo modprobe b43legacy

but that doesn’t connect the wireless.

May I beg your advice once more?


sudo modprobe b43

did wireless spring to life ?

if so, run:

sudo gedit /etc/modules

and add a single NEW LINE at the bottom that reads:-


Save the file … reboot to test.

If that works, let me know … because it might be a good idea to install firmware-b43-installer from the repos now.

Yep - the wireless connection worked on reboot, too, so all is well.
If others are having similar difficulty, then it would a good idea to have the installer in the repositories.
My thanks yet again! My mate now has an ex-Vista laptop running Peppermint flawlessly.


The installer is in the repositories … it’s just that without a wired connection you had no way of getting it.

Ah, I understand.
In fact, then, I didn’t need another PC as I am knee-deep in Ethernet cables. OK, so I exaggerate. I did cotton on eventually and didn’t bother with the second PC.
The owner of the laptop has only wireless so I needed to get it going.

You’re a star.

Yeah, I only gave you the OFFLINE instructions as you said the wired connection wasn’t working :slight_smile: