Adobe hates me.

I installed Adobe Flash Player. Youtube works ok.
But bbc news video will not. And games.
I seem to have it all installed.
I have found lots of sites and installed and re’ installed. Help.
I am using Ubuntu 10.10 Maverick Meerkat.

10.10 64bit by any chance ?

See here on our main (parent) site:

BBC news and games work perfectly for me with this version of the flashplayer in Ubuntu 10.10 64bit… in both Firefox and Chrome/Chromium… previous flashplayer editions gave all sorts of issues.

Theer’s a thread about it here:
http://linuxforums.org.uk/news-and-events/adobe-release-a-new-64bit-linux-flashplayer-plugin/

after installation open Firefox or Chrome and in the URL address bar enter about:plugins hit enter, and check to see if the flash plugin version reads:
Shockwave Flash 10.2 d161

Thank you Mark.
I am useing 32.
the 64 can not use most of the things.
I can not copy the file!!!
I can get the terminal to let me be root.
sudo bash, then my password.
but I can not log on as root?
how do I log on as root with
Ubuntu 10.10 - the Maverick Meerkat.

I try’d the SU boot it will not take my pass word?
in the terminal.

what I wont is how do I log on as root?

You DON’T want to log in as root… install the nautilus-gksu package:

sudo apt-get install nautilus-gksu

This will add a right-click menu item that allows you to open any folder as “Administrator”.

Unlocking the root account on Ubuntu, is not a good idea… learn to use it the way it was intended to be used :wink:

Another option would be to open the nautilus file manager as root:

sudo nautilus

thank you Mark that helpt.
but even with the new file in
it will not play videos on BBC and CNN.
I found a site that told me how to check to see if it is ok.
it said it was all ok???
Ubuntu 10.10 - the Maverick Meerkat
not 64

Are you using Firefox ?

can you open your browser, and in the URL (address) bar enter:
about:plugins
and hit enter.

Now look for any versions of Flash, and tell me what versions they are, and how many are listed.

yes Firefox.
VLC Multimedia Plugin (compatible Totem 2.32.0)
ever one says yes!!!

and can you tel me how to install .sh files?
Ubuntu 10.10 - the Maverick Meerkat

When you go to about:plugins in Firefox, is there nothing that looks like this ?

Shockwave Flash
File: libflashplayer.so
Version: 
Shockwave Flash [b]10.2 d161[/b]</blockquote>

it’s the bold bit I want (if it’s there)

put the file in your home directory, then in a terminal

cd ~
./filename.sh

(obviously you need to change the filename)

File: libgnashplugin.so
Version: 
Shockwave Flash 10.1 r999.
Gnash 0.8.8, 

thank you for your help and time.

call me stupid if you like.
but I still dont get .sh ?
is it some thing like this?
:~$ sh /home/“my name”/boinc_6.10.58_i686-pc-linux-gnu.sh

If it’s in your home directory, that would work… so would:

bash /home/"my name"/boinc_6.10.58_i686-pc-linux-gnu.sh

or making home (~) your current directory and adding ./ before the filename.sh… if you don’t add ./ before the filename.sh, it will look for the file in the “path” rather than the current directory… as in:

cd ~
./boinc_6.10.58_i686-pc-linux-gnu.sh

In ALL cases the .sh file MUST be executableif it isn’t, you will have to make it executable FIRST:

cd ~
chmod +x boinc_6.10.58_i686-pc-linux-gnu.sh

See here:


IMO, Gnash is terrible (and is probably what’s causing your flash problems)…

Disable Gnash in Firefox… open Firefox and go to Tools>Add-Ons>Plug-Ins (tab)
Select the Gnash plugin, and click the “Disable” button.

Now close ALL Firefox instances THEN restart Firefox, and then you will only be using the “proper” Adobe plugin, which should work.

or you could just uninstall gnash.

Thank you the .sh works now. I did,
cd ~
./boinc_6.10.58_i686-pc-linux-gnu.sh
cd ~
chmod +x boinc_6.10.58_i686-pc-linux-gnu.sh
one at a time in the terminal window.

um! Gnash? I can not see it?
I can see.
DivX@ web player.
IcedTea NPR web browser.
itunes Aoo.
QuickTime.
Shockwave flash.
VCL multimedia plugin.
Windows media.
but no Gnash.
I guess I need to add some thing?
but what and how?
I will see what I can find.
but I am very unlucky.

For future readers…

We sorted this out in chat… the answer was to uninstall gnash with:

sudo apt-get remove gnash

Then install the “proper” Adobe flash plugin package (flashplugin-nonfree) from the repositories with:

sudo apt-get install flashplugin-nonfree

I would like to thank Mark Greaves for all the help he gave me.