anti Linux WiFi

Has anyone had problems connecting to public wifi from linux and yet none when connecting the same laptop from windows?

Nope, but then I don’t use Windows :wink:

I can say I’ve never had problems connecting to any wireless network though.

What distro/versin/architecture and wireless adapter and driver are you using ?

Only used windows to test a crazy idea…

Doesn’t work with mageia 2 and knoppix 6. Works with window 7 (yuck!)

With linux it stopped working after they ‘upgraded’ the wifi.

Something funny going on.


iwlist scan

run as root show the wireless network ?

or is it purely a “connection” issue ?

The very first time it seem to work, connection no problem, loaded bbc sport, then stopped working after a few pages.
The next few times one or two pages and then no more connection.
Now not even one page.

Head scratching.

What distro are you running? I used to have this problem on an old version of Ubuntu on my AAO (crappy internet Atheros adaptor)

Mageia 2 and and sometimes knoppix 6 (live). No problems with any old internet cafe. Just this recently upgraded public wifi.
I’d just got my new usb belkin with realtek chipset working fine with both linuxes and the old wifi network, about ten days before they ‘upgraded’.

Have you tried (at least temporarily) disabling IPv6 when connecting to that access point ?

Still might be handy to know what

iwlist scan

says for that access point

along with the output from:




whilst connected

Pretty sure Mageia 2 isn’t supported anymore (IIRC, releases have 18 months of support). Any reason you’re sticking with an older version? Bit of a security risk, especially if you’re using public wifi!

Knoppix 6 is old too, we’re up to 7.4 now!

Tried those many times, nothing stands out, no encrpytion, usual stuff.

Except… sometimes doesn’t see the network at all, yet network is there.

To make it more puzzling, tried same network at different location (miles distant), mageia still doesn’t work at all but the knoppix did, two days in a row. Day after tried both at original location, no joy.

Think it must be something to do with providers hardware/software setup. Or is a little green man pressing a button…

Can’t help if you’re not going to provide the output asked for :wink:

As well as the output asked for above, can you also post the output from:

sudo lshw -C network