AntiX installed on HD does not boot

I had AntiX installed but ran into an annoying scrollbar issue. Could not fix it. Tried to install another OS, but booting from live USB stick did not work. Could not uninstall AntiX, not even with GParted from its own live USB stick. Managed to uninstall with GParted on an AntiX live USB stick.

But, with the antiX live USB GParted recognised the current antiX partitions, so I proceeded to delete them. That seemed to have gone well, but ….

I tried to reinstall antiX (BIOS settings: secure boot – off, Legacy booting on), and marked it for Auto-install, it threw up a message that /sda1 in still in use. So Iset it to custom install, and set the root to the eMMC drive, boot in root, /home in root, swap separate. It asked if everything was allowed to be overwritten, which I confirmed.
The installation completed and at the end asked me if I wanted to reboot (if so, take out the installation medium). Having confirmed that, it rebooted but then got stuck on a black screen with some text, and the message that no bootable device was detected, and to please insert the disc? Huh?

I am completely confused now, don’t understand what I did wrong, and am frustrated with all this. I probably did some things wrong, so I accept my stupidity for that, but is there anything to correct this and get the computer to boot correctly into antiX, hopefully without my earlier issues of trackpad/scrollbar sensitivity. In fact, as things stand now I would like to install a hassle free OS.

My computer is a 64-bit Lenovo Yoga with a 32 GB eMMC and 2 GB of memory.

Can you boot to the LiveUSB and post the output from:

sudo fdisk -l



Thanks for responding Mark.

Command not found


/dev/mmcblk0p1: LABEL="rootantiX17.4.1" UUID="fad90831-3633-4516-88dc-3cb7b52169df" TYPE="ext4" PARTUUID="37aaa7ca-01"
/dev/mmcblk0p2: LABEL="swapantiX" UUID="9d20812f-e4e8-4d97-8071-5da6a9723a73" TYPE="swap" PARTUUID="37aaa7ca-02"
/dev/sda1: UUID="2019-03-28-16-05-31-00" LABEL="antiXlive" TYPE="iso9660" PTUUID="692e3b92" PTTYPE="dos" PARTUUID="692e3b92-01"
/dev/sda2: SEC_TYPE="msdos" LABEL="antiX-uefi" UUID="FB65-2BBB" TYPE="vfat" PARTUUID="692e3b92-02"

This might also be of interest:
partition file syst. mount point label size used unused flags
/dev/mmcblk0p1 ext4 /media/rootantiX17.4.1 rootantiX17.4.1 27.09GB 3.38GB 23.71GB -
/dev/mmcblk0p2 swap - swapantiX 2GB 0 2GB -
/dev/mmcblk0p3 ext4 /media/bios-grub bios-grub 2MB 1.06MB 958KB -
unallocated unallocated - - 30GB — — -
Sorry this does not lign up in the rendered version. What is remarkable is that the partitions are recognised, yet the unallocated space is still shown as 30GB (eMMC size is 32GB), and both “used” and “unused” for unallocated are shown as zero (3 dashes). How that happened I have no idea.

@Mark just to provide some more info:
before wiping the antiX partitions I tried to install Xubuntu. That process gets stuck fairly quickly with some text on a black screen and the Xubuntu logo flashing. Same thing with Peppermint.

I also tried Mint in the compatibility mode. That goes fine, until I get to the set-up page for the various partitions. When I clicked on the Create button a message popped up saying the installer crashed.

After reinstalling antiX unsuccessfully, I tied the other OS’es again, with the same result.

Am I snookered for good, with antiX unusable installed and no possibility to install another OS? In other words, is my delightful little computer ripe for the dustbin?

If not, please tell me how to resolve this. Another OS, newbie friendly, would be better. To use the car analogy: I don’t want to have to be a mechanic to drive the car.

Can you install fdisk in antix, then post the output from

sudo fdisk -l

otherwise you’re going to have to give me text you see when trying to install Xubuntu/Peppermint

Sorry for the late reply, Mark, but i have been busy trying to sort this out. I wiped antiX off the eMMC drive, then tried to install Mint and MX, to no avail: Mint failed to install, MX installed but failed to boot.
I reinstalled antiX because after all the “acrobatics” I went through I have come to the conclusion that only antiX is accepted by the computer. I know that does not sound right, but there is something on the drive.
Anyway, I’ll try to live with the scrolling issue.
Many thanks for your help.