Apache 2.2.24 installation on Linux

Hi All,

Hope you all are doing good.

I was trying to instal Apache HTTP server 2.2.24 on Linux.
I used the following command to instal it:

$ gzip -d httpd-NN.tar.gz
$ tar xvf httpd-NN.tar
$ cd httpd-NN
$ ./configure --prefix=PREFIX
$ make
$ make install
$ PREFIX/bin/apachectl -k start

NN must be replaced with the current version number, and PREFIX must be replaced with the filesystem path under which the server should be installed.

I could install it without any errors.

But under serverFolder/Modules I cant see any modules (*.so files)
and also, the modules are not loaded from httpd.conf(ServerFolder/conf/httpd.conf) file ( LoadModule lines)

I started the server, and when I tried opening the start page by host:port, it is throwing me the error:
“Forbidden You don’t have permission to access / on this server”

I am not sure, it is an installation issue or some permission issue post installation.

Can you please let me know what must be going wrong here.

Thanks in advance

Hi and velcome to the forum.

Any particular reason for compiling it from source?
Version 2.2.22 is in the Debian 7 repos. There could be later versions in other distros, with the advantage of using the package manager to install it.
What distro are you using?

Hi Sezo,

Thanks for the reply.
I compiled it again as part of standard steps provided by Apache.

I followed the above link for unstallation.

I am not sure which distribution it is.
I tried instllation using root user as well, but ended up with the same problem.

Thanks & Regards

Let’s see if we can work out which distro/version you’re using.

Can you post the output from:

cat /etc/*release


lsb_release -a

is apache2 running?:

ps aux | grep apache

What happens if you open a browser on the websever, and navigate to: