Aspire One PXE-E61 media test failure. Help!

I have an aspire One AOA110, intel atom N270. 512RAM and 8GB SSD.
Its failing to boot up now and displays the following
For realtek RTL8101E/8102E PCI-E Ethernet Controller v1.09
PXE-E61: Media test failure, check cable
PXE-M0F: Exiting PXE ROM.
No bootable device-insert boot disk and press any key.

Sounds serious. i’ve tried a reboot with the supplied disc but when running the disc it looks as if there is no 8GB SSD. Is the hard drive toast? is a hard drive hard to change on these netbooks? Or is it something else. :-\ dazed and confuzed.

It seems to be trying to boot from a network drive (through your ethernet cable)

Try entering the BIOS setup and changing the boot order… make sure the HDD (hard drive) is set as the first boot device… To enter the BIOS you need to press F2 just as the screen flashes blue as it is powered on. You can’t hold it… just keep stabbing the F2 key.

Also whilst in the BIOS, you can disable PXE network booting

Set your boot order something like this:

  1. IDE0
  2. IDE1
  3. USB HDD
  4. USB CDROM
  5. USB FDD
  6. Network Boot: Legacy PCI Device (disabled)

Make sure you select ‘save and reboot’.

If this doesn’t work let us know, and we’ll take it from there.

Questions:
Have you got ‘easy’ access to another PC with an internet connection?
If so, is it Windows or Linux?
Do you have a spare USB Pendrive?
Is the hard drive of the Aspire One being detected by the BIOS?

(thought I better highlight the ‘easy’ in the first question before someone said 'how else could he be posting to the forum) :slight_smile:

Failing that , the BIOS will also have an ethernet boot rom or LAN boot rom option … turning that off should have the same effect …

I’ve got easy access to internet from a windows computer. I’ve made the changes suggested, and the pxe message has gone. The netbook now brings up the InsydeH2O setup utility.
I’ve run the aspire recovery disc from an externasl DVD drive but it goes in circles. It gets as far as asking to select partition, but there is no partition to select.
The bios system does not recognise any HDD is fitted.

Mmm, that would explain a lot. (it could be expected to fall back on a network boot if the HDD fails)

So either you’ve inadvertently disabled the hard drive, or the hard drive has developed a fault ??

If your BIOS isn’t reporting the drive AT ALL then either the cables have become loose, the SSD is dead, or the PATA controller chip is dead… I suppose it could be a corrupt BIOS but I doubt it… the only way to tell if it IS a corrupt BIOS would be to Re-Flash the BIOS (see Warning below), or test the SSD in another Laptop.

You have a few options…

  1. Check the cables between the SSD and the motherboard
  2. Test the SSD in another Laptop (any laptop with a PATA connection will do, it does’t have to be an AA1)
  3. Replace the SSD with either another SSD or a standard laptop PATA hard drive
  4. Ignore the SSD altogether, and put Linux on a USB pendrive, and boot it from there
  5. Ignore the SSD altogether, and put Linux on an external USB hard drive, and boot it from there.
  6. Re-Flash the BIOS

For a load of links to pages that will explain how to take apart the AA1, and how to fit either a new SSD or a PATA HDD, see here:

http://repair4laptop.org/disassembly_acer.html
or check out the pics and links here

BUT you will see that Acer have not made changing the SSD simple, it appears to require complete disassembly of the AA1, as there are no external covers for SSD or even memory expansion slot… So unless you are comfortable with taking your AA1 apart, either run it from a USB pendrive, or find someone with Laptop tech experience.

If you want info on running your AA1 from a USB Pendrive (stick) post back and I’ll explain how.

Also if you want info on re-flashing the BIOS post back and I’ll point you to the BIOS binary, the flash utility, instructions on how to get them onto a USB pendrive, and instructions on how to install it.

WARNING - Re-Flashing the BIOS is not without risk, If you use the wrong binary, or suffer a power outage whilst the flash is in progress, you may end up with a TOTALLY dead PC… although I’ve read that the AA1 mitigates this to a certain extent by having a built-in BIOS recovery tool.

Thanks for the advice. Replaced the SSD card and everything is working again. The links for the repair vidoes were especially helpful. ;D

Hi Mark, me again :slight_smile:

I hope you don’t mind me re-opening this old topic. I’ve now made it out to the remote tropics and tried booting up my AOA110. First time it gave me the Peppermint icon/wallpaper across the screen but no menu bar. On rebooting I got the error that is in the title of this topic.

I checked the boot order is rearranged as suggested above. It gives no indicatioin of having an option for LAN/network that I can also disable. Looks like I cannot detect a scent o any HDD/SDD.

I’m wondering is the Loooooooong journey here from europe might have dislodged an inernal cable. Or triggered the demise of the SSD in some other way.

Do you have any thoughts?

p.s. I’m currently in an internet cafe (almost in the middle of the top of a mango tree!) and the connection is slow. I am pretty sure I have the Peppermint OS on my memory stick. The AOA110 USBs don’t work so I have not double verified that yet…

Booting Peppermint from the USB stick should still work … just hit F12 to choose the USB HDD as the boot device.

Though there’s a slight chance it’s a loose cable … others have mentioned the SSD disappearing/reappearing, but that’s normally after they’ve replaced the SSD themselves, I’ve tended to put this down to fitting the SSD badly.

I think it much more likely that your original problems (and these new ones) were caused by a failing SSD.

You can always fit a new SSD, but getting the correct type whilst in a mango tree may be a bit of an issue :wink: … it also requires the total dismantling of the AA1 to fit … probably best left till your return, but I’m happy to help you through it.

There’s a video on here somewhere which shows you how to dismantle an AA1

BTW, the option to disable “Network Boot” … is in the BIOS on the “Main” page … though I doubt it’s going to help.


One other piece of advice … when the SSD fails … I don’t know if this is due to people switching the AA1 on and off repeatedly, in the hope that it will miraculously fix itself, or if it’s somehow connected to the way the SSD fails … but quite often after an SSD failure, the BIOS becomes corrupted, leaving the AA1 displaying nothing but a black screen.

A corrupt BIOS is EASILY FIXABLE on the AA1, so DON’T go thinking “hmm, it’s totally dead now, I’ll just bin it” … it would just require (after fitting a new SSD of course) the BIOS files on a USB stck, then a couple of key strokes … I’ll explain this further if it happens.

Thanks very much. I,ll give what you suggest a go. If you hear nothing from me for a few weeks it,ll be because I can,t resurrect the machine. in which case I,ll consider options when I get home.

Brief reply as I am on an iPad thing :slight_smile:

Thx again!

Okey dokey … and good luck :slight_smile:

Well I might have some progress. I,ll explain it as best I can via two fingers on an iPad. So I,ll try and detail the latest error codes/status…

I tried booting off the stick and was surprised to see it went through to a screen that showed the peppermint (pm) sweet logo, the timer dots, but then the screen just went black.

I took out the stick and tried again and the same happened.

In the bios I disabled the network boot option as you suggested, just en route to trying to get the thing to start upone way or another.

In the bios under Info I was very surprised to see the HDD chip recognised including it,s serial number! As I said previously the HDD info was blank. It also recognised the stick from the boot options menu which it did not earlier on.

Reboo without stick. It brought up a dos like screen titled ,GNU grub v199 rc1-13ubuntu3’

Underneath it had various options

  • peppermint with Linux 2.6 38-14 generic
  • ditto followed by (recovery mode)
  • previous Linux versions
  • memory test memtest86+
  • the same followed by serial console 115 200

I tried the first option. Same thing, sweet icon, timer dots. Ending in a black screen.

I tried several boots from HDD, and stick, and al now end with sweet logo, timer dots, and black screen. There is no apparent way back to the gnu grub menu.

What do you make of all of that? thx!

At a guess, I’d say the SSD is dropping out half way through the boot sequence … which is confusing the bootloader.

Try holding the Shift key when you see the “Acer” logo screen just after turning on the AA1 … that should get you back to that menu.

But if I’m correct, I can’t see a way past this without disconnecting the SSD … do you feel up to that whilst on holiday, if so I can post a link to the disassembly video ?

Meanwhile, I’ll reboot and see if there’s a way of disabling the SSD in the BIOS … but from memory, I don’t think there is.

[EDIT]

Try hitting ESC when you see the sweet and timer dotss … you may be lucky enough to be given a clue as to what’s going on.

I’ll type up instructions to remove “quite splash” from the boot stanza … so it displays the boot sequence, rather than the sweet/dots

OK … to TEMPORARILY (one boot only, so no need to worry about getting it wrong :wink: ) remove “quiet splash” options from the boot stanza … hopefully giving us a clue as to where the boot sequence is stalling.

Reboot your PC, and as soon as the “Acer” logo screen disappears, hit and hold the SHIFT key, until you are presented with the GRUB menu
(if you get to the screen with the Peppermint sweet with 5 or 6 dots underneath it, you have missed it and will have to try again)

Highlight the ‘default’ kernel (usually the top one), but rather than pressing enter, press E to edit.

You will be presented with a screen like this:

http://linuxforums.org.uk/MGalleryItem.php?id=1152

Press DOWN ARROW until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now remove the words quiet splash

Then hit Ctrl+X to boot.

With a bot of luck, we’ll see the last thing that happens before the boot stalls.

My reply of last night got lost unfortunately as using shift I got back into the grub menu and tried booting with option two … Ie with recovery mode. That gave me about 20-30 lines of text that I tried to summarise in a message.

Anyway I,ll try what you suggest and provide an update inddue course.

thx!

Hi Mark,

Back to reality again, and I have made fixing this A110 my current project :slight_smile:

Today I ordered a new battery, as the original when freshly charged was reporting as ‘damaged/very old and only working at 42% capacity’. Using a new 7200mAh in place of the old 2200mAh should put a bit of lead into it’s pencil :slight_smile:

Meanwhile, re: the SSD. How do you think I should proceed? Change the boot stanza as per your previous post, or just go ahead and buy a new SSD chip? And if the latter might you have any suggestions as to where to look? I googled and found chips offered directly by vendors in China, but frankly I’ve only ever bought such components from retailers in Europe who I feel I have some leverage against if purchases don’t turn out as planned.

Personally I’d get a new SSD … what you’re after is a 1.3" PATA (IDE) ZIF SSD … they come in 8, 16, 32, and 64GB sizes.

At present, I can’t see an 8GB in the UK, but there is a 16GB here (twice the size of the default 8GB as fitted by default to the AOA110L):
http://www.amazon.co.uk/Super-Talent-miniPCIe-Solid-Aspire/dp/B002HRE1H2/ref=sr_1_2?ie=UTF8&qid=1342563617&sr=8-2
for £34.82

Considering you’re going to be taking the AA1 apart, you may also want to look at a memory upgrade at the same time … the AA1 can have 1.5GB RAM … 512MB is already soldered to the motherboard, but there’s a slot for another 1GB on the underside of the motherboard.

If you decide to upgrade the RAM at the same time … this is what you want:

for £14.39

Let me know what you decide, and we’ll take it from there.

Check your personal messages.

Well I’ve ordered that SSD, so it and the battery should be here in a week or so I expect.

As for the RAM. With postage it’s probably going to come up to something like another £18 odd, and I don’t know if it’s worth it. The netbook is only really used when one of us goes on holiday (usually me). Also it’s only used for checking e-mail and reading the newspaper etc. No files are stored on it, nothing heavy is demanded of it. Any limit on the performance is usually the local wifi speed.

So that’s where I stand right now! I’ll let you know when the parts arrive.

Oh ps you mentioned somewhere there was a vid re: replacing the SSD. Do you happen to have a link, or a link to that topic? Might as well start preparing for what is to come :slight_smile: