ATI Radeon Xpress 200 - Model 1150 Problem with Debian 8


At first I would like to say I just came here in the last case, cause I don’t know what more I can try, if I’m posting in the wrong place, please move the post.

Well, my problem is very complicated, I’ve an old machine (Dell Vostro 1000) where I’m using Debian 8 with XFCE.
This machine have an integrated video card (ATI MOBILITY RADEON XPRESS 200 - Model: 1150), and it doesn’t work with Debian default configuration.

Let’s see what I already have tried:

  • To turn on my laptop without it shows the notorious colored stripes I need use the “nomodeset” code on grub.cfg.
  • The Debian 8 appears don’t have the xorg.conf (???), I made a Xorg.conf following the instructions at AtiHowTo - Debian Wiki , without success.
  • I tried already tried follow the procedures in the page above, cause the current proprietary driver is not compatible with my old video card. and the older version (legacy) can’t be installed and shows some conflicts with “X”. This way I have to use the generic linux driver.
  • I tried set the display resolution using XRANDR, but it fails and when I made the insertion of another resolution, I just can’t select this.
  • Thinking about modules, maybe I can see a little ligth in the end of tunnel. I find a blacklist file into “/etc/modprobe.d” and removed the module “radeonfb” of blacklist, but when I tried to restart, the machine only shows a black screen with the mouse pointer only. to fix this I changed the “quiet” entry of boot line and changed it with “single” to show the command line and I can see that when the module “radeonfb” is loaded, the letters of command line become small (like it have made a resolution adjustment) but I need understand why only a black screen and the mouse pointer is showed.

Any tip/hint will be appreciated.


Is there anything related posted from dmesg?

My (different) lappy has the Mobility Radeon Xpress 200 video card.
Though this might be slightly different to yours, but mine is running just fine under Jessie with XFCE using the default radeon drivers.
Did you install firmware-linux-nonfree?

What is the output from:

sudo lshw -C display