Bitdefender GUI fails to start solved

Yes we know all the pros and cons of virus programs in Linux but I like to scan incoming emails and other files that come from windows or mac systems.

I installed bitdefender on mint 13 (mate) 64bit. including the GUI interface. The GUI interface now will not start it start did the first run after installing.

Clicking on the short-cut in Menu opens a box saying virus engines starting and then nothing. To adjust settings or update I need to use the GUI interface.

Any clues how to make it run…

Without wanting to install it myself :wink: … what is returned if you try to start it from the command line … probably:




OK, just had a look, and it appears to get installed to /opt/BitDefender-scanner … so instead of the above command … try this one:


What is returned … and what happens

userone@office2 ~ $ /opt/BitDefender-scanner/bin/bdgui
Segmentation fault
userone@office2 ~ $

The virus engines dialogue pops up saying they are starting this closes but the main window for the Gui interface is not started.

OK, try this …

Open a terminal and run:

sudo rm -v /opt/BitDefender-scanner/var/lib/scan/*


sudo su


cat /opt/BitDefender-scanner/var/lib/scan/versions.dat.* |awk '/{print $3}'|while read bdcore_so;do touch /opt/BitDefender-scanner/var/lib/scan/$bdcore_so;bdscan --update;ln -s /opt/BitDefender-scanner/var/lib/scan/$bdcore_so /opt/BitDefender-scanner/var/lib/scan/;done 

(copy/paste that one, as it’s long)


Now try BitDefender with:


Read about the problem here:



Hi, Last night read the information here-

Read about the problem here: and

I applied the first fix in a root terminal and it is now working OK I would say from reading that it fixes about 75% of the systems it is applied too.

Your fix looks simpler and use of a root terminal is not required always a good thing.

Thanks as always for your assistance.

Thanks for posting which solution worked for you … BTW, my solution was based on that same “fix”, I just laid it out differently, and added the step to first delete the file (FYI, that’s the file that gets replaced with a newer and/or 64bit version) … as without doing that first, it didn’t work for me … it left the Bitdefender UI working, but unable to start the scanning “engine” when I tried to scan something… some people can obviously get away without deleting that file first, but it doesn’t hurt to delete it, it’s going to get replaced (with the long command) anyway :slight_smile:

Can you mark the topic [SOLVED] please … TIA

Sorry, but I have to add this …

For future readers … I still don’t advocate the need for anti-virus software (or indeed a firewall) in Linux … it’s not necessary unless:-
a) your Linux box services Windows boxes, as something like a mail server.
b) you are NOT behind a NAT router.
c) you are more paranoid than necessary.
So I’ve now removed BitDefender … I only installed it to answer this question :slight_smile: