black screen on my acer aspire one aoa150

Hi all
2 days ago my acer would not boot up, the power button was on, but had just a black screen.
I googled it and tried the bios flash via a usb, to my amazement it worked. The netbook fired up straight away.
However, every now and then, especially when starting up, it asks for a boot cd?
I’ve turned it off and on again and usually it boots correctly.
It didnt do this before i flashed the bios, so maybe i did something wrong?
I’m running peppermint 5.
Any advice as always greatly appreciated.

I doubt if this is a problem with Peppermint … or the flashing … more likely the SSD is on the way out.

I take it it’s the BIOS that’s prompting for a CD (ie. it’s not Peppermint because that hasn’t even started to load yet) ?

hello Mark
and thanks for the reply
yes it is the bios asking.It does not do it every time, but mostly. On start up this time i hit the f12 to check the boot order, it had the hitatchi one at the top. I hit enter and it loaded. Any way of checking if its the SSD?


Not really, the SSD in the AA1 is a very rudimentary one with no wear levelling or even support for TRIM … they just fail when they fail.

Your AA1 is the SSD model right ? … the one with only 8GB of storage

or is it the HDD model ?

if unsure, what’s the output from:

df -h


sudo hdparm -I /dev/sda | grep -i model


sudo hdparm -I /dev/sda | grep -i rotation

hi mark
the out put is;
Filesystem Size Used Avail Use% Mounted on
udev 485M 4.0K 485M 1% /dev
tmpfs 99M 992K 98M 1% /run
/dev/sda1 109G 11G 93G 11% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
none 5.0M 0 5.0M 0% /run/lock
none 495M 13M 482M 3% /run/shm
none 100M 8.0K 100M 1% /run/user
john@john-AOA150 ~ $ sudo hdparm -I /dev/sda | grep -i model
[sudo] password for john:
Model Number: Hitachi HTS543212L9A300
john@john-AOA150 ~ $ sudo hdparm -I /dev/sda | grep -i rotation
Nominal Media Rotation Rate: 5400
john@john-AOA150 ~ $
its the hdd if i recall with 120 or 160gb cant remember that bit.
it does make a racket when firing up, has done for a while now, i assumed it was a noisy fan.

Yep it’s the HDD model … so I’m suspecting a loose SATA cable between the HDD and the motherboard.

For clarity, how did you “flash” the BIOS ?

it does say something about a loose cable on the printed screen when it won’t boot.
i flashed the bios via usb, downloaded from Acers website.
The instructions were readily available on youtube.
Alls i did was hold the escape and fn button while pressing the power button till it started blinking, the usb then did its stuff.
I was surprised when it worked to be honest, i don’t normally attempt stuff out of my comfort zone.
That suspected loose cable, is it a fix for the amateur?

Ahh, If they’re the ones I’m thinking of, those instructions don’t actually flash the BIOS with a new version … instead they reset it from a backup that’s on the motherboard.

So it’s unlikely you’ve damaged the BIOS

thanks mark
should i leave well enough alone then?
I’m using the netbook right now, but more often than not, it won’t boot straight away, but it’s usable with patience.


If you are any way inclined I would open it up and have a poke around. I had a similar problem with my original 16GB SSD which annoyingly happened when I was travelling. As soon I returned I got the back off and reseated the drive cable into the ZIF housing and it worked. I’ve since replaced that 16GB SSD with a 64GB Super Talent SSD and had no problems since.

Otherwise I’d check out the mounting for the HDD it might have worked loose. And while you’ve got the back off you could also give the fan a clean. I’ve done this myself and step-by-step instructions for all of the above are available on line…

thanks Screagle
if i can find the instructions i will take a peak.
thanks again

instructions for what ? … disassembly ?

Check out this PDF:
(this PDF is for the AOA150 hard drive model … thanks goes to phoenixw2 for pointing it out to me)

or this video (this is for the SSD model AOA110L, but should be very similar for the AOA150):
Video showing disassembly

They’re quite easy to disassemble once you figure out how to release the the clips that hold the keyboard in place.


I referred to this yesterday Acer Aspire One ZG5 RAM Replacement - iFixit Repair Guide. It’s quite handy in case your screws get mixed up as they are listed by length. You can ignore steps 4 to 8 if your ZG5 does not have a wireless card in that location - mine doesn’t.

Replacing RAM in the ZG5 is the most invasive action short of wielding a soldering iron so this pictoral guide should cover everything inc. fan which is shown. Using the pictures, care and common sense I’ve been able to max the RAM out to 1.5GB, replace the original 16GB SSD with a Super Talent 64GB SSD and replace the original Atheros AR5BXB63 wireless card with an Intel 7260 AC - happy days!

Nice … an even better source, thanks Screagle :slight_smile:

thanks mark, thanks Screagle

i will work up the bottle to attempt it over the xmas period, maybe wise to transfer important stuff over to a usb first, in case it goes wrong.
thanks for all the help and advice