Boot issue (Resolved) (Overwriting the windows bootloader with GRUB- how to fix)

I run Linux off a HDD in a external enclosure which i connect by USB to a windows laptop (I know Microsoft bad…but games…). I just updated to Natty and as it updated it asked me where to put GRUB (i think that’s what it asked anyway…) with the advice of if you didn’t know tick all the options, which i did. install, reboot etc. and it all looks fine, and i have to say i quite like it. However it occurred to me (rather late) that maybe when I ticked all the boxes for the GRUB install thingy i might have wiped the Windows bootloader so i shut down and unplugged my Linux enclosure. Lo and behold, windows won’t load. There was an error message which in retrospect would probably be helpful to know…I’ll get that shortly.

So my problem is that at some stage I’ve made my internal drive unbootable (or something?) and really need to fix it so I don’t need the external enclosure to boot. Ideally it would be the original loader which would be restored (the windows one) as technically any installed software will invalidate the warranty ::), but if that’s not possible any fix which works would be good.

the error on boot is:

error : no such device : 8d3db992-3623-4557-b553-44b5f7ba9ce3.
grub rescue>


Which version of Windows ? … and have you got an installation disk ?

Is this a laptop, and does it have a recovery partition ?

If the Windows bootloader was on the internal drive… how did you used to boot Linux ? … by selecting the external drive from the BIOS ?

Windows Vista, at the moment I can’t find the installation disk (if i had one, certainly had some kind of windows disk), might be at my parents but I can’t get hold of them at the moment …
and yes i did have to select the external drive from BIOS, which I still have to do to boot anything.

If you can’t find, or don’t have a Windows Vista INSTALLATION disk, you’ll need to download the Windows Vista Recovery Disk.

You can get it from here for 32bit Vista:

Direct download link:

or here for 64bit Vista:

Direct download link:

Burn the image to disk, then WITHOUT the external USB hard drive attached boot to the Vista Recovery Disk, and follow the instructions in Option 1 here:

If Option 1 doesn’t work… at this point, DON’T move on to Option2 or 3 just yet.

Let me know, and we’ll try EasyBCD instead.

The above is obviously to re-install the Windows Vista Bootloader… your other option would be to Install or fix the GRUB bootloader you have obviously written to the internal hard drives master boot record.

OK thanks, I will try that and get back to you. Sorry to have to bother you with the evils of M$…In an idea world I’ld ask how to fix GRUB so it could boot internally but while i’ve got a warranty, best not to break it in case something i really can’t fix comes up…like hardware failure…

Before you try restore the bootloader from the repair/installation disk, you may want to try this. (I’ve done this and it DOES work.)

Note: Please do back-up before you touch anything regarding system files.

  1. Boot up your laptop, and select Windows from Grub. Once it boots up windows, turn off your pc/laptop abruptly by holding the power button.

  2. You then but up into windows again via Grub, however this time windows will think there’s been an error with boot-up even though there hasn’t so you get the choice of fixing it, or boot up as normal.

  3. What you want to do is select the “Launch startup repair”, and let windows “try” to find some problems. It most likely won’t realize that what you’re trying to do is restore the windows bootloader. Once it’s done, it’ll ask you if you want to restore your system using System Restore, hit “cancel.”

  4. It will now “attempt” to repair windows, that will take about 10-15 minutes until it gives you a message that start up repair cannot repair the computer automatically. Simply close the window, and click “View advanced options for system recovery” on the window behind the one you just closed. It should ask you for the keyboard layout, and your admin password.

  5. Then select Command Prompt, and type in (remember it’s case sensitive!):

Bootrec.exe /FixMbr
  1. Restart your pc/laptop and you should boot-up directly into Windows.
  • BkS.

Ok i’ll give that a shot, seem to be having problems with my cd/dvd drive atm…it keeps making horrible noises and struggling to read the disks…

Sounds like it might be on it’s way out. How old’s your CD/DVD drive?

It could well be, the lappy’s about 3/4 years old. the annoying thing is i’ve already had the hard-drive fail, and it was playing up when that happened so when I send the lappy off for fixing I asked for it to fixed as well…Not sure they did as it the paper saying what had been done didn’t mention anything…but it did stop playing up…for a while. Whats particularly odd is that if will often sound bad for a little and then play DVDs fine, but the writable disks I have it hates (nt sure if they’re CD or DVD but would guess CD.

With regards to your fix i’m afraid its failed, mostly because it turns out that I get a Microlink System recovery (as the lappy is one supplied to me by the government/university due to being disabled and they are the supplier) rather than the regular windows…and while it has start-up repair option (according to the help) I can’t get to it because it requires the “Installation media for the device” or the CD which I burned which it can’t read… Managed to get hold of my brother and he’s found the original disk and will mail it to me once the Bank Holiday is over, will try again then…

If you have no luck with the original installation disk, or it turns out to be an OEM “recovery” disk (ie. not a Vista installation disk, but rather a disk that contains a disk “image”, so your only option is a factory reset, loosing all your data)… try using a DVD-R, rather than a CD-R, there are a lot of cheap CD-R’s out there that laptop drives don’t seem to like.

If the original disk IS an OEM recovery disk… at least you’ll have the option to backup your Windows user files using Ubuntu :wink:

And on attempting to play a couple DVDs the drive fails to find them, just making that horrible sound… seems to have more or less failed completely now… And of course when I test one last time it works… Might have to assume its failed…

I’m guessing this will make fixing the bootloader somewhat harder…?

Erm… YES, it probably will… at least the Windows bootloader, but you can always install GRUB from the Ubuntu drive.

Hold on, I’ve had an idea, but you’d still need a Vista install disk…

Mutlisystem can boot a Vista Installation disk ISO image from a USB stick.

Apologies for the long delay but I can confirm that the bootloader is fixed! CD drive being very annoying, hates half the disks I put in, but has no problems with the recovery disk when it arrived. In the end it was Bks’s method which produced the desired effect, although I did try Option one as suggested by Mark, unfortunately it didn’t work.

So thanks you your help, both of you!
In retrospect I just panicked when I found the lappy couldn’t boot… Should have done some research myself :-[

Further retrospecting leads to the conculsion that the reason I overwrote it in the first place was because I didn’t follow how the naming conventions for Linux partions/drives worked… really need to properly look at that kinda stuff