Boot problem [SOLVED]

Linux Mint 20.2. Only (no dual system with Windows or else).

The system works perfectly, very happy. But when I boot I always see this text twice, before the laptop starts properly :

[ 0.262297] platform MSFT0101:00: failed to claim resource 1 [mem 0xfed40000
[ 0.261827] acpi MSFT0101:00: platform device creation failed: -16

I found a couple of solutions somewhere in other forums, but are neither final nor clear on what to do.
The weird thing is that the system works perfectly, with the exception of this funny booting issue which does make starting the computer slower than it should be with Linux.

Thanks again for any help you may give me.

The key expression here is “platform MSFT0101:00” where the MSFT indicates that the system has had a Windows OS installed. Windows seems to cling on to bits of the disk even when removed.

If the system is working perfectly then I would live with it. How long does your PC take to boot up? If it’s less than 1min then I doubt that there is much value in worrying about the issue.
I did find this: “Usually the messages are an indication the Linux kernel was expecting the BIOS to be written according to certain specs and found it was not. Unless you are having problems, then you can ignore these.” at


Yes, the computer had Windows installed before. So basically one cannot free oneself of Windows even when erasing it all… Then they wonder we we switch to Linux??

1 minute is pretty much as long as the laptop takes to be fully operational; so I suppose I should forget about this issue.
Still, I hope one day a patch will be available to eliminate this last bit of Windows - for this, I’d like to leave this topic open.

I think for now I have sorted all the beginner’s issues I met so far. I very much appreciate the help.

Glad to be of help, WT.

It might be possible to remove all traces of windows by reformatting the entire disc and reinstalling Linux, but it’s a lot of hassle.
If you are happy with the outcome, please mark your first post as [ SOLVED]. Many thanks.