Booting from extenal Hard drive.

As i say elsewhere my peppermint Dell died yesterday. Hard drive on it is a simple slot in affair. I’ve an external HDD case that will allow a hard drive to be accessed via USB port. I’ve tried this but my Win 10 laptop doesn’t want to acknowledge is existance. Blurb on the extenal case says it support Win to XP but no mention of any Linux. Qustions:
Can i run a linux o/s booted from an extenal hard drive on my remaining (win 10) laptop?
Can i run from my (external) Dell hard drive which has peppermint already installed? Do i need a different external case that supports linux to access the Dell hard drive?
Should i just give up entirely & live in a cave?

As long as the PC’s BIOS supports booting from USB then:-

a) YES the external HDD will work (and be bootable) with Linux

b) NO you don’t need a different HDD enclosure (they’re all standard as long as they don’t contain some weird kind of Windows only encryption).

c) You should be able to simply move the HDD from internal to an external USB enclosure and it should just boot … the caveats are:-

i) if Peppermint was installed in non-UEFI mode and you attach it to a UEFI PC you’ll have to switch the BIOS to “Legacy” mode
ii) If Peppermint was installed in UEFI mode it will not boot on a Legacy BIOS (non-UEFI) PC

My windows 10 (remaining) lap top won’t boot from the extenal HDD. It will not even display it as a drive in Win file explorer.

I tried switching off UEFI in the BIOS & have scared the bejesus out of myself when i ended up not being able to boot from anything or regain access to the BIOS to undo what I’d done.

F12 on start up gave me a boot menu that no longer had system set up as an option. It wanted to start from a USB as a 1st option (where I’d set it) but i had no usable stick, I tried highlighting 2nd option of HDD (to boot to WIN 10) & pressed enter - got the same message asking for a bootable medium (as i got for USB option). I’m only here now becuase i remebered that F2 was also supposed give some sort of BIOS access (previous didn’t allow any changes but boot sequence) but now gave me Sytems set up options. I undid previous changes & regained Win 10. I’m reluctant to mess about in there now.

Switching off UEFI didn’t repalce with ‘Legacy’ but something else - forgot write it down just too relieved to be able to undo the change.

I don’t know if the Dell was UEFI or not, it’s dead now so i can’t find out.

If the Dell was ‘legacy’ would Win still show it as a drive in file explorer? Ohterwise it’s porbably the external case.

update: Just been brave & gone back to BiOS. I can no longer get to the system set up via F12 as i used to but F2 now does the same job. To access UEFI i have to first turn off ‘secure boot’ in the security tab. then go to ‘advanced’ tab & select the ‘system configuration’ sub-menu. Turning off ‘boot mode [UEFI]’ gives ‘boot mode [CSM boot]’ and also generates another catagory ‘SATA controller mode [AHCI]’ - no sign of ‘legacy’.

Still haven’t tried to boot from the external HDD & won’t until know more about what’s going on with this UEFi / legacy thing.

CSM (Compatibility Support Module) emulates “Legacy BIOS” … basically it’s the same thing (kinda), but you’ll still need to access the boot device selection screen and choose the USB drive as the boot device.

Right… latest installment. I set boot to CSM , with USB as 1st boot up option, plugged in USB HDD, exitted BIOS (with save changes) & behold peppermint booted normally. Everything appeared to work, it wanted the wireless router password to connect to the internet, everthing else looked normal. I created a file in Liber office & saved it in home directory to see if, on next boot, it remained saved. Shut down normally. removed usb cable. Re-attached USB cable & switched on - went straight jail. As previously a black commandline style screen with:

Intel UNDI, PXE-2.1(Build 083)
(copyright stuff…)
(patents stuff…)
Realtek PC1eFE family controller series v1.27 (10/31/11)
PXE-E61: MEDIA TEST FAILURE, check cable
PXE-MOF: exitting PXE ROM
No available boot device… insert boot disk & press any key

I think it won’t boot to the internal HDD as 2nd boot option because Win 10 won’t boot from CSM boot.

I messed about switching CSM boot to UFEI trying again then swtiching back but, usually got the above blerb or Win 10.
I couldn’t try a different cable as i don’t have a spare, but i don’t think this is the problem.
However on one occasion got the Peppermint loadscreen background & 4 options about which O/S to boot to but by the time i’d read everthing i was just in time to see the default counter hit 0 to load Peppermint GNU. Which then came up with the following:

[4.948744] sd 2:0:0:0: [sdb] no caching mode page found
[4.948791] sd 2:0:0:0: [sdb] assuming drive cache : write through scanning for btrfs file systems
/dev/sdb1 (load bar and increasing No% which ended with following message) contains a file system with errors, check forced.
Entry 'system-privte- (long string of numbers & letters)-rtkit-daemon.service-E40T1p in/var/tmp (1350454) has an incorrect filetype (was 2, should be 1).
/dev/sdb1:UNEXPECTED INCONSISTENCY ; RUN fsck MANUALLY ( ie without -a and -p options)
fsck exited with status code 4.
the root system on /dev/sdb1 requires a maual fsck

Busybox v1.22.1 (Ubuntu 1:1.22.0-15 Ubuntu) built-in shell (ash)
enter ‘help’ for list of built-in commands.

So, what now ? (I’m tempted by a length of rope :stuck_out_tongue: .)

Somehow you’ve screwed up the filesystem on the external HDD

We could attempt to fix that but you’re always going to have to keep changing the BIOS between CSM/UEFI unless you reinstall Linux in UEFI mode.

I’m tempted to say ‘no sh*t, Sherlock’ but I don’t want to appear an ingrate.
Given the only computer i currently have is UEFI Win 10 & refuses even to recognise that that external HDD is attached to a USB port , is it going to be possible for me to re-install Peppermint on it ? Would that drive still work if got the Dell fixed ?

update: Remebered i still have the old HDD from my previous Dell. I think it was Vista but it is recognised as a drive by this laptop. I’ve checked there’s nothing left on it that’s wanted or not backed up elswhere so it is available.

As an aside - this spare drive worked just fine on the, alledged, Legacey BIOS’ed Dell that’s just died, so how come my UEFI Win 10 laptop recognises that old Vista drive but not the Peppermint one? (Am i asking too many questions? …oops. :-X )