Broadcom b43 woes - again! Abandoned

Hi Guys! Any Puppy enthusiasts out there?

I’ve installed Puppy (Lucid) on a HP Compaq Mini Netbook and I’m struggling to get the wi-fi running.

The network manager ‘sees’ wireless (wlan0) but won’t connect properly even after setting it up with the correct keys etc. In fact, sometimes it connects for a minute or two, then drops, or doesn’t connect at all on startup. After it drops, a search states ‘no wireless networks available’… ???

Mark provided a replacement for the Broadcom b43 software when I had this issue after installing Peppermint.

(OK, with the netbook connected to your router with an ethernet cable (so it has an active interweb connection), open a terminal and run:
Code: [Select]
sudo apt-get install b43-fwcutter firmware-b43-lpphy-installer
When that’s finished … REBOOT
Did wireless come to life … ie. if you click the networkmanager icon in the system tray (by clock) does it list your network ?)

I’m assuming that this software will work the same in Puppy as it is changing the wireless card software not the o/s?

The problem is this file doesn’t appear anywhere in the Puppy Package Manager and Puppy doesn’t use ‘sudo’ or ‘apt-get’ to download via the Terminal and I can’t find out the correct command or method to install it! (I found references to ‘wget’ on the internet but that isn’t in PPM either!) Any ideas please?

Thanks in advance, as always!


Maybe see the first response from mill0001 here:
then see the link in his post:
that points to a file half way down that page

Hi Mark and thanks for the reply.

No dice, I’m afraid! I read through those posts and tried other variants of the b43 software (one test said I needed the PIO version) but still the wifi is dead. Even the eth0 stopped working at one point… :-[

I know from the last time that the Broadcom driver is a pig to sort out… Strange though that the wifi will sometimes work - briefly - but then drop and the scan utility reports no networks found?

Anyway, I reinstalled Puppy from scratch (under 5 minutes!!) and at least the ethernet is back up! Any further advice would be appreciated!


Edit: I note that Puppy works very differently from other distros (one is immediately logged in as root, for example) and there’s nothing I can find that describes installing software direct from the terminal. Is this done purely by downloading directly to a browser and installing from there?

Edit 2: I successfully downloaded the b43-PIO-mode-k2.6… file (via ethernet cable) and installed it. However, the installer states ‘note, this package does not have a menu entry’… hence it is not seen in the network wizard driver loading list? How do I make it available?

I’ve never used Puppy for more than a quick look so I don’t know if I can help much … maybe someone else can, or maybe try the Puppy forum.

Is there an option to install the “wl” broadcom proprietary driver, or maybe it’s listed as “broadcom STA” or “bcmwl” or similar ?

Yes to both! I found 2 versions of the driver that are ‘supposed’ to work and installed them but when I go to the network manager and look for the relevant entry, there isn’t one! It just says ‘file not found’ and no amount of searching will turn it up! Very frustrating!!

It must be the Broadcom driver that is at fault - in all other aspects Puppy runs fine but without wireless might prove to be useless, for me, in this instance.

Thanks for the help thus far - I’ll try posting on the Puppy forum and see what that turns up.


Hi Mark - I’ve had no more success unfortunately - no-one seems to know how to install extra software via terminal… ??? All the answers point to the package manager and the Broadcom drivers ain’t in there!

Anyway - I’ve put Puppy on my old laptop and it’s working just fine. Wireless sprang up straight away and has good signal strength. So… Not being one to give up with the Compaq Mini, I’ve installed Debian Jessie on it to try it out.

I believe the install went ok as I didn’t get any error messages, however - I wonder if I slipped up when setting some of the parameters? On boot, I get to the Grub screen ok, Debian GNU/Linux is selected and the boot process begins. After a few seconds the screen goes blank and sits there, no cursor flashing or any sign of life, though the computer hasn’t shut down. Ctrl/Alt/Del will re-boot it but it just repeats the cycle.

I remember that I had this issue before when installing Peppermint 4 and you gave me instructions on how to modify the Grub file? I booted it with my Puppy usb stick and mounted the Debian drive (sda1). I found the file ‘/etc/default/grub’, modified it to “quiet splash nomodeset” and saved it. I tried to update grub but the terminal in Puppy only works in Puppy - if you see what I mean?

Is this the right way to go or am I way off base? And is it possible to update Grub on one drive with a terminal on another?

Thanks in advance


Rich, this doesn’t fall under the title of this topic … next time can you start a new topic for a new problem.

One issue per topic, with a descriptive title … this forum is here as a searchable resource not as free one to one support, it’s nearly impossible to mark topics with multiple issues as solved when one issue is and the other is not, and marking them solved makes it much easier for future searchers with the same issue.

TIA :slight_smile:

OK, the following instructions are for a single boot ONLY.

Turn ON your PC, and as soon as your BIOS POST screen disappears, press the SHIFT key and hold it, until you are presented with the GRUB menu … SIMILAR to this:
(you won’t have long to hit the shift key, and the timing can be a little awkward, so it may even be easier to hit AND HOLD the Shift key DURING the BIOS POST … ie. immediately after turning on your PC)

Select the ‘default’ kernel (the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:

Press DOWN ARROW until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now you can enter additional kernel boot options… so add nomodeset as in the above screenshot … so that line now contains:

[b]quiet splash nomodeset[/b]
(doesn't matter if it moves down a line, as long as there is a space between splash and nomdeset)

Now hit Ctrl+X to boot.

If the PC boots properly, make the edits to /etc/boot/grub that you mentioned in your last response and then run:

sudo update-grub

Apologies! Of course I’ll start a new topic…wasn’t thinking! :-[