Broadcom BCM4318 Not always starting at Boot

Hey guys…this is not a big issue as it works, and very happy I found these directions below - use them all the time as I’ve been trying to find a good distro for my old Acer Aspire3000.

The problem as stated in title, is that it don’t always start at Boot, and have to push the little wireless button to activate wireless. If there is a simple fix that would be great - otherwise no worries. I looked for a solution but not sure of what I am doing and don’t want to make things worse.

Is there a BIOS option to start with wireless enabled ?

Thanks for the advice Mark. Firstly, it all works well in XP, so guessing it is a b43firmware issue. Was wondering if it would help if the b43 Driver was installed prior to OS Install? Still working out which OS will be kept.

I went into BIOS and only saw two things that sounded like might work.
Under “Main” - “Network Boot”
Under “Boot” - “Boot to LAN”

Thanks, NastyCodes

can you post the output from:



sudo lshw -C network

whilst wireless is working.

then the next time it boots without wireless, copy the output from:


to a text file, then reboot to get wireless working and post that output here … so we can compare a working and non-working lsmod output.

if this gives no clues, we’ll move on to checking the logs

I will try and post this properly but forget how. Just read the Posting instructions, so hope I get it right. I’m supposed to post it as a Attachment right?

Crazy enough, it is booting with WiFi now each time lol. I’ll post back later, thank you so much!

No, post output inline, but in code boxes please … I’ll do this one for you, and delete the attachment :wink:

-Aspire-3000:~$ lsmod
Module                  Size  Used by
nls_iso8859_1          12617  1 
nls_cp437              12751  1 
vfat                   17308  1 
fat                    55605  1 vfat
usbhid                 41937  0 
hid                    81731  1 usbhid
nvram                  14029  0 
msr                    12772  0 
joydev                 17393  0 
snd_intel8x0           33455  2 
snd_ac97_codec        110213  1 snd_intel8x0
ip6t_LOG               16846  4 
ac97_bus               12642  1 snd_ac97_codec
xt_hl                  12465  6 
ip6t_rt                12473  3 
snd_pcm                80916  2 snd_intel8x0,snd_ac97_codec
nf_conntrack_ipv6      13581  7 
nf_defrag_ipv6         13175  1 nf_conntrack_ipv6
arc4                   12473  2 
ipt_REJECT             12512  1 
ipt_LOG                12783  5 
b43                   342801  0 
snd_seq_midi           13132  0 
xt_limit               12541  12 
xt_tcpudp              12531  18 
mac80211              436544  1 b43
bnep                   17830  2 
dm_multipath           22747  0 
xt_addrtype            12596  4 
snd_rawmidi            25424  1 snd_seq_midi
parport_pc             32114  0 
bluetooth             158447  7 bnep
psmouse                97340  0 
ppdev                  12849  0 
xt_state               12514  14 
snd_seq_midi_event     14475  1 snd_seq_midi
serio_raw              13027  0 
ip6table_filter        12711  1 
ip6_tables             22528  3 ip6t_LOG,ip6t_rt,ip6table_filter
binfmt_misc            17292  1 
nf_conntrack_netbios_ns    12585  0 
snd_seq                51592  2 snd_seq_midi,snd_seq_midi_event
nf_conntrack_broadcast    12541  1 nf_conntrack_netbios_ns
nf_nat_ftp             12595  0 
nf_nat                 24959  1 nf_nat_ftp
nf_conntrack_ipv4      19084  9 nf_nat
nf_defrag_ipv4         12649  1 nf_conntrack_ipv4
nf_conntrack_ftp       13183  1 nf_nat_ftp
nf_conntrack           73847  8 nf_conntrack_ipv6,xt_state,nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_nat_ftp,nf_nat,nf_conntrack_ipv4,nf_conntrack_ftp
snd_timer              28931  2 snd_pcm,snd_seq
iptable_filter         12706  1 
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
ip_tables              18106  1 iptable_filter
x_tables               22011  13 ip6t_LOG,xt_hl,ip6t_rt,ipt_REJECT,ipt_LOG,xt_limit,xt_tcpudp,xt_addrtype,xt_state,ip6table_filter,ip6_tables,iptable_filter,ip_tables
cfg80211              178877  2 b43,mac80211
bcma                   25651  1 b43
pcmcia                 39826  0 
mac_hid                13077  0 
snd                    62250  11 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
yenta_socket           27428  0 
pcmcia_rsrc            18367  1 yenta_socket
k8temp                 12905  0 
soundcore              14635  1 snd
pcmcia_core            21511  3 pcmcia,yenta_socket,pcmcia_rsrc
snd_page_alloc         14115  2 snd_intel8x0,snd_pcm
i2c_sis96x             12743  0 
shpchp                 32265  0 
lp                     17455  0 
parport                40930  3 parport_pc,ppdev,lp
dm_raid45              76451  0 
xor                    25987  1 dm_raid45
dm_mirror              21822  0 
dm_region_hash         16100  1 dm_mirror
dm_log                 18193  3 dm_raid45,dm_mirror,dm_region_hash
btrfs                 638343  0 
zlib_deflate           26622  1 btrfs
libcrc32c              12543  1 btrfs
vesafb                 13516  1 
sis900                 22729  0 
ssb                    50691  1 b43

       description: Ethernet interface
       product: SiS900 PCI Fast Ethernet
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 91
       serial: 00:16:36:2f:56:5c
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis900 driverversion=v1.08.10 Apr. 2 2006 duplex=half latency=173 link=no maxlatency=11 mingnt=52 multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 ioport:1800(size=256) memory:e2005000-e2005fff memory:60020000-6003ffff
       description: Network controller
       product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: b
       bus info: pci@0000:00:0b.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master
       configuration: driver=b43-pci-bridge latency=64
       resources: irq:17 memory:e2000000-e2001fff
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:16:ce:2f:b3:89
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=3.2.0-97-generic firmware=508.1084 ip= link=yes multicast=yes wireless=IEEE 802.11bg

If you find the b43 wireless driver isn’t being automatically loaded at each boot, add it to the:-


file … all modules listed in that file are automatically loaded each boot.

so run:

sudo gedit /etc/modules

and add a single NEW line at the bottom that reads


SAVE the file and exit gedit.

Reboot to test.

Thanks so much Mark!

No worries mate, if after a few days you consider this (SOLVED) please remember to return and mark the topic solved … you can do this by editing the FIRST posting in this topic and changing:-

Subject: Broadcom BCM4318 Not always starting at Boot (SOLVED)

Thanks in advance :slight_smile:

Is this what I am supposed to do? Looks like a pretty simple text file.

# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


Yeah that’s what you were meant to do, but there’s only a need for “lp” to be mentioned once … try making it read

# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


I’m on it! Wonder why there are so many “lp’s” in there? This is a new install of LXLE 12.04-32bit, so I don’t think that file has been modified? I’ve never even printed from this Install yet.

I see this is LinuxPrinting, again, if you have time or would like to educate me on why this would be, would really like to learn/understand!

I have no idea … possibly a mistake by the LXLE team, but it should only be necessary for the module to be loaded once, no matter how many parallel ports you have.

AFAIK the lp kernel module is actually a parallel port driver … though parallel ports were most often used for printing

Mark, it’s not working.

I appreciate your expertise Mark, but wouldn’t there be more entries in that file if it is were things are loaded from? I thought there was another file that these things loaded from?

Or is that because LXLE Lubuntu has most of these things already eliminated to ease resource usage?

Thanks NastyCodes

What isn’t working … wireless ?

If so, when you boot and it’s NOT working, can you run:
and copy the output to a text file … then reboot (to get wireless working) … then post the output from the text file to here

So I can see if the b43 module was actually loaded when wireless wasn’t working … just to eliminate that.

NO, that file is nearly always pretty empty … most kernel modules will be loaded automagically as hardware is detected, that file is only there to specify a list of modules where they aren’t (or can’t be) being loaded automagically for whatever reason :wink:

FYI, mine reads just

# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.


You surely understand this but I don’t, and it probably don’t matter, but I find this Entry In in /etc/modprobe.d, blacklist.cfg file:

# replaced by b43 and ssb.
blacklist bcm43xx
Shouldn’t this line be commented out?

I guess it won’t help Adding it to Startup Applications because it is not an Application?

O, Maybe this will help, this Distro comes with this “Firmware” (if that is the right term) installed from the dev, the b43 Driver Thing.

I will keep researching, don’t feel obligated to keep helping as there might not be an answer.

Thanks, NastyCodes

I think I have found Replies that confirm my Theory, please give me your thoughts:

[i]"Under 12.04 you just need to comment out blacklist bcm43xx in /etc/modprobe.d/blacklist.conf.

To do that, run this command in the Terminal:

gksu gedit /etc/modprobe.d/blacklist.conf
This will open the file in a graphical text editor. In the editor, find the blacklist bcm43xx line and put a # character at the beginning of it. Save the file and quit the text editor.[/i]"

Here: 11.10 - How do I get my wireless to automatically start after reboot - Ask Ubuntu

Sorry, I missed this: The wireless is still not always starting after login/boot or when ever it is supposed to.

I will do that, forgot these directions from before. When you say Text File, is LibreOffice Writer okay, then insert as Code like you did for me before?


Do not use LibreOffice for editing configuration files, it introduces formatting and that is a no-no.
Use the likes nano, Gedit etc. (simple text editors)

which distro/version/architecture are we talking about here

eg. Ubuntu 14.04 64bit

I ask because bcm43xx hasn’t been included for some time now in *buntu’s