cannot boot Peppermint 4 on desktop computer[solved]

Hi Mark.

my ageing desktop that was duel booted with peppermint 2 and xp, now has no os,

I tried to put peppermint3 on, doing away with xp, but all this did was to remove both peppermint 2 and xp , it booted untill the run live, install,l bit and when I tried to install, it would not go any further, it had it as a fdd not hdd drive.

So i created a new a new peppermint 4 usb stick, which I have used to put peppermint 4 on this netbook, so it works fine, but when I try it on the desktop computer, it doesn’t work.
Possibly removing xp has done something,
any help would be appreciated, just remember I know nothing about this, so keep it simple please.



BTW the inxi output is (or was)
keith@keith-K7VT4APro ~ $ inxi -F
System: Host keith-K7VT4APro Kernel 2.6.38-13-generic i686 (32 bit) Distro Peppermint
CPU: Single core AMD Sempron 2400+ (-UP-) cache 256 KB flags (sse) bmips 3332.93 clocked at 1666.467 MHz
Graphics: Card nVidia NV11 [GeForce2 MX/MX 400] X.Org 1.10.1 Res: [email protected]
GLX Renderer Mesa DRI nv11 20091015 x86/MMX+/3DNow!+/SSE GLX Version 1.2 Mesa 7.10.2 Direct Rendering Yes
Audio: Card VIA VT8233/A/8235/8237 AC97 Audio Controller driver VIA 82xx Audio at port c400 BusID: 00:11.5
Sound: Advanced Linux Sound Architecture Version 1.0.23
Network: Card VIA VT6102 [Rhine-II] driver via-rhine at port c000 BusID: 00:12.0
Disks: HDD Total Size: 80.0GB (3.4% used) 1: /dev/sda WDC_WD800BB 80.0GB
Partition: ID:/ size: 30G used: 2.6G (10%) fs: ext4 ID:swap-1 size: 0.53GB used: 0.00GB (0%) fs: swap
Info: Processes 107 Uptime 1:03 Memory 165.1/496.1MB Runlevel 2 Client Shell inxi 1.4.23

Will a Peppermint 4 LiveCD boot to the Live session desktop ?

I press f11 to go into the boot menu,

USB USB-FDD- (this bit empty)

searching for boot record from usb-fdd-ok

ERROR no configeration file found!
no default or ui configeration found!

Thats as far as it goes

Can this PC boot from USB sticks ? … a lot of older PC’s can’t

Plus, it should register as a USB HDD, not USB FDD

Have you tried burning then booting from a LiveCD (or DVD) rather than a LiveUSB stick ?

Does it then end at:-


With a flashing cursor ?

If so, try typing


and hitting enter.

If it DOES end at “boot:_” and typing “live” doesn’t work … let us know what you used to create the LiveUSB.

firstly- I booted this computer with peppermint2 from a usb stick a while ago.

I’ve only have my AA1 netbook so I cannot create a liveCD.

The live usb was created using usb-creator-gtk and worked ok when installing on the netbook, so should be ok, so should show as HDD but does not.

it does end at boot: with flashing cursor, i typed in ‘live’ and it returned 'could not find kernel image: live

If this is an AA1 zg5 … try a different USB stick , I know the 32bit Peppermint 4 ISO works with the AA1, but they can be fussy about USB sticks.

The sign of it not liking the stick is when it registers as a USB FDD rather than a USB HDD

And be sure to let startup disk creator format the stick first


Sometimes using a different LiveUSB creator such as Unetbootin works, but usually if the USB stick won’t register as a USB HDD you need to use another.

See here if you want to try Unetbootin:
you can download it here:

Put the unetbootin-linux-585 file on your desktop, and run:

chmod +x ~/Desktop/unetbootin-linux-585

now double click it and select “Execute” to run it.

Sorry for the delay, but holidays and illness got in the way, but I’m back.

I have tried all the above,
I have used 3 different usb sticks,
formatted them fat 32
Downloaded Peppermint 4 iso many times,
will boot the zg5 no problem but still comes up on the desktop computer as a FDD.

Will it just be easier to get my son to download the iso on a cd or dvd?

thanks for your help


Not only will it be easier, but probably “necessary” if this PC doesn’t like booting LiveUSB’s :wink:


I will let you know how I get on.

Good luck :slight_smile:

update :smiley:

asked my son to run me a live cd,
he came around Sunday and wasn’t sure if he had downloaded it correct, so he did me a live usb stick as well,
went on the pc, decided to show him why previous attempts failed, so I put the usb stick in and tried to boot, it came up with FDD, so I said it wouldn’t work because it should be HDD, Well, blow me, the next menu came up so I booted to try peppermint 4.

That loaded very slow, I then installed peppermint4,

it was very slow and “flakey” but did load.
I did the install as your tutorial up to stage 7
but it’s not very fluid or quick, not slow but not quick,
another strange thing is that when I slide the cursor over an icon the icon disappears

so now I’ve got it working, I’m going to boot again, next to this boot, so I’ll let you know if Its any better or if I need any more help.


Okey dokey … graphics may be an issue, IIRC nVidia haven’t supported the the MX400/440 in Linux for some time now.

So it all now depends on how well it works with the open source drivers.

I think you might be correct Mark, it could be a graphics problem,

question 1. how do i source drivers, as I think I might need one for my cd and dvd drives?

question 2. is there a diagnostics test to see if every thing installed ok or if I might be missing something.

BTW, my son is looking at buying a laptop with no OS for £70 and putting peppermint on it.

  1. You don’t need drivers for an optical drive … though to play commercial DVD’s with CCS encryption, you’ll need to run:
sudo /usr/share/doc/libdvdread4/
  1. not that I know of … what’s the output from:
sudo lshw -C display

thanks for the reply
keith@keith-K7VT4APro ~ $ sudo lshw -C display
description: VGA compatible controller
product: NV11 [GeForce2 MX/MX 400]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: b2
width: 32 bits
clock: 66MHz
capabilities: pm agp agp-2.0 vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=32 maxlatency=1 mingnt=5
resources: irq:16 memory:de000000-deffffff memory:d0000000-d7ffffff memory:dfef0000-dfefffff

2 questions,

  1. how do I find and install graphic drivers

  2. I can’t get my cd and dvd drives to open, only in file manager.
    When I try to open in vlc nothing happens, any ideas?

If you go to:-

menu > Preferences > Sowftware Updater > Additional Drivers (tab)

is there anything listed ?

And in VLC, go to

Media > Open Disc

What’s listed under

Disc Device:


I find that VLC defaults /dev/dvd on mine yet if I change it to /dev/sr0 then it works.
You could find out where it is located with this:

/usr/sbin/hwinfo --cdrom | grep "Device File"

Then just use that device in the future.
You can change the default device by going:
Tools->Preferences->Show Settings->All->Input/Codecs->Default Devices

If you go to:-

menu > Preferences > Sowftware Updater > Additional Drivers (tab)

is there anything listed ?

NO nothing,

thats worked perfect
many thanks