Canon Pixma Tr8550 printer. Solved

I am new to Linux Forum and using Linux Mint 19.3 Cinnamon and have just installed a Canon Pixma TR8550 printer. I have installed Scangearmp2 from Software Manager and launched it. However it doesn’t appear in the Graphics list. I find I have to launch it by opening Software Manager then Graphics and type in scangearmp2 in the question block. This opens the install block and from there I launch the scangearmp2 successfully see attachment. Is there any simpler way to do this?

Hi, and welcome to the forum.

I’ve not used Canon Printers so have no direct knowledge but printing /scanning issues in general can be problematic. This is not a fault with Linux, more that the manufacturers do not always provide Linux compatible drivers for all of their products. That said, look here -

to see if that helps? Alternativey, if all you need to do is scan - in Mint, go to Menu/Graphics/Simple Scan and see if that works. And make sure your printer is switched on when you open the app. :wink:


Rich’s suggestion might be the simplest method unless scangearmp2 provides something fancy that you need - I’m not familiar with it.

It’s not unheard of for installed s/w to be absent from the menus: an example is Imagemagick. You can probably launch scangearmp2 by typing that name into a terminal, which might be quicker than launching from the Software Manager if that turns out to be your only method.


The program ScanGear MP2 installs the printer driver, so you only need to run it once, which is probably why it doesn’t get put it in the menu. The link given by Rich seems to tell you all you need to install the printer.

Hi Rich J, Keith & David McCann.

Thanks for all your replies, as I’m new to Linux Forums not sure which is correct way to reply so hop[e this way is okay.

The method put forward by Rich I didn’t think had worked however, I tried it again after restarting my computer and pleased to report that I am able to connect to the Canon scanner with Simple Scan exactly as I was wanting to do. So thanks again for all your help.

For my part - you’re welcome! Glad you got it sorted.

Can you mark this as Solved? Go to your first post, open it, click on ‘Modify’ then add ‘Solved’ to the end of your title line. This can be a big help to others who may have the same issue in the future. :wink: