Can't execute scripts [SOLVED]

I’ve just bought a new laptop - Dell Latitude E5570 - and am still trying to come to terms with its quirks. Installed Ubuntu 20.04.

I have all my scripts in a directory /home/keith/.bin and have changed the PATH to include it:
keith@E5570:~$ echo $PATH

…and I’ve made the scripts executable. But when I type a script name I get a “command not found” error.

I’ve not had problems in the past as the process is so simple. Any ideas what I’m not doing?



it looks like you’ve done this, but I’ll add it here for others:

I assume that these work:

i’d check the directory permissions too…may ensure those permit execute too (just in case)

thinking about it…

/home or /home/keith isn’t on another partition is it??? check /etc/fstab isn’t mounting them as ‘non executable’

Hi Brian.

Your commands don’t work, surprisingly, although if I go to the directory .bin where the scripts are, that appears to work.
But your suggestion of changing directory permissions worked a treat! As directory permissions are not generally shown, it didn’t even occur to me to try that.
Many thanks.