Can't get Photoshop to work on WINE 1.2.2?

I’ve just downloaded WINE 1.2.2 (stable version), and added Photoshop CS5 to the list of programs… I go to execute it and BAM. I get this message:

"Blocked: wine start /unix

The file ‘/home/bally/.wine/dosdevices/c:/Program Files/PhotoshopPortableCS5/PhotoshopCS5Portable.exe’ is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit."

Charming… any help? I downloaded WINE so I could use Photoshop in Ubuntu, without having to install Windows :confused:

It does work as I have used it. Wait for Mark to talk you through it, however…why PS5? The Gimp will do virtually everything you want that PS5 can do and it’s a dedicated Linux program. Photography is my passion and I have found The Gimp to be more than up to the job, you just have to play around with it. What are you trying to do in PS5 Portable?

BTW, PS5 portable can’t process RAW files in Linux or Windows.

If you need any more help on Graphics with Linux then Pm me. :slight_smile:

I know Photoshop like the back of my hand, I’ve used it for years, where as with Gimp, whenever I try to work with layers like I do with PS, it won’t do what I want it too :frowning: ! and I know, I’m only using it to edit some JPEGs I got lying around (: Photography is my passion too :O!? Got Flickr?

All I can tell you is Photoshop CS5 Portable works in WINE.

Bks, try this link. It’s Gimp but in mode of Photoshop, it’s called Gimpshop. :slight_smile:

How convenient… Photoshop works now ::).

Right, I don’t know what the WINE team have done, but my photoshop isn’t a happy chappy. I found a .exe that would work with WINE 1.3.28/29 but ever since WINE updated to 1.3.3 It works for about a minute then gives the stupid error message:

“The program Photoshop.exe has encountered a serious problem and needs to close. We are sorry for the inconvenience.”

I’ve tried uninstalling and then reinstalling it, but nope doesn’t want to play ball, so is there a way I could get just photoshop to run an older version of WINE? 1.3.28 Preferably. Everything seems to be breaking ever-since Oneiric was released. :frowning:

You’ll be able to the .exe here in my Mediafire folder.

WINE is a funny beast like that … Once you have it working it’s probably best to lock the version in Synaptic so it doesn’t get updated.

I take it you’re looking for the best way to downgrade WINE to 1.3.28/29 ?

Have you tried everything on WINE 1.2 which should be in the repos ? … or do you need 1.3.28/29 for something else ?

Well I need 1.3.28 for LFS, as the FFB for my wheel was finally sorted in that version, but it was also the version Photoshop was stable in, so yeah I guess a downgrade to 1.3.28 is what I’m looking for. I’ve got the ppa for WINE installed in Synaptic so I guess I should remove that huh?

Erm … YES, use ppa-purge to remove it.

The version in the repo’s is still 1.3.28 (at least in 11.10)

Once you’re back to 1.3.28, lock the WINE version fin Synaptic… so it doesn’t get automagically upgraded.

Right, I’ve removed the ppa, but the latest version of WINE is 1.3.30 :frowning: I’ll go check the HQ for a .deb file for 1.3.28/29.

just disabling/deleting the PPA will still leave the 1.3.30 version in the local cache… you need to use ppa-purge.

uninstalling wine1.3 then running:

sudo apt-get clean

Then reinstalling wine1.3 may work … but best to use ppa-purge.

What was the name/address of the PPA ?


I’m guessing to use ppa-purge I would do something like:

sudo apt-get remove --purge ppa:ubuntu-wine/ppa

First make sure ppa-purge is installed:

sudo apt0get install ppa-purge

If you already deleted the PPA, add it again:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update

then remove it and all it’s packages with

sudo ppa-purge ppa:ubuntu-wine/ppa

Just to be sure:

sudo apt-get clean


sudo apt-get update


Now see what version of wine1.3 is in Synaptic… and if it’s 1.3.28, reinstall it.

The one in Synaptic is now, 1.3.15.

Hmmm … they obviously aren’t up to 1.3.28 in the natty repo’s yet.

Here’s the WINE daily build PPA (which DOES contain 1.3.28 for Natty):

to install:

sudo add-apt-repository ppa:ubuntu-wine/daily
sudo apt-get update

Now either install wine1.3 through Synaptic … or:

sudo apt-get install wine1.3
sudo apt-get upgrade

Once you are at 1.3.28, lock the version in Synaptic, or disable the PPA.

It’s installed 1.3.30 :frowning:

I checked the “about” section in “configure wine”.

2 thing you can try…

  1. run:
sudo apt-get remove wine1.3 wine1.3-gecko
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get install wine1.3 wine1.3-gecko


  1. Uninstall the PPA:
sudo ppa-purge ppa:ubuntu-wine/daily
sudo apt-get update && sudo apt-get upgrade

Remove wine1.3 and wine1.3-gecko:

sudo apt-get remove wine1.3 wine1.3-gecko
sudo apt-get autoremove
sudo apt-get clean

Then go here:

and download/install

with either one, you may also want:
if it doesn’t automagically get installed as that’s in the repos anyway.

I’ve downloaded wine1.3_1.3.29-0ubuntu1~ppa1~natty1_amd64.debbut the software center doesn’t fancy playing ball. The usual install bar is red, and the install button isn’t clickable? Although it’s fine with everything else in the software center.

If I were you, I’d install the default 1.3.15 from the repos, then add the ppa:ubuntu-wine/daily PPA, then run:

sudo apt-get update && sudo apt-get upgrade

Then no matter what winecfg>about says … test it out.

When you last installed from that PPA, what version did Synaptic report as installed ?