Can't install Linux 2nd time around, error: unknown filesystem. grub rescue

Hi all, I’m a newbie to Linux. I did an install of Dreamstudio 11.10 as I want to layout a book for printing using Scribus.
All was ok except even with PAE in the kernal, it wasn’t showing or using over 3.2 Gb of RAM although I have 16 Gb of 1600 ddr3 memory.
Graphic response was really slow even after I updated the Driver from AMD/Ati. So I decided to download 11.04 and using a dvd with 11.04,
tried to install it. Would not do it, just kept booting into the 11.10. I had my BIOS set to boot from CD/DVD but no go, Hit F12 to go
into boot menu and selected CD/Rom as first boot, still no joy. I then removed my C drive, put it into a Win 7 PC, deleted both partitions
and formatted the drive in NTFS, full format. Placed drive back into the original PC and tried to install 11.04 from DVD. All I get now is
‘unknown filesystem. grub rescue’. I have tried several times with 11.04 and 11.10 discs and with no disc at all, still get the same
message. I’m guessing from this that it is a PC hardware problem and nothing to do with either Linux disc.
The system is made up of Gigabyte MA 790FXT UD5 mobo, AMD 1055 x6 core CPU, water cooled, 16Gb kingstone Hyper X DDR3 1600, Fan cooled,
OCZ Vertex 3 Sata v3.0 120 Gb SSD, Saphire 5770 Ati PCIE graphics, Sony BluRay DVD Writer, 700 watt cooler master Silent Pro PSU.
Had Windows PCs for 11 years and never had this happen at all, never even heard of it before. I would be so grateful if anyone can tell me
how to sort this problem,
Thanks in advance

Hi TheDipper, and welcome to the forum :slight_smile:

I’m assuming you can boot to a working desktop from both the 11.04 and 11.10 LiveCD’s by selecting “Try Ubuntu” ?

Are you saying the install appears to go properly, but when you reboot you get that GRUB message ?

All was ok except even with PAE in the kernal, it wasn't showing or using over 3.2 Gb of RAM although I have 16 Gb of 1600 ddr3 memory.

Any particular reason you’re not using the 64bit version.

If you can boot to the LiveCD … try this:-

Boot to the LiveCD and select “Try Ubuntu” NOT “Install Ubuntu” … Once you’re at a working desktop, hit Ctrl+Alt+T to open a terminal … in the terminal enter:

sudo gparted

In GParted, right-click on any partitions and select “Delete” … untill there are NO partitions on the drive, then click the Apply button.

Close GParted.

On the desktop, click the “Install Ubuntu” icon … and if/when asked tell it to use the “Whole Drive”.

If when it has installed and told you to reboot, it still gives you the GRUB error message … DO NOT reformat the drive just come back here and we’ll go through reinstalling the GRUB bootloader.

Hello, thanks for the quick reply. I was up all night with this, been at work all day so feeling a little vague at present.

Anyway I cannot get the pc to boot from cd/dvd, I set cd rom to first boot in BIOS, ignores that and attempts to load OS, which isn’t there anymore.

Tried F12 boot menu, same result, ignores it, so I’m unable to run OS from disc either.

Had a thought that maybe clearing cmos might help, it has got me out of trouble before but only with windows and of course, not this specific problem.

As far as I knew, I had downloaded the 64bit OS from DreamStudio, plainly not.

The AMD/Ati graphics driver was marked x86 + 64bit but I didn’t notice a choice on DreamStudio’s website, perhaps I just missed it somehow, I’ll go back and have another look.

I have wanted to have a dip into linux for a few years and having just built a top end gaming desktop using my win 7 pro x64 disc, I thought now’s the perfect time, and no more cash layout, bonus.

I’m feeling enthusiastic about learning a bit of programming too, sadly I don’t know any programmers so it will be web tutorials for the mostpart.

If the cmos thing works, I’ll let you know. You’re probably going to say that won’t work but I’ll find out soon enough.

Thanks again for the quick reply and I’ll be getting back soon.

If it’s ignoring the CD drive it sounds like either a bad burn … or your CD drive doesn’t like the disks you are using.

have you tried using a DVD rather than a CD ? … or even better, another optical drive ?

Is your hardware capable of booting a USB stick … because you could always use something like Universal USB Creator or Unetbootin to put Ubuntu (or other distro) onto a USB stick insted … then install it to the hard drive from there.


(will apply to 11.04 too)

There are also instructions for creating a LiveUSB on the Ubuntu downloads page:

see step 2 … tick the “USB Stick” box, and whatever the OS of the PC that you want to create the stick on … and follow the instructions.

Another thing to bear in mind is that Linux (unlike Windows) is usually happy if you swap a hard drive with Linux installed to another PC … it will normally just sort out the drivers itself.

So another option might be to remove the HDD from another PC (so it’s safe) that CAN read the CD/DVD, attach the HDD you want Linux on, install Linux, then move the Linux HDD to the other box … then put the original HDD back in the first PC.

If you get my meaning.