Change Keyboard to UK

I am trying to change my keyboard layout to UK but I’m not having much luck.
I can’t see any GUI settings where I can change the keyboard (is there any?) so I found there’s another way by directly editing the config file.

sudo gedit /etc/default/keyboard

gives me

Check /usr/share/doc/keyboard-configuration/README.Debian for

documentation on what to do after having modified this file.

The following variables describe your keyboard and can have the same

values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options

in /etc/X11/xorg.conf.


If you don’t want to use the XKB layout on the console, you can

specify an alternative keymap. Make sure it will be accessible

before /usr is mounted.


As you can see, the keyboard IS set to GB, BUT when I type + 2 I get @ NOT " and when I type 3 I get # NOT the pound sign
The keyboard I am using is a Logitech K800 Wireless.

Is it still
system settings → input devices → keyboard → layouts tab → configure layouts
in KDE ?

Sorry Mark, I thought you’d realise I was referring to a Peppermint problem and not a Kubuntu one as I am in the Peppermint support forum.
The auto spell is also tagging words as wrong, take ‘realise’, that is the English spelling but it is telling me that it should be ‘realize’.

OK, for Peppermint 5 keyboard layout is set in the Peppermint Control Centre

menu > Preferences > Peppermint Control Center > Keyboar & Layout (tab)

Then click the “Select Keyboard Layout” button

then select

gb > English (UK)

and click “Apply

If spelling is still in US … in which application(s) ?