Choppy Youtube video

Hi guys I installed Peppermint 5 to my wifes PC and it’s running well the only issue is streaming video from youtube is slow and choppy (that’s the best way I can describe it), I’m not sure if this is a deficiency with the PC itself or a network issue but there’s no buffering and the PC is quite fast otherwise

Here’s some info that might help

Chromium Browser 34.0.1847.116 (Built on Ubuntu 14.04, running on Peppermint 5 aura) OS Linux Flash plugin /usr/lib/pepperflashplugin-nonfree/
at@Linux2 ~ $ lshw -c display
WARNING: you should run this program as super-user.
       description: VGA compatible controller
       product: RV710/M92 [Mobility Radeon HD 4330/4350/4550]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:40 memory:d0000000-dfffffff memory:febf0000-febfffff ioport:e000(size=256) memory:febc0000-febdffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

any suggestions would be appreciated

Many thanks


Hi Graeme.

I had a similar experience on you tube and a couple of other graphics problems, using Chromium aura

I disabled desktop effects in the Peppermint control centre and that solved “my” problems.

Good luck.


Hi Keith

Thanks for that, unfortunately it didn’t have the desired effect in this case, I can’t help feeling I’m not getting hardware acceleration because when i run a video the cpu is maxed out, but I don’t know how to find out if I am getting hardware acceleration or not

Many thanks


OK … bad news I’m afraid … after going through the ATI site, it suggests the last drivers for this card were 13.1

Now if you look at the bottom of this page:
(excatly the same for 32bit)
it suggests the last kernel version supported by those drivers were the 3.4 kernel series and Xorg Xserver 1.12

so they’re not going to work in Peppermint 5

They will however work in Peppermint 3 … in fact Peppermint 3 may offer them automagically through Additional drivers

ATI don’t seem to support their low end hardware for very long I’m afraid

OK thanks for that Mark

I should have tried this before posting but I’ve just installed Firefox and youtube video is working far better and there’s even a noticeable difference in general performance ie refreshing pages.


OK, your call.

Sorry it was bad news, but then again I don’t own ATI :slight_smile:

Not your fault like you said you don’t own ATI, but it could be the GPU driver hasn’t been the problem after all, I’m seeing a huge improvement not only with video streaming using Firefox

So we’ll run Firefox for a while and test it properly before removing Chromium

Many thanks


Maybe Chromium/Chrome doesn’t the PPAPI flash plugin (pepperflash)

If you use the pre-aura version of Chrome/Chromium it’s possible to get those to use the NPAPI (adobe flash) version … same as Firefox.

Ice would still work then.

Would I be right in saying that Ice would still work so long as I didn’t remove Chromium from the system even if Firefox is the default browser ?


Yep, it’s enough for me to never buy an AMD product again - I can’t use propriatory drivers for my 4850 in my desktop, it’s still a great card, much better than some of rubbish they sell now. Yet they can’t just keep the driver in line with the kernel and Xorg? Nvidia & Intel manage it!

I’m pretty sure that’s true - I remember seeing a post about it at the weekend, and instructions on installing pepperflash with Chromium. I’ll try to find it at lunch time

Firstly, in Peppermint 5 Ice now works with EITHER Chromium or Chrome

Chromium in Peppermint (by default) is the latest aura version and already uses pepperflash.

If you download and install Chrome from Google, you’ll get the aura version and pepperflash

If Firefox is much better at flash video I can only assume it’s because it DOESN’T use pepperflash, instead it uses the NPAPI Adobe flashplayer

To use Chromium or Chrome with ANY NPAPI plugins requires you go back to a pre-aura version, as Google have now dropped support for NPAPI plugins (so no Java in Chrome/Chromium either now … though you can spend days trying to get java to work because at no point does Chrome/Chromium tell you it’s NPAPI so won’t work, it just silently fails)

I’ve written a tutorial on how to go back to a pre-aura version of Chrome and/or Chromium on the Peppermint forum,494.0.html

Once you’re running a non-aura version it should be a simple matter to go to:
Hit the +Details button
then you should see 2 shockwave flash versions (both enabled), just disable the one that mentions “pepperflash” and restart Chrome/Chromium … it should now use the Adobe flashplayer (the same one Firefox is using).