CYBERMAX MD41257 fails to boot on 50% of start ups. Solved

I have mint 13 32bit on a CYBERMAX MD41257 (Medion) and it stops after the log in on the blank screen in 50% of start ups from cold. There is no response and the only option is to switch of and switch on then it boots normally.

It has a P4 CPU and has always been a pig when I had XP on it it failed to boot and BSD 50% of cold boots. The computer has been checked by a computer shop and it seems that everything is working as it should.

I was wondering if anyone had bad experiences with CYBERMAX or Medion computers. I had to renew the battery after just 2 years and now the new batery seems to be on its way out after only 14 months.

Could it be the monitor ?

I used to have an old 15" LCD monitor that would only kick in half the time at login … but if when it goes to a blank screen you turned off the monitor, then turned it back on, it would work.
( I spent months turning the PC off before realising that)

I forgot to mention that it is a laptop… I do not think it is the screen as the key board is dead and there is no hard disk activity…

As I said it has always been a bit of a pig… It used to overheat and shut-down this was traced to the battery that was not holding a charge, replacing the battery solved the overheating.

I exercise good battery management fully discharging and recharging every month and yet I noticed recently that the battery(only 14 months old) is only lasting for an hour when it is supposed to last 2.5 hours on high demand.

I tested the Hard disk and the RAM and all is in order. So it would seem that it is just a crap laptop.

Well if it’s a laptop, and the HDD and RAM are known to be good, there’s little else you can do.

Have you tried REISUB when it appears to be locked … to see if it reboots ?

The reason I ask … if REISUB works, then the system is active … that’s partly how I worked out it was my monitor, I thought it was frozen during the boot as all hard drive activity stopped, but in reality it had just finished booting.

Not that there’s necessarily anything you can do if it’s a laptop and it is the monitor.

Forgot all about REISUB will try it next time it fails. It is possible to get a new screen from ebay but this laptop is extremely difficult to undo and replace components I had to have a shop upgrade the RAM as I just could not get the thing open.

If it is a screen issue a second-hand laptop would possible be the best option.

Thanks for your comments.

Just in case you can’t remember the key combo

Hold Alt+SysRq … and whilst holding them, type R - E - I - S - U - B (leave a few second between keystrokes)

Some laptops require AltGR+SysRq instead.

and SysRq is usually the same key as PrtSc (print screen)

I’d agree … if it’s the monitor, it’s probably less risky just to get another laptop.

Is a boot log generated that I can check to see where it stops…The back light is always on sometimes the num lock is not working and thus none of the buttons work.

Errors during booting wil be at:-
but be aware … those are ONLY errors that don’t stop the boot process … ie. a kernel panic won’t be logged, as it’ll kill the system before it can be logged.

You might find more info in these

Can you attach an external monitor to your laptop, just to prove that it has/not fully booted?
Also changing the kernel line to verbose might give you some indication (that is if you get some display going)

I have been thinking if it could be something to do with the boot splash being black, maybe the video driver drops out sometimes I wanted to install a splash screen using " sudo update-alternatives --config default.plymouth" but I am told there are no alternatives so how do I install some?


I take it we’re talking about Ubuntu ? … which version ?

What’s the output from:

sudo lshw -C display

Have you tried attaching an external monitor to see if it’s booting properly … but the monitor backlight is not coming on ?

Read Out: PCI (sysfs)
System is mint 13 32bit.

The only monitor I have is attached to the desk top system and I am not sure is the lead will reach.

The backlight seems to be on at all times…

password for usertwo:
description: VGA compatible controller
product: RS300M AGP [Radeon Mobility 9100IGP]
vendor: Hynix Semiconductor (Hyundai Electronics)
physical id: 5
bus info: pci@0000:01:05.0
version: 00
width: 32 bits
clock: 66MHz
capabilities: agp agp-3.0 pm vga_controller bus_master cap_list rom
configuration: driver=radeon latency=66 mingnt=8
resources: irq:16 memory:e0000000-efffffff ioport:9000(size=256) memory:d0100000-d010ffff memory:d0120000-d013ffff

OK I doubt if the lack of a bootscreen (if you mean the screen with the 5 dots) has anything to do with this.

That could probably be fixed by adding vga=791 to your kernel boot line.

is “Additional Drivers” not offering you any other graphics drivers ?

If I had to take a guess I’d go for

a) some kind of weird acpi issue … try adding acpi_osi=Linux as a kernel boot parameter.
b) failing hardware … does the SMART data in Disk Manager report any errors ?
c) screwed file system … run: sudo touch /forcefsck then reboot, a file system check should be run during the next bootup.
d) graphics driver issue … but then I’d expect it to happen EVERY boot.

is “Additional Drivers” not offering you any other graphics drivers ? Ans- NO although ATI do offer Linux\drivers for this video card.

sudo touch /forcefsck - found no problems…

a) some kind of weird acpi issue … try adding acpi_osi=Linux as a kernel boot parameter. How do I change the boot parameter?

Disk manager says there are 7 bad sectors on the HD how do I fix them?

a) some kind of weird acpi issue .. try adding acpi_osi=Linux as a kernel boot parameter. How do I change the boot parameter?

OK, the following instructions are for a single boot ONLY … so you’ll have to do this EVERY time you boot … but if it works, we can automate the procedure.
(I’m not automating it now in case it stops your PC from booting, or causes other issues … any problems and a reboot will clear the setting)

Turn ON your laptop, and as soon as your BIOS POST screen disappears, press the SHIFT key and hold it, until you are presented with the GRUB menu … SIMILAR to this:
(you won’t have long to hit the shift key, and the timing can be a little awkward, so it may even be easier to hit AND HOLD the Shift key DURING the BIOS POST … ie. immediately after turning on your PC)

Select the ‘default’ Ubuntu kernel (usually the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:

Press DOWN ARROW until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now you can enter additional kernel boot options… so add the acpi_osi=Linux option instead of nomodeset in the above screenshot … so it now reads:

[b]quiet splash acpi_osi=Linux[/b]
(doesn't matter if it moves down a line, as long as there is a space between splash and nomdeset)

Now hit Ctrl+X to boot.

and test doing this for a few boots to see if it makes any difference.

BTW, if this works, it will only work for a single boot and will need re-applying at the next boot … but if it solves the issue, we’ll make it permanent :slight_smile:

Disk manager says there are 7 bad sectors on the HD how do I fix them?

Disk Manager ? … if you mean Disk Utility …

You can’t … they are damaged … but depending on what EXACTLY Disk Utility is saying, they may already have been marked as not to be written to any more.

The bad news … when a HDD starts getting bad sectors the drive is usually going to get worse.

If you can boot a LiveUSB without issue EVERY time … I’d say the problem is the hard drive.

Changing the line in the boot sequence seems to have solved the issue as has booted 6 times now with no problem. How do we make it permanent?

OK, you need to edit /etc/default/grub … then update GRUB.

First backup /etc/default/grub … just in case:

sudo cp -v /etc/default/grub /etc/default/grub.backup

Now open /etc/default/grub for editing:

sudo gedit /etc/default/grub

Find the line that reads:-


and change it to:-

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_osi=Linux”

visually check the line to make sure it’s correct.

SAVE the file and close gedit.

Back in the terminal run:

sudo update-grub

Done :slight_smile:

I will let you know what happens over the next few days.


Yeh please do, it will be interesting to know if that worked :slight_smile: