D-Link USB wifi will not log in to my wifi networks (SOLVED)

Using mint 19.3 mate.
Have not used the wifi adapter for some time but needed to use the computer away from a cable point.

The USB can see the networks and attempts to connect but the log-in box dose not appear then it times out.
When I check the connections they are grayed out and no alterations are possible.

I booted from a mint 19.3 live USB and the wifi is working normally. noted what software packages were installed on the live USB and checked on my installed mint 19.3 and they seem to be the same.

Any suggestions.

Note - just tried my mobile data USB and that works just fine so it is only a wifi problem.


I believe this works on Ubuntu, but I’m not 100%

Lets start from scratch, and test if the USB is recognised:

you can then scan for wifi APs
you can find the network device from “ip a s” (assumed wlan0 below)
iwlist wlan0 scan

if that all works we can try to setup you network…

let us know…

Hi thanks for your reply…
Everything is working correctly… the wi-fi networks are available it was just not possible to log in to them as they just timed out.

However, this has now been resolved by creating a new network for each of the wi-fi networks and naming them with the correct network name.

Strange but once this was done they connected normally.

ah… sorry for the late reply, but equally glad you managed to resolve it.