Dell 5100cn colour laser printer on network

We’ve had this printer for ages, and had it in the network before, accesible from laptop and desktop, but its stopped working. ::slight_smile:

I’m guessingthat this may be a change of ISP, and the “new” router, but given we have an HP3392 all in one which just works, I am a bit lost as to what has happenned.

I’ve used ifconfig to find the gateway and subnet mask, assigned a fixed IP to the printer, but can’t get it to work on the net. USB still works fine, but, obviously this isn’t as convenient…

Could anyone walk me through this please?


If you open your web browser and go to

then go to

Administration (tab)

and click on “Find New Printers

is anything found ?

Thanks for the reply.

No new printers are found in CUPS on both the wireless connected laptop (P6), or the hardwired desktop running P6. ???

Was the printer turned on, and is it in the same IP range as the PC ?

What’s the IP and subnet of your printer ?

What’s the IP and subnet of your router ?

What’s the IP and subnet of your PC ?

Aye, the printer is turned on ! works fine over USB from the desktop…

IP and subnet of printer:- subnet ( I tried to use the top of the range after reading the FAQ on TalkTalks forum and reserving 240 to 255 out of the DHCP table - it didn’t work )

IP and subnet of router:- subnet

IP and subnet of PC:-

sim@OCC ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr 74:d4:35:e2:9c:85
inet addr: Bcast: Mask:

I can’t even ping the dell!! process just sits there until I ctrl+Z it (!)

I have tried setting the IP to a fixed IP within the Huawei 633 router ( as above ) - no joy, then setting the IP to x.x.1.4 - still no joy, installed snmpwalk, and tried
sim@OCC ~ $ snmpwalk -Cc -v 1 -c public | tee snmpwalk.log
Timeout: No Response from
sim@OCC ~ $

same command directed to the HP’s IP works instantly

So I tried arp, which gives:-

sim@OCC ~ $ arp
Address HWtype HWaddress Flags Mask Iface (incomplete) eth0 ether 08:00:37:2a:96:af CM eth0 <— supposedly the Dell ether 58:7f:66:b1:52:77 C eth0 ← router ether dc:d3:21:aa:7a:1f C eth0 <— ??? ether c4:85:08:e5:43:40 C eth0 <— set top box ether 00:14:38:d1:e9:02 C eth0 <— HP3392
sim@OCC ~ $

The x.x.1.245 was deleted using arp -d - but remains in the list for some reason (?) the MAC address at x.x.1.4 is the Dell’s MAC

I’ve tried reseting the Dell, and more or less every permutation of protocol I can think of - still works fine over USB - would you like a test page ::slight_smile: - i have “several” spares free to a good home!!

lost? you betcha!


Are you SURE you’ve told the Dell Printer not to get its IP via DHCP ?

Well, until you asked the question, I was sure - but now you ask the question, I can see why - resetting the thing will have reset that bit too. Ooops!

I’ll try and get it back to a fixed IP…

Any advice on the next steps please?

Sorry, :-[ and thanks :slight_smile:

If you make SURE the printer is set to have a static IP of I’d expect it would “just work” if that’s that’s the IP it had when you originally set up the printer.

otherwise either give the printer that IP then change the IP to match in the printer profile, or delete the printer profile and reset it up from scratch.

Thanks for the reply. :slight_smile: I expected it to “just” work - and still don’t know why it didn’t. ??? I do wonder if something has happened to the network side of the printer. :frowning: I’ll set a static IP, and try to ping it - once I get that to work, I’ll see if it will play the rest of the game ::slight_smile:

I’ll be back !! :slight_smile:

Have you got one of those routers where you can reserve an IP for a given MAC address, and have you implemented that and forgotten ?