Did I get a virus or the HD is dead?

Thanks for reading!!.I am not good at pc so I beg you to forgive my way of expressing myself on computers.I use 10.04 (lucid) kerne linux 2.6.32-45 generic Gnome.
The problem: The Pc turns up as usually.I see my desk,my docs and and it goes to the net. I am able to surf (i using this pc to write now) but the rest is no responding.NADA.The process line, opening the docs even turning de pc off do no work.The green light of the HD is no flicking so the hd is no spinning.
What shall I do?.There is no safe mode as in windows as I read somewhere.Thanks in advance for your time and patient.Anette

Hi anette, and welcome to the forum :slight_smile:

When you boot your PC to the desktop are you able to open a terminal (Ctrl+Alt+T) ?

Thanks for your reply.Yes,I can open the terminal using Ctr+alt+T.Anette

Open a terminal and run:

sudo touch /forcefsck

You willl be prompted for your password, but when you enter it nothing will be echoed to screen (not even ******) but the password is going in, so just type the password and hit enter.

Once you’ve done that … REBOOT.

During booting, the system should run a file system check.

Let us know if this corrected the issue or not.

Nothing happened.Tried several times.Anette

OK … Can you list what doesn’t work.

The PC starts as usually.It shows the docs and folders I have on my desk.It connects to the web and I can surf.And that,s all!!.
The command line where the icon (batteries,skype,net,on and off bottom) and the docs on the desk are no responding.Neither do programs,system,firefox and help icons. I can see them but they do not respond to anything.Nada.
The command lines on firefox don’t work so every time that I surf i have to open a new bowser.(book marks works). There`s no noise or funny klicking from the HD.It looks like I have been looked out from the the pc.
Using skype,I can chat but no use the “phone”.
Is there anything you would like me to check?. Thaks Mark.Anette

You could look in Disk Utilities SMART data fro your hard drive to see if there are any errors … you can start Disk Utility from the terminal (Ctrl+ALt+T) by running:


But I’m more inclined to think this is a user config issue in your home directory somewhere … can you add a new user account, and test if everything works in there.

To add a new user account …

Open a terminal and run:


In the window that appears, hit the Add button (you wil be prompted for your password) … in the next Window, give the Account a name and username, then click OK … in the next window, set a password by hand but DO NOT tick “don’t ask for password at login”, click OK.

Back in the original “Users Settings” window … click Change next to “Account Type”, and change it to Administrator.

Now close “Users Settings” … and log off … you should be offered the new account at the login screen, log on as the new user and tell me if everything works in that account.

There is another option, it is possible that the filesystem had errors, and went into read-only state because of it.
You could test it it in Terminal (Ctrl+ALt+T) (and post the output):

touch foo.txt

If that gives a response like
touch: cannot touch `foo.txt’: Read-only file system
then it is confirmed.

I did as you wrote :I created a new account, and after several on and off I could log on as a new administrator.I created a new doc and I was able to save on my desk.
How can I recover all my docs,videos and folder created under my old account? Is it possible?
Can I access to skype from my new account?.I don`t see the icon on the process line.

Hello SeZo,
Thanks for your time.
I did as you wrote but nothing happened after writing the command. It just asking me to write again.
Should the terminal “answer” something else?.

Should the terminal "answer" something else?.

No, if the command run successfully, then nothing would have been returned.

However just to make certain that in fact it created the “foo.txt” file in your home directory:

ls | grep .txt

That would be lowercase L

On the other hand , as Mark intimated, it might be a permission problem on your account.
to check what groups you belong to (on both accounts) type in the terminal:


This shold return the list of groups you belong to.

Also you could try to start a fresh with say Firefox, by renaming the .mozilla directory in your home folder
(it will be re created automatically when firefox starts up)

mv ~/.mozilla ~/.mozilla.back

Restart Firefox and see if you can use it properly.

Isn’t Skype in the menus ?

Can you open a terminal and send the output from:

ls /home

so I can see what your user accounts are called … can you also indicate which is the old account and which is the new account.

the terminal shows :

gustavo59@Gus-laptop:~$ ls | grep .txt
gustavo59@Gus-laptop:~$ groups
gustavo59 adm dialout fax cdrom floppy tape dip video plugdev fuse lpadmin admin sambashare

I have not tried firefox “trick” yet.

gustavo59@Gus-laptop:~$ ls /home
gustavo59 hanne

hanne: it is the old one
gustavo59: it is the new one

Yes, skype is on the application panel.
What I ment, it was how I could use Skype from my “old account” because I had tanked some money for connecting to land lines. I guess I have to tank again on my new one.
Thanks. Anette

As far as I’m aware if you log into Skype using the old username and password, any money you’ve paid should still be there.

If not, let me know and we’ll try moving the old .Skype directory to the new account and see what happens.

Firefox bookmarks etc.

Whilst logged onto the gustavo59 account and with Firefox CLOSED, open a terminal (Ctrl+Alt+T) and run:

mv -v ~/.mozilla ~/.mozilla-old


cp -vr /home/hanne/.mozilla ~/.mozilla

Now open Firefox … are al your bookmarks etc. now in the new account ?

To copy any other documents etc. … it will probably be easier to copy these through the file manager (nautilus)

Open a terminal and run:

nautilus /home/hanne

A file manager window will open in the OLD home directory … copy whatever you want from there to the new home directory … but ONLY from the Documents, Downloads, Music, Video, etc. directories … in other words DO NOT copy anything (file or folder) that starts with a “.”

Can you also whilst logged onto the new gustavo59 account, send the output from:


so I can check the new account is in the sudo group.


Here is the terminal to firefox :

gustavo59@Gus-laptop:~$ mv -v ~/.mozilla ~/.mozilla-old
‘/home/gustavo59/.mozilla’ → ‘/home/gustavo59/.mozilla-old/.mozilla’
gustavo59@Gus-laptop:~$ cp -vr /home/hanne/.mozilla ~/.mozilla
‘/home/hanne/.mozilla’ → ‘/home/gustavo59/.mozilla’
cp: kan ikke tilgå ‘/home/hanne/.mozilla’: Adgang nægtet ( DENIED LOG IN)

It has NOT been allowed.

Here is the terminal to groups:

gustavo59@Gus-laptop:~$ groups
gustavo59 adm dialout fax cdrom floppy tape dip video plugdev fuse lpadmin admin sambashare

About skype,it worked fine. I could log with my username and pasword and everything was there.

When the pc is turn on, what shall I do to log onto my new account (gustavo59)?
Wil be okay to delete the old account once I copy all my data in the new directory?
Many thanks Mark

OK, first you need to add the gustavo59 account to the sudo group …

Log into the old account (hanne), open a terminal (Ctrl+Alt+T) and run:

sudo usermod -aG sudo gustavo59

Then log off, and log back on as gustavo59 … now (WITH FIREFOX CLOSED) run:

mv -v /home/gustavo59/.mozilla /home/gustavo59/.mozilla-old2


sudo cp -vr /home/hanne/.mozilla /home/gustavo59/.mozilla


sudo chown -R gustavo59:gustavo59 /home/gustavo59/.mozilla

Now check if Firefox has your bookmarks etc.

When the pc is turn on, what shall I do to log onto my new account (gustavo59)?

Why … does it automatically log you into the hanne account ?

Wil be okay to delete the old account once I copy all my data in the new directory?

YES … but DO NOT delete it until you’re 100% SURE that the gustavo59 account is a member of the sudo group

Here’s 2 way to check gustavo59 is a member of the sudo group:-

  1. run:
groups gustavo59

is sudo in the list ?

  1. Whilst logged on as gustavo59 … open a terminal and run:
sudo gedit /opt/sudo-test.txt

SAVE that file and run:

nautilus /opt

is there a file called sudo-test.txt in the file manager that just opened ?

Thanks Mark,
Before proceeding on to the next step, I tried to copy the docs and folder onto a extern HD. Coping the docs was pain free but i was not able to copy the folders with small videos (very shorts). Neither could be copied one at the time.The message is: “there is no enough place on the disk. (which is no true and i tried 2 hd to be sure)”.
Another thing that I encounter it was that the system did not react as it happened when i logged onto using my old account name. I had to reboot several times.
How do I solve the problem with the folders?.
Thanks Mark and have a nice week end.Anette

Note: i tried to post this message and the pc hanged again