Disgruntled, and ranting about the evil Jockey...

Well, I have to admit, for the time being, I’ve given up. Installed ubuntu 11.04 on my acer aspire 5732z. The first problem was the black screen (sorted), the second was the backlight (sorted) now, the whole thing seems to freeze on when the system tries to go idle (can be disabled in power management settings…).
All are noted bugs in launchpad.
Also slightly worried as things seem to running quite hot, and I’m bothered that ACPI might not be allowing correct (if any) control of fans? Anyway, apart from that, things seem quite sweet, and Unity is nowhere near as ugly as some say…

Then updated to xubuntu on my wife’s ancient laptop. This was less painful, although there seems to be an acknowledged bug on there:- system doesn’t shut down from the indicator applet, it just logs out. You can then shut down from login screen. Hardly a deal-breaker, and everything very nice there.

So, having got things stable, I decide to upgrade main work computer from 10.10. I do a lot of work in blender, the Gimp etc. and develop 3d applications (using JMonkeyengine). A decent 3d card is a must. The upgrade appeared to go well, until I realised there were driver issues. To cut a long story short, there seems to be a problem with Nvidia drivers. Jockey loads them, but doesn’t use them. No amount of persuasion, change of drivers, use of ppa etc seems to work. I have now wasted the best part of 2 days trying to sort this out to no avail, and I am not alone.
3 machines using 11.04, 3 sets of problems. Horrible when 10.10 was such a wonderful system.
For the main pc I am about to defect to Fedora, I think. Does anyone have any ideas RE fan control on Acer aspire 5732z?
Glad I’ve got that off my chest…

“Google” for lm-sensors, fancontrol, and pwmconfig


A couple of places to start:



Disclosure -
So far (touch wood) I’ve not had to configure the fan speeds myself, and as it can be dangerous, I don’t really want to attempt a walkthrough… but if you have any questions, I’ll try help

Thanks for the reply. I’m looking into it now, but so far lm-sensors gives no reference whatsoever to fans. I shall (with heart in mouth) try to increase the divisor as per the archlinux.org thread. Both cores appear to be running around 50 degrees, which strikes me as a little hot even for a laptop (if it was my PC I’d be rushing off to buy bigger better fans!).
I appreciate the help. It’s been a long day, spent messing around (to no avail over the nvidia drivers…), so I think I may get somewhere with this.
My worry is that the only way around the pesky screen function on this machine was to edit /etc/default/grub as follows

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_osi=Linux acpi_backlight=legacy”

I was wondering if tinkering with acpi may have affected the fan control?

Thanks again for the advice

Have you tried the patched kernel and gnome-power-manager from this PPA ?
(Maverick and Natty versions available)

See post #39 here:

Thanks for that! I am trying the kernel now. certainly had a bit of action from the fans, so I think we may get away with it. The temperature of both cores no longer seems (yet) to exceed 40 degrees, so I can live with that. It seems natty stays on this laptop! A good thing really, because I am getting on with unity…

Going back to my first post, I’ve found no workarounds(and boy have I been looking) for the nvidia driver issue on my pc, and unfortunately, no 3d acceleration on that machine is not a possibility. Many people seem to having the same problem- it’s turning into a bulky launchpad thread.

Before going back to (a very reliable) 10.10, I decided to have a play with Fedora 15, and get a look at Gnome 3. I’ve found it very stable (so far, and not to be released until the end of the week, that is quite an achievement) very simple to set up, and very hardware friendly. You can’t help but notice striking similarities between unity and gnome 3 though. In fact, they are remarkably similar. I can also confirm that on this distro gnome 3 does default to a rather bare and clunky (but usable) 2d desktop until the 3d card is installed.

Anyway, thanks for your help again!

Can you give me a link to the launchpad thread you are referring to, and what GFX card are we talking about ?

Sure can! https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/771788
My card is a GT450, but there seem to be many others suffering the problem. In my case, I could get into the unity desktop, which worked, but was sluggish. Anything requiring the slightest acceleration was hideously slow, but curiously glxgears reported a pretty good framerate (although it looked terrible). Additional drivers reported Nvidia drivers as being activated but not in use. no amount of uninstalling, installing from ppa, or compiling from source of nvidia drivers made the slightest difference. An odd problem to say the least.
Hell, it gave me a chance to try Fedora…

You’ve probably already gone through this but just in case, is there anything in the /var/log/Xorg.0.log or /var/log/jockey.log that gives you a clue what’s happening ?

and does lsmod show the nvidia driver as loaded ?

bear in mind, I’m miles behind you on researching this issue but I see what you mean about it affecting a LOT of people… it’s all over the web, I’m kind of glad I’m still on 10.10 :o

lsmod showed the driver as loaded. I checked the logs to no avail I’m afraid. It’s my own fault, really. I waited till I’d got 11.04 working relatively well on the laptop (bar the fan issue, now sorted!!), and thought the time was right to upgrade the workhorse. Stupid me!! I couldn’t afford to wait too long for workarounds and leave it out of action, so I had to make a hard and fast decision - downgrade (which felt a waste of time!) or change distro. At least until I’m sure things are settled. As you pointed out in another thread, I don’t think 11.04 is quite ready yet. It feels rushed.
It’s a shame though as I don’t dislike the changes in unity, or the direction it’s taking.

Ahh… so you no longer have the issue, as you’ve changed distro ?

On that machine yes.

I kinda feel stupid having asked for info then :wink:

I don’t like giving up like that, but the issue had soaked up too much work time. If it had been another machine in the house, I would have hung on to see what could be done, as that obviously helps the community improve the end product. Yes I do feel a bit guilty :-[ I certainly don’t want to waste your time either with all the work you do on here…

Heh… thanks, but it’s impossible to waste my time, I enjoy getting my teeth into a problem too much, but also agree on a workhorse you’d have to move on.

It will be interesting to find out what’s causing it… at the very least I’m aware of it now so can keep an eye out for a working fix… I have no doubt it will raise its head on here again some time :slight_smile:

So thanks for the heads up :slight_smile: