downloading peppermint

trying to download as your instructions, but hit a problem.
downloaded the iso, which went automaticaly to temp internet files,
downloaded pendrive
chose peppermint two
on the step 2 could not ‘point’ to iso, trie to highlight in temp files but could not get it on step 2.
then i sent iso to my documents and tried again,
then on line 2 it said c;\documents and settings\user\my documents\peppermint-two etc
selected flash drive drive letter. formatted

on downloading get message below
7-zip; diagnostic message
0 casper\filesystem.squashfs
1 te system cannt find the file specified
at the same time a windows pop up saying windows- delayed writer failed

then while i’m typing this on my aa1 a box poped up on the aa1 saying ‘pepprmint two-i386-06052011.iso.xarchiver 0 4.9svn-r’ operation complete
this is now confusing me,

do you think my xp m/c is at fault or am i doing something wrong

while i'm typing this on my aa1 a box poped up on the aa1 saying 'pepprmint two-i386-06052011.iso.xarchiver 0 4.9svn-r' operation complete

That looks like you’ve downloaded it on your AA1, and it is attempting to open it in Xarchiver, rather than save it.

if you want to download the ISO image in Firefox (Linpus or Windows), right-click this link:
and select “Save Link As” then tell it where you want it saved.
(In internet Explorer, I think it’s “Save File as”, or just “Save As”, or similar)

Once you have the Peppermint-Two-i386-06052011.iso file on your Windows PC, it might be a good idea to check the files MD5 checksum.

To do this, download this (free) application to the windows PC
unzip it, and use it to generate the MD5 hash for the Peppermint-Two-i386-06052011.iso file.

Help page for the MD5 application can be found here:

It should be:

If it is anything else, the download is corrupt

If it is EXACTLY as posted, go ahead and try to write it to your USB stick.

thanks for the reply
i will try the windows thing tomorrow,
btw my windows m/c has internet explorer (dont use it often) not firefox

i’ve just downloaded to the aa1 and saved it to downloads but don’t know what to do with it now, its asking for an application to open it, ??

determined to succeed

copy the ISO image to a USB stick and transfer it to the Windows PC … once it’s on the Windows PC, try using Universal USB Creator to write it to the USB stick as a LiveUSB.

Effectively you need to get the Peppermint-Two-i386-06052011.iso file onto your Windows PC … then point Universal USB Creator to extract and write it to a USB stick.

Or have you got an Ubuntu PC ?

thanks for the reply
its starting to make sense
sorry for appearing to be a noddy
havn’t a ubuntu pc but hoping after installing peppermint on the aa1 going to look at a linux distro on the pc
getting late now for me so will try everything tomorrow
will let you know how i get on

No problem … and as you say, let me know how you get on :slight_smile:

will have to leave it untill the w/e and do it on my sons laptop,

my windows pc doesn’t seem to like linux and keeps doing strange things,when trying to download to the stick it keeps saying its full, when i check, it its empty, also the pc keeps freezing, something it never does,
a while ago when trying to download the recovery disc to a stick it would not do it, but worked 1st time on my sons laptop,
so going to do it sunday when he come around
let you know how i get on.

Very strange, but then we are talking about Windows :wink:

still having problems,
tried to download on sons 2 laptops running xp professional and windowa 7
downloads iso image ok
on usb pendrive when trying the download comes up with not enough space even though both sticks are empty,
my son who is an it tech cannot come up with anything,
the usb installer is version, differant to yours, don’t know if this is a reason

Are you creating the USB stick to INSTALL PeppermintOS, or to test drive it ?

Are you allowing Universal USB Installer to format the USB stick ?

What capacity is your USB stick ?

Is this a SanDisk U3 USB stick, by any chance ? ← these can be a pain because they present themselves to the system as both an emulated CD and a USB mass storage device at the same time … the partition that contains the emulated CD image cannot be written to, so would probably say it is “full” or “write protected” or similar.

Have you tried formatting the USB stick in Windows (as FAT32) ?

I’ve uploaded Universal USB Installer to my dropbox … link here:
see if that helps.

If that doesn’t work, you could try using something else to put PeppermintOS on the USB stick, such as Unetbootin:

Just select DiskImage as in the second pic on that page, and point it at the Peppermint ISO image you have already downloaded.

Unetbootin will create an INSTALLATION LiveUSB, but it will NOT make it persistent … so it will behave like a LiveCD … fine for installation, but changes CANNOT be saved to the USB stick, so less useful for test driving … if you get my meaning.

Another LiveUSB creator you could try would be Live USB Creator:

Not 100% sure this supports PeppermintOS (Two) though.

just used the linuxlive usb and have a live stick
mine was a sandisk cruser 4 gig reformated to fat 32
dont know what my sons was but original probs were on all, looks to me like the prob was with the universal pendrive creater
will try a test dive b4 an install after ive said goodby to my son and family
so it looks like a BIG thanks
if this works ok next will be a try on ubuntu on my desktop

Glad you’ve got it sorted :slight_smile:

Be Aware - If you used Linux Live USB Creator it probably didn’t include a persistence file, so though you’ll still be able to take it for a test drive, you WON’T be able to save any changes you make … ie. any changes, such as adding your wireless key will be lost the next time you reboot.

And remember what I said about not judging the speed of Peppermint based on how it runs from the USB stick … it will be quite a bit slower running from a USB stick than it will be once installed :slight_smile:

Also be aware that running multiple applications from the USB stick will cause major slowdown, as there is no swap space, and the OS as well as the applications are having to be loaded into RAM, which the AA1 is short of … this is NOT the case once it is installed.

So only treat the USB test drive as a way to check the “look and feel” of PeppermintOS and not its performance.

it did include a persistence file and i know the speed will be slow but its one step at a time and making sure i’ve got all my passwords etc for when i install.

Cool … I thought I spotted on their site that it only supported PeppermintOS (One and Ice) and didn’t do persistence … but all the better if it does, and handy to know :slight_smile:

YEAH installed
again a big thanks
going back to your tutorial to install the other things, then i will let you what i think. looking good so far

Hope it all goes/went well, but any problems … you know where to come :wink:

I’d be VERY surprised if you don’t prefer it to Linpus … but let me know.


I’ve edited the first part of the PeppermintOS tutorial to reflect your problems with the newer version of Universal USB Installer:

much better than linpus lite,
impressed with the speed very quick
thoroughly recommend to any one thinking of changing, anyone used to windows will find it very easy,
Your tutorial Mark was so easy to follow
even my son was impressed you came back with a solution to the usb problems so quick,
so again a big thanks
and next an install of ubunto onto my desktop pc, so be ready for a barrage of questions,

Glad you like it … IMHO, PeppermintOS makes Linpus look silly, and is SO much easier to use.

Also glad to hear the tutorial was helpful :slight_smile:

even my son was impressed you came back with a solution to the usb problems so quick,

Heh … well this is the Linux community :wink:

Good luck with Ubuntu on your desktop, and if you have any problems let us know and we’ll see if we can help … that’s what we’re here for.


did the automatic login from your tutorial, works perfect,
but i still have to

enter password for keyring ‘default’ to unlock.

an application wants access to the keyring default but it is locked

any ideas how i can do this automatically



Open NetworkManager and delete your wireless connection.

then set up your wireless connection again … if at ANY time (whilst setting up the wireless connection again) it asks for a “keyring” password … leave it blank … it will complain about “unsafe storage”, but accept it anyway.