draft sight and peppermint 6 (Solved)

Hi Mark,
I have a Toshiba Satellite 350-17P laptop, 64 bit running Windows 7 that I want to dual boot with Peppermint 6.
I have successfully installed Peppermint alongside win7 and am happy with that so far.
I now want to install DraftSight in Peppermint and started to install from a previous thread I made concerning this but it is not going well.
When I run the first command I get this
jack@jack ~ $ sudo apt install libaudio2:i386 libxt6:i386 libgtk2.0-0:i386 lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6 libgl1-mesa-glx:i386 libglu1-mesa:i386
[sudo] password for jack:
Reading package lists… Done
Building dependency tree
Reading state information… Done
libaudio2:i386 is already the newest version.
libaudio2:i386 set to manually installed.
libxt6:i386 is already the newest version.
libxt6:i386 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4)
Recommends: libgl1-mesa-dri:i386 (>= 7.2)
E: Unable to correct problems, you have held broken packages.
jack@jack ~ $
Can you help me here please

Is your Peppermint install 32 or 64 bit?
Draftsight dropped the 32 bit version late last year, now ONLY supports 64 bit.
If it is 64 bit then just install the latest .deb from Draftsight with Gdebi. You should not need the 32 bit (i386) libraries to run it.

What’s the output from:

uname -a

Hi Mark,
I get this from the command
jack@jack ~ $ uname -a
Linux jack 3.16.0-45-generic #60~14.04.1-Ubuntu SMP Fri Jul 24 21:16:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
jack@jack ~ $

I think I know what is wrong, but I will await your reply before doing anything.
@ SeZo I tried putting a 32 bit AutoCAD 2012 on the Windows 7 partition and it refused to load and demanded a 64 bit version.
I thought a 64 bit OS would run 32 or 64 bit progs ?

If this is 64bit Draftsight, why are you trying to load 32bit dependencies ? … where did you get the .deb ?

Sorry Mark :-[,
I have the correct deb package and it has been installed. I will register my address in the morning on the site.
I have been working on this dual boot machine and my brain is being frazzled.
Thanks for the help