dual booting peppermint 8 Linux with windows10 on an Acer ES15 (SOLVED)

I downloaded peppermint 8 x 64 bit using rufus for the iso to copy a to thumb drive. Inserted thumb drive to an acer es 15,4gb memory,1terabyte hdd.
changed the boot order. Tried peppermint 8 and liked it. Decided to try and install it along side windows 10. Let the installer do its own routine on installation noticed it split the 1 terabyte c: approximately 500 gb for windows and 400 gb for peppermint. After installation I rebooted the laptop AND FORGOT TO REMOVE THE THUMB DRIVE?
The laptop boots straight to windows 10. I cannot find linux anywhere on the laptop or the grub boot loader. I went into the eufi settings yesterday to have a look but after rebooting from the advanced options in recovery to access the bios/eufi screen when i was presented with the bios/eufi screen none of the keyboard keys worked. I could see the boot option along the top of the screen but could not access it. I noticed in windows that the c: appears to have been split in disk management approx. 500 gb and 400 gb. I may be little bit out of my depth with this, although I dual booted this asus eeepc win 7 with peppermint 8 x32 bit ok. After 45 years with windows this linux learner is leaning to linux. I did notice a post earlier about dual booting unfortunately a little to late for me.
Any advice at all would be gratefully accepted. I’m a bit concerned I may mess this laptop up. Although I’ve got an acer 4920 that needs a cmos battery but that’s another story. Yous sincerely normanliddle

Are you able to boot the Peppermint 8 64bit LiveUSB still ?

Yes Mark the usb drive still works OK and I’ve used it to try peppermint 8 again successfully,and still have the option to install peppermint 8 again
from the desk top. My problem is I’m not sure where to go from here?
Yours sincerely normanliddle

Sorry Norman but i’m not 100% sure what the issue is here ? … are you saying you’ve installed Peppermint but it’s still just booting directly into Windows without ever offering you Peppermint ?

If so, can you boot to the Pepperrmint LiveUSB, open a terminal, then post the output from these commands:

sudo fdisk -l


sudo blkid

Thanks for your feedback Mark. I’ll try that tomorrow and get back to you. Apologies for being a pain I don’t know whether peppermint is installed
or not? It just boots to windows without offering peppermint. I do know trying to install peppermint split the hdd.
Yours sincerely normanliddle

peppermint@peppermint ~ $ sudo fdisk -l
Disk /dev/loop0: 1.2 GiB, 1257021440 bytes, 2455120 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 8AA8B3A0-E90C-44E7-AB21-454AB275186C

Device Start End Sectors Size Type
/dev/sda1 2048 206847 204800 100M EFI System
/dev/sda2 206848 239615 32768 16M Microsoft reserved
/dev/sda3 239616 1040195157 1039955542 495.9G Microsoft basic data
/dev/sda4 1951426560 1953523711 2097152 1G Windows recovery environment
/dev/sda5 1040195584 1943199743 903004160 430.6G Linux filesystem
/dev/sda6 1943199744 1951426559 8226816 3.9G Linux swap

Partition table entries are not in disk order.

Disk /dev/sdb: 3.8 GiB, 4025810432 bytes, 7862911 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x37d71b0e
sorry for the delay Mark hope this is of help?

/dev/sda1: LABEL=“ESP” UUID=“9E99-E13D” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“b59d2b94-1a6a-466a-968f-dfe8b4f0022b”
/dev/sda3: LABEL=“Acer” UUID=“CC3A9AE93A9ACFB6” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“6681c8ed-a1ff-4afd-9549-995cc2dd6047”
/dev/sda4: LABEL=“Recovery” UUID=“5CFE9C78FE9C4BE0” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“2a7e8473-7add-4c43-87e3-8c0fea9bd331”
/dev/sda5: UUID=“197757c3-3eee-4469-bc84-4e8bd43ed978” TYPE=“ext4” PARTUUID=“f560ae64-de8b-46b9-af06-91bc9a4821e2”
/dev/sdb1: LABEL=“PEPPERMINT” UUID=“6C8F-1F63” TYPE=“vfat” PARTUUID=“37d71b0e-01”
/dev/loop0: TYPE=“squashfs”
/dev/sda2: PARTLABEL=“Microsoft reserved partition” PARTUUID=“023226f8-e179-485f-b47f-5e779174c147”
/dev/sda6: UUID=“67fe107d-b92b-42a5-857e-40780295b24a” TYPE=“swap” PARTUUID=“7aeb81b7-f5e3-4118-956f-533fb4973d6e”
/dev/zram0: UUID=“0f7bca68-dfd0-422e-9629-9e2ac5588b93” TYPE=“swap”
/dev/zram1: UUID=“a6a4ac53-b7e2-4a4e-b021-200b36e44b94” TYPE=“swap”
peppermint@peppermint ~ $ ^C
hope this is of use to you Mark.Yours

Your Peppermint has been installed onto /dev/sda5
It is possible that you might have installed the grub boot loader onto the wrong partition.

Thank you for your reply. I really have not got a clue as to how to proceed from here? Is it possible to rerun the installation from the thumb drive?
Although the same thing may happen again? I’m not very confident messing about with partitions although I’ll have to start some time.
yours sincerely, normanliddle

Can you boot to the Peppermint LiveUSB … open a terminal … and run this command

efibootmgr -v

and post back here what is returned in the terminal

peppermint@peppermint ~ $ efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 2001,0001,2002,2003
Boot0000* ubuntu HD(1,GPT,b59d2b94-1a6a-466a-968f-dfe8b4f0022b,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Windows Boot Manager HD(1,GPT,b59d2b94-1a6a-466a-968f-dfe8b4f0022b,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}…
Boot0002* USB HDD: SanDisk Cruzer Micro PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(3,0)/HD(1,MBR,0x14,0x800,0x77f27f)RC
Boot0003* Unknown Device: HD(1,GPT,b59d2b94-1a6a-466a-968f-dfe8b4f0022b,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot2001* EFI USB Device RC
Boot2003* EFI Network RC
Thanks for you patience Mark, unfortunately I’m in and out of bed on a daily basis at the moment due to illness. Yours sincerely, norman liddle.

What make and model of PC are we talking about here ?

It looks like Peppermint was installed, but not added to the UEFI boot manager sequence.

I there an option to select “ubuntu” at the boot selection screen ?

Thanks for your prompt reply Mark. The machine is: Acer laptop ES1-715-P1VN, ALSO described as Aspire ES 15. When the thumb drive is not inserted
the laptop boots straight to windows 10, No option to boot into ubuntu. When the thumbdrive is inserted it boots to the demo/guest version of peppermint
8 (which I am using to send you the details that you are asking for ?)
Again thanks for all your help. Yours sincerely, normanliddle

Immediately after turning on the PC (kinda when the Acer Logo displays) hit the F12 key.

You should be presented with the the boot selection screen.

Can you tell us what is displayed ?

Hello Mark, I hit f12 on boot up and this was displayed: choose an operating system, Windows 10, or Macrium Reflect System Recovery, or Change defaults or
choose another option. I went all the options displayed which was basically choose another windows operating system. No mention of Ubuntu or peppermint.
I could not cut and paste as I have previously. Yours norman liddle

Boot to the Peppermint LiveUSB, open a terminal and run:

sudo efibootmgr -o 2001,0001,0000,2002,2003

Now REBOOT but be ready to hit F12 to enter the boot device selection screen.

Is “ubuntu” listed now ?

If so, what happens if you select it ?

Thanks for your reply Mark, ran your commands in the terminal, after hitting Enter the response was: Boot entry 0000 does not exist? Ran with it any way
but still booting straight to WINDOWS with no mention of Ubuntu? Any help is appreciated. Yours Norman

Okay, do you know how to boot the Peppermint LiveUSB in UEFI mode ?

No Mark I don’t. But I’m open to any advice from you. Yours norman.

Okay, when you boot the Peppermint 8 64bit LiveUSB, do you see the GRUB menu … or do you see this: