DVD drawer won't open [Solved - embarrassingly!]

Following a hard disc drive crash, I fitted a new HDD (with the help of the forum) and installed Ubuntu V12 – the DVD worked faultlessly.
Now when I come to use the DVD the drawer will not open. When I press the “Open” button, I can see through the drawer gap a light flashing in response. It stops flashing when I press it again.
Searching the web suggested a couple of commands to see if the system recognises the drive, and I attach the results of two terminal commands:
grep “CD-ROM” /var/log/dmesg
sudo lshw -C disk

To my untutored eye, all seems well – but the device remains obdurate. Any ideas, anyone?

Is there a disk in the drive ?

what happens if you run:



eject sr0


eject /dev/sr0


eject cdrom


eject /dev/cdrom

is there a tiny pin hole in the drive for manual tray opening ?

No, there is no disc in the drive.
None of your suggested commands had any effect.
I had already looked for a pinhole, but no such luck!

To my untutored eye, all seems well – but the device remains obdurate. Any ideas, anyone?

Not quite, this line indicates (fromt the output of lshw -C disk):

*-cdrom description: DVD-RAM writer -------------------------------------------- configuration: ansiversion=5 status=open

that the system thinks the tray is open (when in fact it is the opposite)

Try running the following:

eject -vT /dev/sr0

With this option the drive is given a CD-ROM tray close command if it’s opened, and a CD-ROM tray eject command if it’s closed.

Here is the output:

keith@desktop-1:~$ eject -vT /dev/sr0
eject: device name is /dev/sr0' eject: expanded name is /dev/sr0’
eject: /dev/sr0' is not mounted eject: /dev/sr0’ is not a mount point
eject: `/dev/sr0’ is not a multipartition device
eject: toggling tray

Sadly, the drawer remains closed.

Sadly, the drawer remains closed.
Running that command once would have closed the draw if it thinks it is open, but running it again would have toggled it

You could try (just in case it is locked) to unlock the drive:

eject -i0 /dev/sr0

Then try to manually eject the tray with the physical eject button

I ran the command again but no success. Then:
keith@desktop-1:~$ eject -i0 /dev/sr0
CD-Drive may be ejected with device button

Unfortunately the device button still does not operate the draw.
Perhaps it’s time to check connections inside the machine.

What happens if you turn on your PC and immediately hit and hold the shift key till the GRUB menu is displayed … then whilst at the GRUB menu hit the optical drives eject button ?
(if that doesn’t work … it’s a hardware fault, as the OS isn’t even loaded yet)

Null response!
Ah, me! More expense. I’ve been thinking about buying a laptop - perhaps this is the time…
Thank you all for trying to help. I’m sorry it didn’t work out, but I’ve learnt many new commands to add to my armoury.

You could just get an external USB DVD from ebay for a tenner :wink: … cheaper than a new laptop :slight_smile:


Here’s the external USB DVD-ROM I bought for my Aspire One netbook (£8.90 including postage):

They also do an external USB DVD-RW (£12.90 including postage):

Thanks Mark - they look like a good bet and I’ll order one of those for my immediate need to read some technical manuals just arrived on CD!
In the medium term, though, I am tired of desktops for all sorts of reasons and have enjoyed playing with laptops belonging to friends whom I’ve converted to Ubuntu. I shall need some technical advice on that subject so expect some posts in the near future.
My thanks again, as usual.

Didn’t realise this was a desktop … you may be able to find a cheaper internal drive then.

But the externals are always handy to have for other devices :slight_smile:

I personally would take the DVD drive out of the slot, with it still plugged in, and check to see if it’s opening and closing properly. It might just be there isn’t enough clearence, especially if you can see through the gap! ???

Actually as it’s a desktop internal drive … and there’s nothing to loose … I’d be tempted to take the drive out and get brutal with it :slight_smile:

Being brutal by nature, I did so before logging on to the Forum and seeing your suggestion and … found a loose connection!
How embarrassing is that?! :-[
But your time (and that of other contributors) has not been wasted as I’ve learnt several new tricks.
Speaking of disk drives, I have a floppy problem… but that’s another story.
My grateful thanks to to everyone for your combined advice.

Great … problem solved :slight_smile:

See, it’s not always the software. :wink:

Great you solved your problem though.

Your right! And I try so hard to check thoroughly before troubling the Forum.
But it’s all good learning experience, and I’m grateful for your advice.
But don’t go just yet - I have more questions on other topics!