E122 Dongle please help

Right here goes I’m new to Linux well and truly so I know nothing.

My problem is I’m trying to get my dongle to work with it, with no success. The dongle is on 3 and is a Huawei E122 and im running Absolute Linux which i believe is slackware

Many Thanks

I know nothing about Absolute Linux, but try this… is wvdial installed?.. if not, install it… then (with the dongle plugged into a USB port) in a terminal, type :

sudo wvdialconf

Hit enter, and see if it detects your modem… you should get an output similar to this:

Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan< *1>: S0 S1 S2 S3
ttyUSB0: Device or resource busy
Modem Port Scan< *1>: USB0
WvModem< *1>: Cannot get information for serial port.
ttyUSB1< *1>: ATQ0 V1 E1 – OK
ttyUSB1< *1>: ATQ0 V1 E1 Z – OK
ttyUSB1< *1>: ATQ0 V1 E1 S0=0 – OK
ttyUSB1< *1>: ATQ0 V1 E1 S0=0 &C1 – OK
ttyUSB1< *1>: ATQ0 V1 E1 S0=0 &C1 &D2 – OK
ttyUSB1< *1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 – OK
ttyUSB1< *1>: Modem Identifier: ATI – Manufacturer: huawei
ttyUSB1< *1>: Speed 9600: AT – OK
ttyUSB1< *1>: Max speed is 9600; that should be safe.
ttyUSB1< *1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 – OK

Found a modem on /dev/ttyUSB1.
Modem configuration written to /etc/wvdial.conf.
ttyUSB1: Speed 9600; init “ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0”

The Bold bit is what we are after (/dev/ttyUSB1)

If it isn’t discovered as a modem get back to me, and I’ll let you know what to do

Now as root, edit /etc/wvdial.conf so that it reads:

[Dialer Defaults] Init1 = ATZ Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 Stupid Mode = 1 Modem Type = Analog Modem ISDN = 0 Phone = *99# Username = three Password = three Modem = /dev/ttyUSB1 Dial Command = ATDT Baud = 9600

[Dialer three]
Init2 = ATZ
Init3 = ATE0 V1 &D2 &C1 S0=0 +IFC=2,2
Init5 = AT+CGDCONT=1,“IP”,“3internet”
ISDN = 0
Modem = /dev/ttyUSB1
Modem Type = Analog Modem
Baud = 460800

Then to connect… from a terminal:

sudo wvdial three

Hit enter.
Ctrl+C will close the connection.

if the bit in bold writing during detection reads something other than /dev/ttyUSB1, change both the Modem = lines in wvdial.conf to reflect this.

Or find out which PPP dialer applications are available in Absolute Linux (gnome-ppp, pupdial, kppp, ppp-go, pppsetup etc.) and configure it from there with the above settings.

Or if you want to have a go at installing the gnome network manager in slackware, see here:

If you’re prepared to switch distro’s, Gnome’s network manager contains most of what you need … for example if you install Ubuntu it will automatically install drivers for a number of the Huawei models, the most you need to do to get a 3G connection in this instance is enter PIN number for your SIM card. If you’re unlucky and your device isn’t automatically supported it gets more complex, but I run a HUAWEI E220 and I’ve been able to just ‘plug and go’ with in since version 9.04.

Okay thanks guys I’m going to give this ago and get back to you, I was considering changing distros, I remember about a year ago i thought I’d try to get into linux and installed Suse i believe that used the Gnome framework.

As i said ill get back to you

OpenSUSE by default now uses KDE (4) desktop, which drove me up the wall, although maybe KDE4 has become more stable since then… that was 11.2… desktop icons kept going missing (easily solved), and hplip system tray applet was trying to load before the system tray was loaded at boot time, so dropped out with an error which left me unable to print… never did solve that one.

That system now runs Ubuntu, and Mint on my laptop… No problems at all.

It is possible to run OpenSUSE with the Gnome desktop, but it kinda put me off so I didn’t bother trying.

Right OK I’m now running Linux Mint and I’m still having some issues though I’m getting further than I did it finds a modem at /dev/ttyUSB0 so i then went on to edit wvdial.conf to say match what you said changing USB1 to USB0 as stated after saving that ran sudo wvdial three
i get this error

Sending ATE0 V1 &D2 &C1 S0=0 +IFC=2,2
Command not support
sending ATQ0
Resending ATE0 V1 &D2 &C1 S0=0 +IFC=2,2
Command not support
Modem not responding

In Mint 8 (Helena) there is no need to use wvdial…
System>Preferences>Network Connections
or at a terminal:


hit enter

Select the “Mobile Broadband” tab, Click Add, and follow the instructions.


Or install gnome-ppp, and use that to configure your connection…

install gnome-ppp either from the package manager, or with

sudo apt-get install gnome-ppp

then either start it from the Applications>Internet>GNOME PPP menu item
or from a terminal


Click Setup then Detect then Close
then enter three as both username and password, and *99# as the number… Click Connect
(you might need to clear everything from wvdial.conf first as gnome-ppp edits the wvdial.conf file when you click “Detect”)


Or try changing

[Dialer Defaults] Init1 = ATZ Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 Stupid Mode = 1 Modem Type = Analog Modem ISDN = 0 Phone = *99# Username = three Password = three Modem = /dev/ttyUSB1 Dial Command = ATDT Baud = 9600

[Dialer three]
Init2 = ATZ
Init3 = ATE0 V1 &D2 &C1 S0=0 +IFC=2,2
Init5 = AT+CGDCONT=1,“IP”,“3internet”
ISDN = 0
Modem = /dev/ttyUSB1
Modem Type = Analog Modem
Baud = 460800


[Dialer Defaults] Init1 = ATZ Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 Stupid Mode = 1 Modem Type = Analog Modem ISDN = 0 Phone = *99# Username = three Password = three Modem = /dev/ttyUSB0 Dial Command = ATDT Baud = 9600

[Dialer three]
Init3 = ATZ
Init4 = ATE0 V1 &D2 &C1 S0=0 +IFC=2,2
Init5 = AT+CGDCONT=1,“IP”,“3internet”
ISDN = 0
Modem = /dev/ttyUSB0
Modem Type = Analog Modem
Baud = 460800

and use sudo wvdial three to connect, and Ctrl+C to disconnect

You can also try removing the Init3 and Init4 lines altogether

But your best option would be to use nm-connection-editor

Lol I’m nearly there The modem initialises but doesnt connect im going to give up on it for a couple of days its given me a headache lol

Can you give us the output as it tries to connect, and let us know how you are doing it… ie. Network Manager, gnome-ppp, or wvdial

You could try leaving the username password blank

If you use the dongle in Windows, it might be a good idea to check it’s settings there, as far as Init strings, username, password, number, etc.

When you say it doesn’t connect, what is the error message, or is it connecting but you cannot access webpages… I’ve read a lot about people having probs with 3internets Domain Name Servers.

If it’s of any use;

I looked for that page (I knew it was there somewhere) and couldn’t find it… that should be helpful, it would have been nice if the Password Authentication Protocol (PAP) and encryption parts were mentioned elsewhere on the interweb… I suppose that would explain why a lot of people are having problems… they are obviously going to the wrong forums :wink:

JustExpired - Pick that tutorial up from Step 11… but in Mint the “Network Manager” Icon will be bottom right, by the clock.

–>bad init string.

that should be AT+CGDCONT=1"IP",“3internet” not AT+CDGCONT=1"IP",“3internet”

I’m really not having much luck

Sudo wvdial three
→ cannot get information for serial port
→ Initializing modem.
→ Sending: ATZ
→ Sending AT+CGDCONT=1"IP",“3internet”
–>Modem Initialised
–>Sending *99#
Connect 7200000
–>Carrier detected. Starting PPP immediately
Starting PPPD at Mon May 17 13:44:55 2010
–>pid of pppd: 6102
–>using interface PPP0
→ pppd: ??[0c]
–>pppd: ??[0c]
–>pppd: ??[0c]
–>pppd: ??[0c]
–>pppd: ??[0c]
–>pppd: ??[0c]
–>pppd: ??[0c]
–>Disconnecting at Mon May 17 13:44:55 2010
–>The PPP daemon has died: A modem hung up the phone (exit code = 16)
man pppd explains error codes in more detail.

Ive also try to use nm-connection-editor, put in the details and tryed to connect, its a failed connection and used KPPP dialer.

AM i chasing a lost cause

Also when I used Lsusb it says the modem is an E620 even though the box says E122

I set up a “3” E122 mobile dongle about 2 hours ago for someone… here’s what I did

Make SURE your dongle is PLUGGED IN to a USB slot

Clear the wvdial.conf file

sudo gedit /etc/wvdial.conf

clear the contents, and save… close gedit

still in the terminal:


and wait till it returns to a prompt (you should see it detecting the modem)
close the terminal, but ONLY after it returns to a prompt

Right-click the “Network Manager” icon by your system clock, select “Edit Connections”… select the “Mobile Broadband” tab… select “Add”… make sure your dongle is listed under “Create a connection for this mobile broadband device”… click forward… select “Britain (UK)”… click forward… select 3 as the provider… click forward… select “Internet” as your plan… click forward, then Apply.

In the window that pops up…
Connection name: 3 Internet 1 (or whatever you want to call it)

Mobile Broadband tab:
Number: *99#
username: three
password: three
APN: 3internet

tick in: Connect automatically (if you want)
tick in: Available to all users (if you want)

ALL other boxes clear, except if you’ve set a PIN number for the dongles SIM

PPP tab:
Authentication allowed methods should ONLY read PAP… so click the “Configure Methods” button, and remove all options except PAP.
Clear ticks from ALL OTHER BOXES on the PPP tab screen, except -
Connect automatically (if you want)
Available to all users (if you want)
Click “Apply

“I” had to disable wireless, otherwise it would connect, but I was unable to browse the web… but this shouldn’t really be necessary.

Reboot with the dongle in… and as long as you ticked “Connect automatically” the internet should just work… if you didn’t select “Connect automatically” you will have to right click the “Network Manager” icon and select “Enable mobile broadband”

See here for pics and instructions

Thanks anyway Mark that didnt work either,. dongle works fine with windows, looks like I’m going to have to go back to that which means forking out for it grrr I wont take anymore of your time.

I wouldn’t give up… it should work… come back in a while I’ll see what I can find… weird though, worked for me.

Does the blue light come on?

Is this PAYG or contract?

The blue light comes on and stays on, it says gsm network disconnected you are offline, yet the blue light stays on cant use the internet though

Didnt work either, my gf has just arrived so im going to give up for a couple of hours

Which disto?.. Mint 8?.. I may have found the problem, can you tell me what kernel version you are running

cat /proc/version

will tell you (mine Linux version 2.6.31-21-generic)

I’ve just discovered there is a bug in earlier kernels that affect Huawei E122 HSPA USB (and other) dongles
see here:


If your Linux PC has never been connected to the internet and/or never got a kernel update this could explain why I had no problem… My kernel HAS been updated.

If this IS the problem, you have 2 options.

  1. move over to Mint9 when it is released, or Ubuntu 10.04 now (remembering the intel graphics problems… so try it with a LiveCD first)
  2. Update your kernel…

To update your kernel in Mint8…
Click the “Padlock” icon by the clock
when the “Update Manager” starts… Click “Edit”… Click "Preferences.
On the “Levels” tab… put a tick in the “visible” box for level 5, and click apply.

Now the awkward part (for you)… you are going to NEED an internet connection… Is there any way you can take this PC to somewhere with a wireless or wired internet connection (router) ?

If you can… click the “Padlock” Icon, and when the Update manager starts… select all updates… click apply… and wait while they are installed.

I would advise Mint 9 or 10.04, as long as you don’t have an intel graphics chipset… BUT try it on a LiveCD first.

Mint 9 RC (32bit) available here:
or Mint 9 RC (64bit) available here:

or Ubuntu downloads here:
if you want the 64bit…click the “Alternative download options, including Ubuntu installer for Windows” link and tick 64-bit version