EPSON SX425 All-in-One Wi-Fi set up

Nearly there just the printer to set up and the system will be complete.

I have all the drivers and software required to operate the printer/scanner on Linux.

But how to set it up? Setup instructions are provided for CUPS V.1.3.9 using an internet browser to connect to the CUPS server http://localhost:631

But this dose not work as firefox returns a host not found report.

My version of CUPS is V.1.4.3-lubuntul.3

Any help would be appreciate.

Can you send the output from:

ps ax | grep cups

Output as follows -

1090 pts/0 S+ 0:00 grep --colour=auto cups

I ran it a second time and got a slightly different readout -

1290 pts/0 S+ 0:00 grep --colour=auto cups

In both cases the word cups is in red.

OK… looks like the CUPS service isn’t being automagically started at bootup… try this:

sudo service cups start

then try:

Let me know if that works, and we’ll have to sort out how to make CUPS start at boot time… so you don’t have to enter that every time :wink:

If the CUPS service IS running:
ps ax | grep cups
should have given you an output similar to -

22763 ? Ss 0:00 /usr/sbin/cupsd -C /etc/cups/cupsd.conf 22954 pts/29 S+ 0:00 grep --color=auto cups

Hi, thanks for assistance, CUPS was not running once started printer installed OK.

Had to restart CUPS after booting up today so need a way to start CUPS at boot time.

To start the cups service at bootup in Peppermint…

Open a terminal, and enter:

gksu leafpad /etc/network/if-up.d/cups

leafpad wil open a blank file.

Add these 2 lines to the file:

#!/bin/sh service cups restart

SAVE the file, and exit leafpad.

Back in the terminal, enter:

sudo chmod +x /etc/network/if-up.d/cups

Now reboot… the cups service should now be running without you having to do anything.

You can check cups is running with:

ps ax | grep cups

you should get 2 lines returned, similar to:

22763 ? Ss 0:00 /usr/sbin/cupsd -C /etc/cups/cupsd.conf 22954 pts/29 S+ 0:00 grep --color=auto cups

worked like a dream, thanks…

Now having a problem with the scanner the computer can see the scanner and starts to scan then stalls with the lights flashing on the scanner any clues?

Go to this page:

ignore the Model name drop down menu, and instead scroll down to the Form for download section.

in that section look for the:

Epson ME OFFICE 560W,Epson Stylus NX420/SX420W/SX425W/TX420W

and tick the box (circle).

scroll to the bottom of the page, and make the 2 dropdown menu’s read:

Distribution = Ubuntu
Distribution version = 10.04

Click Next.

Now from that page, download these 2 packages.


To install them, just double-click them, then when Gdebi opens, Click Install… they MUST be installed in the order above, scan-data_1.8.0-0_all.deb FIRST.

Whilst you are on the driver page… if


WASN’T the printer driver you installed… you may need to install that too… download it, but only install it if needed.

Thanks for the advice however, I get the following error message when I try to scan using iscan - could not send command to scanner check the scanner status

How did you originally set up the printer?

If you were following any instructions, can you post a link to them.

Run this:

sudo apt-get install xsane sane-utils libsane

Then with the scanner plugged in and switched on, can you send the output from:




also check if Graphics>Xsane Image Scanner works, if you haven’t already.

and just to make sure the sane backend is working, does this command result in a load of PASS’s ?

scanimage -d test -T


Read outs as follows -
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


sane-find-scanner will now attempt to detect your scanner. If the

result is different from what you expected, first make sure your

scanner is powered up and properly connected to your computer.

No SCSI scanners found. If you expected something different, make sure that

you have loaded a kernel SCSI driver for your SCSI adapter.

No USB scanners found. If you expected something different, make sure that

you have loaded a kernel driver for your USB host controller and have setup

the USB system correctly. See man sane-usb for details.

Not checking for parallel port scanners.

Most Scanners connected to the parallel port or other proprietary ports

can’t be detected by this program.

You may want to run this program as root to find all devices. Once you

found the scanner devices, be sure to adjust access permissions as


scanimage -d test -T
scanimage: scanning image of size 157x196 pixels at 8 bits/pixel
scanimage: acquiring gray frame, 8 bits/sample
scanimage: reading one scanline, 157 bytes… PASS
scanimage: reading one byte… PASS
scanimage: stepped read, 2 bytes… PASS
scanimage: stepped read, 4 bytes… PASS
scanimage: stepped read, 8 bytes… PASS
scanimage: stepped read, 16 bytes… PASS
scanimage: stepped read, 32 bytes… PASS
scanimage: stepped read, 64 bytes… PASS
scanimage: stepped read, 128 bytes… PASS
scanimage: stepped read, 256 bytes… PASS
scanimage: stepped read, 255 bytes… PASS
scanimage: stepped read, 127 bytes… PASS
scanimage: stepped read, 63 bytes… PASS
scanimage: stepped read, 31 bytes… PASS
scanimage: stepped read, 15 bytes… PASS
scanimage: stepped read, 7 bytes… PASS
scanimage: stepped read, 3 bytes… PASS

The scanner is operated in Wi-Fi mode just like the printer side of the All-in-one.
The printer side is working fine in Wi-Fi mode.

Hi, I set up the scanner and printer as per instructions on this site -

Ahhh… I didn’t realise it was a networked printer (I should have from the heading ::slight_smile: )… did you install the iscan-network-nt_1.1.0-2_i386.deb network plugin ?

If not… install it now (same address as linked above).

Now you need to get the IP address for your All-In-One.

This bit is for a different Epson printer, but it should be similar for the SX425… Go to Menu on the front of the printer, select “Setup,” then “Confirm Network Settings.”
Somewhere in there, the IP address of your printer/scanner should be listed.
If you want, you can print a status sheet from here by hitting the “Start” button… This will contain info like your IP address, Device ID, Workgroup, Port, etc.

Once you know the IP address for the All-In-One, open the /etc/sane.d/epkowa.conf file for editing:

sudo leafpad /etc/sane.d/epkowa.conf

(check that it already contains a load of commented out (# at beginning of line) lines… if it’s empty, let me know).

Add a line at the bottom that reads:

net <[b]your[/b] Printer's IP address>

example -

SAVE the file, and try iscan now (may require a reboot).

It would be a good idea to give your Epson All-In-One a static IP, because if it ever gets assigned a different IP by the DHCP server, the scanner will stop working unless you edit epkowa.conf with its new address.

Thanks for all the help, printer/scanner now fully working. In fact I have a choice of scan programs.