Error formatting USB stick. (Solved)

I am having difficulty formatting my Lexar 16gb usb stick. I get ‘Error formatting disk’. Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)

Also I cannot un mount it.

Any ideas?

Read this:

Then install gparted:

sudo apt-get install gparted

and use that to format the USB stick

Unmount it from the command line with:

sudo umount -f /dev/sdbX

where bX is the drive/partition number.

Or just don’t mount it in the first place :wink:

Thanks Mark. I completely forgot about Gparted. :-[

Works now. :slight_smile:

You’re welcome :slight_smile:

I have a hard drive I am trying to use for my Ubuntu PC, and I got the same response when trying to format it. Specifically, there is one partition that does not erase itself. I looked at it in GParted, but it does not show that there are any partitions on the disk. It shows an exclamation point within a large red dot, and when I right-click “unallocated” and click information, it tells me: /dev/sdb: unrecognized disk label
I have no idea what that means. Can I get some help?

Nevermind, I fixed the disk. I asked a friend to help and they added a partition in GParted and it cleared up. Wierd, but it’s fine. (For the most part.)