Exfat in Gparted (Solved)

Trying to format a 64g micro Sd card to exfat in Gparted.

The exfat option is greyed out.

Jocklad ::slight_smile:

sudo apt-get install exfat-utils exfat-fuse

then restart Gparted … is it still greyed out ?

ben@ben-Dell-DV051 ~ $ sudo apt-get install exfat-utils exfat-fuse
[sudo] password for ben:
Reading package lists… Done
Building dependency tree
Reading state information… Done
exfat-fuse is already the newest version.
exfat-utils is already the newest version.
0 to upgrade, 0 to newly install, 0 to remove and 21 not to upgrade.
ben@ben-Dell-DV051 ~ $

It installed ok, but exfat still greyed out in Gparted

If you look at the suported oprations for different file systems here:
it seems Gparted doesn’t support creation of exfat file systems … I read somewhere that it’s for “legal reasons”, but don’t know if that’s true.

I just used
menu > Preferences >Disks

selected the device I wanted to format in the laft hand column

clicked on the partition I wanted to format (so it was outlined) … then clicked the little cog icon underneath, and selected “Format

then set
Type: Custom (Enter filesystem type)
Filesystem: exfat

Then clicked Format > Format

That seemed to do the trick :slight_smile:

Thanks Mark will have a go at that :slight_smile:


just checked, and Win7 was happy to recognise the USB stick formatted with “Disks” as having an exFAT filesystem :slight_smile:

Gparted (and blkid) also recognises it as exfat.

Yes that did it Mark.

Have formatted the SD Card and inserted back into camera,its working fine.

Again many thanks. :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile:


You’re most welcome … I learned something new myself too :slight_smile:

I know this thread is marked as solved, but it contains false or misleading information. The little clog icon and the Custom field are NOT found in GParted. They are found in GNOME Disk Utility a.k.a Disks. Those are two different partition managers. Based on my own experience, GParted is completely useless as fas as ExFat goes. It can’t even detect an ExFat partition properly. Use GNOME Disk Utility and the little clog icon.

Welcome to the forum botable :slight_smile:

I strongly suggest you go back and re-read the post of mine that you quoted before telling the world it was misleading … then saying EXACTLY the same thing.

And if you’re going to quote my posts, please quote them in FULL rather than clipping them to fit YOUR misconception or agenda…

For clarity here it is again (in FULL) with the relevant parts highlighted in red/blue for your benefit:-