External DVD player for Linux [NOT YET RESOLVED]

I ordered a cheap DVD player for my Dell Latitude E5570 laptop running Ubuntu 20.04 but it didn’t work. It wasn’t even recognised by VLC or the file manager and the df command did not list it.
I tried it on another laptop (Lenovo T500) running Ubuntu 18.04 and on a desktop (Asus P6) running MX (Debian) and they didn’t see it either. So I returned it to eBay.
I thought I would try a slighty more expensive player (OK, only £22) and that wasn’t recognised by any of my computers either.
These things are supposed to be plug-&-play and Ubuntu has been very good in that respect until now. What am I doing wrong – if anything? All suggestions would be received gratefully.

First things to try, when you plug it in, try “lsusb”, see if it’s recognised at all and if so, what as.

Here’s the output:
keith@E5570:~$ lsusb
Bus 002 Device 002: ID 413c:81b6 Dell Computer Corp. DW5811e Snapdragon™ X7 LTE
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0a5c:5832 Broadcom Corp. 5880
Bus 001 Device 002: ID 1bcf:28b8 Sunplus Innovation Technology Inc. Integrated_Webcam_HD
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
This was after waiting several seconds for the disc to spin up. So not looking hopeful.
I think David McCann posted briefly about changing default applications - I tried that without succcess.
If you have any more ideas I would be very grateful.

Of possible interest is that although my Asus P6 desktop when running Ubuntu or Mint refused to recognise the built-in DVD player, with MX (Debian) installed the built-in player works fine. But MX doesn’t recognise the external DVD player. I doubt that I have had two duff external players.
Oh, and the mount command doesn’t list it either.

Ok, so unless I’m missing something, your device isn’t listed, which would lead me to one of the following;

  • A compatibility issue between the devices and your machine
  • A fault on the devices
  • A fault on the USB socket on your machine

Given you’ve tried two devices, the first two options seem unlikely. With an integrated webcam, I’m assuming (possibly incorrectly) your device is a laptop … either way, it’s likely to have a mix of USB ports, i.e. they won’t all be the same or use the same controller … so if a controller has failed, some may work and some not. I have a Sony laptop here and 1 out of the 4 USB sockets work, the other three don’t … so I can only plug my external mouse into one position.
So … can you try plugging the device into each USB, give it 10s, then try “lsusb” and see if it pops up?
(unless you’ve already tried this …)
Also, can you plug a mouse into each socket and just check it works in each position …
… but if it doesn’t popup on “lsusb”, the chances are that it’s a hardware issue or a hard compatibility issue. (for example it’s a USB 1 port and the device only works on 2+)

Two laptops (Ubuntu 18 with internal DVD player, and Ubuntu 20) and a desktop (MX, with built-in DVD player) - none of which will recognise an external DVD player.
All the USB ports on all the computers seem to work with usb sticks (files and live USBs), external web-cams and wired keyboard, and they all appear on lsusb. So I think the USB sockets are OK.
The DVD player has two leads (usb power and USB data) and I’ve tried mixing ports, but to no avail.

The two players that I’ve tried were cheapo devices (~£20) but these things are generally very reliable (for a while, at least). I looked at Dell external DVD drives on Ebuyer but the very long compatibility list didn’t mention my Dell E5570 laptop, so I’m stuck.

Ok, well, you can also get faulty cables, have you tried switching them?
What sort of USB connector are they, standard, or USB-C?

I had to buy one specially as I didn’t have one “in stock” - USB type A. Just the old-fashioned square corner type.
The first DVD player I bought (and didn’t work) had a single USB cable integral to the device, so in a way I have tried two USB cables.

If I can find someone with a Windows PC to try it on, that will certainly show where the problem lies. Next week, probably. But if you have any more thoughts…

Ok … so … maybe … your new device should be USB-3 (or 3.1) and your laptop is “probably” 3.0 (?) and you’re using a 2.0 cable. (4 wires instead of 9 in USB-3) Now whereas I have an expectation that this combination should work, just at USB-2 speeds because of the cable, I guess there is a possibility the laptop is sending a “hello, what are you?” , the DVD says “USB-3”, the laptop says “me too!” and ignores the cable spec … maybe worth trying a USB3 cable? It may fix the problem, but regardless it’s technically 10x quicker …
(USB-2 is circa 2000, USB-3 is circa 2008)

Although the USB sockets on the laptop are black rather than the the conventonal blue for USB3, I looked up the specs of my E5570 and sure enough the three USB ports are USB3.
There is no data on the DVD device and as it’s a cheap one I’m sure it’s USB2.
But as you say (and I’ve checked on line) mixing USB2 & 3 just means data is transferred at the speed of the slowest thing in the data path.

I shall try to find someone with a Windows machine this week to see if the DVD works on that. If it does, then it looks like a Linux problem.
I’ll report back when I have some news.

Yeah, if it’s a new device I would be somewhat surprised if it was USB2 … all machines from 2012 (ish) onwards, or maybe even earlier should be USB3, just because it’s the new standard. At chip level, again I wouldn’t have expected the price difference for the manufacturer to be more than single digit pennies.
Caveat; my experience with 3.0 has been poor and that 3.0 devices don’t always meet the speeds often quoted as “USB3” … it’s “USB3.1” that delivers the 10G speeds … and just reading up, 3.2 quotes 20G.

I had a closer look (ought to have done it earlier!) at the DVD eBay page and it does say USB3. However, although it lists support for many Windows and Mac versions it doesn’t actually state “Linux” although we know that the Mac is Linux-based.
I don’t know anyone near me well enough to ask to test the device on their computer so I have decided to return the item.

Many thanks for your advice and suggestions. Not wasted as I always learn something new.
If anyone can recommend a USB-based DVD player/writer known to work well with Ubuntu 20.4 I would be interested to hear about it.


Hi Keith
I think it’s unlikely the DVD player is incompatible with Ubuntu 20.04, especially if your USB ports are USB 3 and the player is likewise, if I understand MP correctly it should still work, I don’t have an external DVD player to test but I notice my internal player doesn’t show up under


or removable devices unless I have a disk in it then it shows as ISO9660, have you tried that?, you could also try plugging it in then running

sudo dmesg | tail -20 

to see if it shows up, that said if it didn’t show with lsusb then it’s unlikely but might be worth a try.

finally there’s an interesting article that might help here


Good luck

Hi Graeme.

Well, this is partly embarassing.
At first none of your tests produced anything, but I’ve just discovered that there is a secret integral cable tucked away in the bottom of the DVD player. But don’t get excited.

When plugging that one in along with the separate cable that came with the device the device was partly recognised. Your tests show this:
keith@E5570:~$ blkid
/dev/nvme0n1p5: UUID=“92ba0f4e-e3b0-424c-91b7-8748fff01126” TYPE=“ext4” PARTUUID=“6a6cd5a9-05” (this is the SSD)

keith@E5570:~$ sudo dmesg | tail -20
[11387.943460] usb 1-1.4: Manufacturer: Generic
[11387.943465] usb 1-1.4: SerialNumber: 121220160204
[11387.944934] usb-storage 1-1.4:1.0: USB Mass Storage device detected
[11387.946772] scsi host2: usb-storage 1-1.4:1.0
[11388.473921] usb 1-1.2: new high-speed USB device number 11 using xhci_hcd
[11388.575180] usb 1-1.2: New USB device found, idVendor=13fd, idProduct=0840, bcdDevice= 1.14
[11388.575196] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[11388.575203] usb 1-1.2: Product: External
[11388.575208] usb 1-1.2: Manufacturer: Generic
[11388.575213] usb 1-1.2: SerialNumber: 523832453647464236313438
[11388.576791] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[11388.577302] scsi host3: usb-storage 1-1.2:1.0
[11388.954789] scsi 2:0:0:0: Direct-Access Mass Storage Device 1.00 PQ: 0 ANSI: 0 CCS
[11388.955425] sd 2:0:0:0: Attached scsi generic sg0 type 0
[11389.232935] sd 2:0:0:0: [sda] Media removed, stopped polling
[11389.238652] sd 2:0:0:0: [sda] Attached SCSI removable disk
[11389.599540] scsi 3:0:0:0: CD-ROM TSSTcorp CDDVDW TS-L633F LE02 PQ: 0 ANSI: 0
[11389.616571] sr 3:0:0:0: [sr0] scsi3-mmc drive: 8x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[11389.627900] sr 3:0:0:0: Attached scsi CD-ROM sr0
[11389.628132] sr 3:0:0:0: Attached scsi generic sg1 type 5

So it’s found it.
Inserting a CD lit up VLC player but it took ages to list the tracks, and then only as “Track 10”, “Track 11”, etc. Eventually it started to play them but in a very halting fashion.
Inserting a DVD produced the usual “choose which episode” dialogue but clicking on any of these simply repeats the invitation.

I tried mounting the device manually using that website but had this:
keith@E5570:~$ sudo mkdir /mnt/cdrom
keith@E5570:~$ sudo mount /dev/sr0 /mnt/cdrom
mount: /mnt/cdrom: can’t read superblock on /dev/sr0.

blkid still refuses to list it.

So: partial success, (and I can’t believe my stupidity in not seeing the buried cable!) but the player is not behaving properly with my system.
Not sure what to do now. I am guessing that a mains-driven one will behave similarly and they all seem to use SCART or HDMI outputs. And no, I don’t have a modern TV - B/W only! - hence the interest in getting this going.

Many thanks for your advice, Graeme. If I get anywhere I shall report back.

Well at least that’s some progress :), however I’m a bit confused so a couple of questions firstly this other cable you found is it USB? and if so does that mean it requires 2 USB cables to be connected?, I’m asking that because it’s not unusual for portable drives to require 2 USB connections also from what you’re describing I get the impression the reason it’s not playing properly is because it’s underpowered,which might explain why it’s now almost working since you connected the second cable, the problem is (at least in my experience) not all USB ports are equal, so have you tried plugging the cables into different ports or even better trying it on a different machine preferably a desktop

Hi Graeme.
The “hidden” cable has the blue inner that shows it’s USB3 and I am guessing that this is the data cable, and that the extra, supplied cable is for more power - as you say.
Just tried it on a desktop MX setup with a CD in. The file manager sees files but listed only as “Track 10” etc. VLC complains:
Your input can’t be opened:
VLC is unable to open the MRL ‘cdda:///dev/sr0’. Check the log for details.
Just like Ubuntu 20.04.

Just tried a DVD: it behaves just as before (showing the invitation to select an episode) except that VLC now says:
Playback failure:
DVDRead could not open the disc “/dev/sr0”.
Your input can’t be opened:
VLC is unable to open the MRL ‘dvd:///dev/sr0’. Check the log for details.

Trying different USB ports has no effect.
The eBay company has provided a return label but I’m not sure what to do. It’s unlikely to be a duff player, but I am not all that confident that I will find a solution. On the other hand it would be nice to succeed one day. I have a few days to make up my mind.

Many thanks for your suggestions, Graeme.

I decided to return the item to eBay.

I shall probably buy a mains-powered DVD reader to display DVDs on a stand-alone desktop monitor. Such devices will have an audio output for my hifi.

This doesn’t solve all my problems, of course, as I can’t “rip” CDs for backup storage.
I would be interested to hear from Members who can run an external DVD reader/writer with a laptop, with details of which DVD reader and OS and any special settings that had to be made.

My thanks to Mad Penguin and Graeme for their help.


Hi Keith

I don’t have an external DVD player so I’m not much help I’m afraid, I used to have one and I dropped from the hatch in my attic so needless to say it never worked since but nonetheless as I remember it just worked, I didn’t have any special settings to make, I’m really surprised you’re having this issue and sadly don’t any have advice to give you that you haven’t already tried, except trying it on a Windows machine, I hate suggesting to anyone to use Windows to solve a Linux issue but sometimes it is necessary (I have a Windows VM I use for this sort of thing although I can’t remember the last time I used it( but would be helpful at this point to know if it does work on Windows is there any way you can do that ?


Hi Graeme.

Thanks for relating your experience. LIke you, I am surprised that I’m having trouble as Linux has been so very accomodating so far. But three Linux machines failed to read DVDs (Ubuntu 18 & 22 and MX). I can always buy a mains-driven DVD reader and send the output to a monitor, but I would like the facility of ripping CDs for backup.

As for trying out on a Windows machine: I’ve returned the offending DVD players so no chance at present. And all my friends live >100 miles away from my new home which would slow up the test somewhat. I shall continue to search the web for possible solutions and perhaps check with eBuyer what DVD reader they have that they can guarantee to work on Linux. Worth a try.

I don’t know anything about Windows VMs but your suggestion is a good one if I can get it to work.

Many thanks for your advice.