Facebook suddenly not connecting on Chrome

My daughter is going frantic because she can’t get onto Facebook ::). It suddenly stopped connecting around 6 this evening, it was fine before.
Laptop is Linux, phones and tablet are android and we normally use Chrome. Have tried on Firefox and that won’t connect either. I’ve done the usual clear history/cache and still nothing. I’ve checked if there’s a problem with the site via a couple of Is it down sites, they say it’s running okay.

Any ideas?

Sorry I’ve put this in the wrong section!

So what exactly happens if you try to visit facebook ? … the page doesn’t appear ? … you get a 404 error ? … you can see the page but it won’t accept your login details ?

What’s the output from:

ping  -c 5 [url=http://www.facebook.com]www.facebook.com[/url]


ping -c 5

and can you go to here in your browser:
(manually enter that into your browser address bar and hit enter)

The page doesn’t open at all Mark. After about 30 seconds of just the little circle going round I get the following:

This web page is not available

ReloadHide details
Google Chrome could not load the web page because www.facebook.com took too long to respond. The website may be down or you may be experiencing issues with your Internet connection.
Check your Internet connection
Check any cables and reboot any routers, modems or other network devices you may be using.
Allow Chrome to access the network in your firewall or antivirus settings.
If it is already listed as a programme that is allowed to access the network, try removing it from the list and adding it again.
If you use a proxy server…
Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don’t believe you should be using a proxy server: Go to the Chrome menu > Settings > + Show advanced settings > Change proxy settings… and make sure your configuration is set to “no proxy” or “direct.”

ping -c 5 www.facebook.com
ping: unknown host www.facebook.com

ping -c 5
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=90 time=20.8 ms
64 bytes from icmp_req=2 ttl=90 time=21.1 ms
64 bytes from icmp_req=3 ttl=90 time=20.6 ms
64 bytes from icmp_req=4 ttl=90 time=20.1 ms
64 bytes from icmp_req=5 ttl=90 time=19.7 ms

— ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 19.786/20.528/21.120/0.513 ms just gives the same page.

I would have suggested this was a DNS issue, but as you still can’t access it via the IP in the browser, I’m a bit lost :-[

Are all other sites ok, or are others inaccessible too?

Every other site is fine which is puzzling me because no one else is having any problems with Facebook.

Nope that’s the very definition of a DNS issue … able to connect via IP but not via domain name means there’s a problem with name resolution :wink:
(in the browser it appears that it still attempts to resolve the IP to a domain name and fails)


Which Linux distro are we talking about here ?

and do you either
a) know how to change DNS to googles DNS servers (in networkmanager) ?
b) know how to access networkmanager ?

Another thought … have you simply tried restarting your router ?
(I doubt if this’ll help but stranger things have happened)

I’m on Mint 13.

Which Linux distro are we talking about here ?

and do you either
a) know how to change DNS to googles DNS servers (in networkmanager) ?
b) know how to access networkmanager ?

No I’m afraid not. :-[

Yes I did restart my router and still not having any luck.

OK, we can probably fix this in Mint … but it’ll not fix it for Andriod or Windows (to do that you’d need to change the DNS settings in those too)

In fact this is a DNS issue, so you might want to take it up with your internet service provider … if they fix it, it’ll be fixed for ALL OS’s.

OK, in Mint … is this a wired or wireless connection ?

and if you open a terminal and run:


does the network connections dialog open ?

if so, what connections are listed ?


and can you post the output from:

ls /etc/NetworkManager/system-connections

It’s a wireless connection. Yes the network connections opens, with my Sky connection and a few others. No output from ls /etc/NetworkManager/system-connections.


What’s the name of your Sky connection ?


can you run:

sudo updatedb

then post the output from:

locate -i Sky0A746

Just a thought, you haven’t been playing with your Sky Broadband Shield settings have you ?

Do you know what Sky Broadband Shield is and how to disable it ?

Do you know how to access your MySky account ?

Are you unable to access Pinterest

Yes I added a website to be allowed on Sky Shield yesterday!
I can’t open Pinterest.

OK, it’s my guess you’ve set the social media block in Sky Shield.

Normally sites that are blocked would display a page saying they’re being blocked by Sky Shield … but sites that use HTTPS (secure connections) do NOT, they just silently fail.

Try disabling Sky Shield altogether, or unblocking social media.

or move from PG to 13 in the settings (social media is blocked by the PG setting)

Or add facebook to the allowed sites liist

Okay just switched it off and bingo, Facebook works! I only have shield on because my daughter is only 13.

Thanks for your patience Mark. :slight_smile:

If you want the shield on … just change it from the PG setting to the 13 setting … PG blocks social media, 13 doesn’t :wink:

Will do. Thanks.

You’re most welcome :slight_smile: