Failed to start the X Server (Resolved)

I am running mint 13 maya 64 bit.

Everything was working OK when I switched off yesterday.

When I switch on this morning the system stops booting with an error.

Failed to start the X Server (your graphical interface)…

I tried updating the system from recovery mode and also tried a scan of the file system.

I go through the reports and can find no problems.

The X server is then dissabled and I can only log in to a command prompt.

Any help please…

Also ran the log file from the command line and the following error was show.

Fatal server error:
Unreconised option: Server

What happens if you boot to where it stalls, then hit Ctrl+Alt+F3 to drop to a console

Log on (in text mode)

Then run:



I get the following error messages.

Error: API mismatch: the NVIDIA kernel module has version 304.88, but this NVIDA driver component has version 173.14.37. Please make sure that the kernel module and all NVIDIA driver components have the same version.

Fatal server error:
No screens found

xinit : unable to connect to X server: No such file or directory

Do you know what graphics card you have, and which graphics driver you were using ?

The output from:

sudo lshw -C display

might ell you, if you can’t remember.

Card= NV44 (GeForce 6200) VGA

driver=nvidia latency=32 maxlatency=1 mingnt=5

I do not know if this has a baring on the problem but a new set of NVIDIA drivers was downloaded durring an update yesterday but I did not change the driver I use because it is working OK.

Waht’s the output from:

dpkg -l | grep nvidia

I only need the status (ii, rc, etc.) and the package name/version (NOT the description) … so in output like:-

ii skype i386 client for Skype VOIP and instant messaging service ii skype-bin i386 client for Skype VOIP and instant messaging service - binary files

I’d only need the bits I’ve highlighted in red

Hi I am having trouble with the code as I can not just copy and past into the command line after dpkg is this a special symbol if so I can not find it on my keyboard…

Hi Tramlink I think the symbol immediately after dpkg is a dash lowercase L then space followed by pipe usually found on the key immediately to the left of Z

Thanks for that info readout is:

ii nvidia-173-updates 173.14.37-0ubuntu0.0.1
ii nvidia-304 304.88-0ununtu0.0.3
ii nvidia- 304-updates 304.88-0ununtu0.0.3
ii nvidia-common 1:
ii nvidia-current 304.88-0ununtu0.0.3
ii nvidia-current-updates 304.88-0ununtu0.0.3
rc nvidia-settings 295.33-0unbuntu1
ii nvidia-settings-304 304.88-0ununtu0.0.3
ii nvidia-settings-updates 304.88-0ununtu0.0.3
ii nvidia-settings-updates 304.88-0ununtu0.0.3

Before we go any firther, can we check you hasve an active internet connection … run:

ping -c 5

Was the output similar to what’s below ?

PING ( 56(84) bytes of data. 64 bytes from icmp_req=1 ttl=57 time=28.9 ms 64 bytes from icmp_req=2 ttl=57 time=28.3 ms 64 bytes from icmp_req=3 ttl=57 time=28.9 ms 64 bytes from icmp_req=4 ttl=57 time=28.8 ms 64 bytes from icmp_req=5 ttl=57 time=28.5 ms

— ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 28.397/28.730/28.967/0.295 ms

Yes looks very similar to yours.

Confirming I have an internet connection.

OK, try running:

sudo apt-get remove --purge nvidia*

before accepting the changes, make sure it’s not going to remove anything important … it should remove ALL packages that start with “nvidia”

Once that’s done, run:

sudo mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.old

(be sure to use a capital X in Xeleven)

sudo apt-get install --reinstall nvidia-current nvidia-settings


sudo shutdown -P now

Now see if it will boot

This has resolved the issue and system booted normally.

I would be interested to know how this problem happened in the first place.

As I said the system was working OK when shutdown…

Thanks for your help…