Failure to connect to the internet on Acer Aspire One.

I cannot get an internet connection through BT Home Hub on my AA1 loaded, as far as I know, with the basic Linpus Linux Lite. I can access the internet using an ethernet cable but not the wireless adaptor, there is a light showing that the wireless card is working. Is there any way I can get confirmation that the adaptor is serviceable. Any help would be appreciated, thank you.

Are you able to access the Network Manager ? … and/or is the Network Manager icon missing ?

Do you know how to open a terminal ?

and do you know your routers IP address ?

Yes to all three questions.

With the ethernet cable disconnected, what is returned if you run:
ping -c 5


ping -c 5

Also, what is the output from:



Have you tried deleting ALL network connections (as both user and root), then setting up your connection again ?

You can delete all network connections (as root) with:

sudo gconftool-2 --recursive-unset /system/networking

Then as user with:

gconftool-2 --recursive-unset /system/networking

BE AWARE … those commands will clear ALL network settings, so you’ll have to set up wireless again

It’s described here:

Hi Mark, I take it you wanted me to make these entries in a terminal, accessed by Alt & F2. I must point out that I am fairly computer illiterate, only ever having used Windows. I entered the four things you suggested and got nothing in return, except the desktop. I then deleted all entries in the network connection manager, and re-entered the SSID for the BT Hub, plus the Wireless Key, still no connection to the internet, and the wireless adaptor light has gone out. It looks as though the Wireless adaptor has gone toes up, and could entail a visit to the local PC repair shop. Thank you for your trouble.

Try this …

Turn off the AA1 … remove the power lead and battery.

hold the poweer button for 10 seconds.

put the battery and power lead back in.

boot the AA1

Dejete and recreate the wireless connections.

Yes I meant enter those commands in a terminal … to access a terminal hit Alt+F2 … then in the dialog box type terminal and hit enter … a terminal should open.

Sorry Mark, tried all that,and still no joy.
I did re-try the previous suggestion.
To the first entry, got, “network is unreachable”.
Second entry got a huge mass of numbers and letters, which completely baffled me.
No reply to the third and fourth entries, but it did clear the network center. When I created a new network connection, the summary said that, the Interface,Speed,Driver and Hardware Address were all unknown. Don,t know if this is significant. Thanks for the suggestions. Still no network light showing.

Before taking it any further … let’s see if there is a problem with the wireless card or not.

Have you got a 2GB or larger USB stick ?

I’m thinking you should create a Peppermint LiveUSB … boot to it, and select “Try Peppermint” … then see if your Wireless works from withing Peppermint.

If it does … we’ll go from there.

Instructions for creating a Peppermint 3 LiveUSB and booting to it can be found in this posting:

DO NOT select “Install Peppermint”, or move on to stage 2 of that tutorial … just try the wireless whilst booted to the Peppermint LiveUSB

Hi Mark,
Back again.I did,nt think I had the expertise to create my own usb stick of the Peppermint 3, so I went to the Peppermintos web site you mentioned and bought one. I ordered it on the 6th Nov and the money was taken out of my account on the same day. They quoted a delivery time of 6 to 10 days, but I am still waiting. Will try your suggestion when it arrives. Thanks DaveP.

Okey dokey … if you get tired of waiting and want to create your own LiveUSB, let us know :wink:

Mark, Finally received my Peppermint 3 usb, and tried it on my AA1. wireless card still dead as the proverbial Dodo, so it looks as though I shall have to replace the card. Thank you very much for all the helpful suggestions, if I have any more problems, I hope I can get in touch again. DaveP.

Sorry to hear the card is dead, but glad you’ve got to the bottom of it … By all means any Linux related questions, give us a shout :slight_smile: