Firefox 4 installation problem on Acer Aspire One - Linpus Lite

Please help!

I ran into the problem of firefox not working when it updated to firefox 4. Being overconfident, I removed firefox and reinstalled the old firefox 2 from the add/remove software panel. Then used firefox 2 to download the firefox 4 archive and unpacked it to a temporary directory, so I could see what the problem was. Seeing it was lack of a GLIBCXX file, I found the relevant rpm (using firefox 2) and installed it. Firefox 4 then worked, so I planned to replace firefox 2 with it.

I noticed the desktop was not responding as usual, so restarted. Blank desktop with only the search bar and bottom bar visible (but these work). Using the search bar opens firefox 2 or a desktop search- but can’t open folders from that search as nautilus isn’t running. Rebooting, ctrl-c at startup to get a command prompt, unmounting filesystem and running fsck returns no errors.

I’d rather recover the desktop as it was than install another distribution if possible- not least because a linux mint live usb didn’t work with the wireless card and I’m not sure if the relevant drivers are available.

So, any suggestions as to how I can get my desktop back?

Thanks very much.

IMPORTANT note for future readers - DO NOT uninstall Firefox 2 (uninstalling FF2 will kill your system)… if you haven’t already uninstalled Firefox 2, and have just updated to Firefox 4 and found that it no longer starts… see here:

If you HAVE uninstalled Firefox 2, and found that you now have a blank desktop with just the search bar… I’m afraid it’s too late, and you are going to have to reinstall your whole OS from the recovery DVD… so read on.

Links to Recovery DVD images are further down this topic

Are you running Linpus Lite ? … as you mention nautilus, and Linpus Lite doesn’t use nautilus as its file manager, it uses thunar.

How did you install this .rpm ?
What was the .rpm called ?
and where did you get it ?

If you installed it system-wide rather than following the above instructions, it will probably have overwritten the libstdc++6 (as used in Linpus Lite) with a later version.

Try reinstalling the original version… if that brings your system back… just extract the files contained in the .rpm into the firefox 4 directory, rather than installing them system-wide.
(you may need to do this manually from a LiveUSB if you have no access to the package manager or command line)

[EDIT 2]

Future readers finding this topic, may also want to read this topic:

Thanks for the reply :slight_smile:

It’s definitely linpus lite, the error message however does refer to nautilus, not thunar.

I got the .rpm from rpmfind and installed it system wide using the standard installer that opens when a .rpm is downloaded. So you’re probably right about the cause of the problem.

Do you have a link for the correct version so I can be sure I’m using the right one for the fix?

Thanks very much.

First of all, is it THIS Linpus Lite ?

If so…

As Linpus Lite is based on Fedora core 8, I’m guessing you require the libstdc+±4.1.2-33.i386.rpm from here:

BTW, it appears it IS libstdc++6 ( as opposed to as required by Firefox 4 ), not libstdc++5 … but it’s an earlier versionm than the one required for Firefox 4.

The 2 files contained in the .rpm need to go in the /usr/lib directory… it would be a VERY good idea to back up the ones already there before overwriting.
(ie. backup,, and if it exists also backup and any other libstdc++.* files contained in the /usr/lib directory)

And be SURE to copy BOTH files to /usr/lib as the file is a symbolic link that points to the other file… so only copying the file won’t work.

BTW, the wireless drivers in Linux Mint/Ubuntu should be easy to fix (they are available)… just in case you fancy a change :wink:

It is (or at least was!) like the picture shown. :frowning:

I have replaced the and files with those from the rpm ( and ) but sadly no change. I still have the black desktop with only the search bar and lower bar visible. Firefox 2 still runs when the search bar is used. The /usr/lib/ directory also contains (symbolic link) and

I’d like to fix the linpus install if at all possible, but if not there’s a mint usb stick standing by- which currently works with ethernet but not wifi. I’m a little wary as I’ve had problems with ubuntu and mint and wifi drivers on other laptops- some work great, some are not reliable.

Thanks :slight_smile:

I don’t actually own an AA1… normally I’d fire up the OS in a VM, reproduce the issue, then sort out a fix, but the recovery DVD appears to contain a disk image rather than an installer, so I can’t load it into a virtual machine.

So the only thing I can suggest is to reinstall Linpus Lite from the Recovery DVD… if you don’t have one, an ISO image can be downloaded from here:

The above link is to the lastest version 1.0.21E, as listed here:

And instructions for its use here:]How to recover an Acer Aspire One

BE AWARE - This will erase the drive completely, putting it back to factory default… so back up anything you will need BEFORE following the above instructions.

Download the older 1.0.15E version (which I think was the original as installed on the ZG5) as a torrent:

Then follow the instructions here:

Test downloads of those -

1.0.21E from top link - 23 minutes

1.0.15E from torrent link - 82 minutes

So they are quite quick

As another matter of interest… what files that start with libstdc++ are contained in your /usr/lib directory ?, symbolic link to:, symbolic link to:

Was there before you overwrote it with the file I told you to download, or was there ONLY ?

No, there was only and the link to it

I’m wondering if libstdc++6 is supposed to be installed AT ALL, as it seems a bit weird that version 5 is there as well.

How do you fell about moving the symbolic link… MOVE it, don’t delete it, just in case it needs replacing.

Battery and wifi icons no longer appear and firefox 2 no longer starts from search bar. Other than that, black screen with search bar and bottom bar visible as before.

OK, put it back :frowning:

Back to the black desktop with wifi and battery icons, firefox 2 working from search bar. As before.


OK, I just unpacked the Linpus Lite 1.0.21.E image and it definitely uses libstdc++6.0.8 so it’s highly likely you are using the correct version now.


When you originally removed firefox… how did you do it ?
(if you did it from Add/Remove software, it will have been FF2 that got uninstalled)

It seems that you are NOT supposed to remove Firefox 2 from a Linpus Lite system as it is interwoven with the desktop… doing so also removes a lot of other things including most of the xfce4 desktop.
(reinstalling it does NOT replace these packages)

You are ONLY supposed to remove it with the --nodeps option so it doesn’t remove the dependencies…
ie. rpm -e --nodeps firefox

Is there a log file somewhere in Linpus that will tell you what was removed with Firefox ?

If not… you could try reinstalling xfdesktop and xfdesktop-acer … they should be safe, as you are only installing/reinstalling packages from the official repo’s, but you attempt them at your own risk.

sudo yum install xfdesktop


sudo yum install xfdesktop-acer

I’m putting these links here for future reference… they are the Linpus lite src.rpm repo’s

You may also want to reinstall pretty much everything else that starts with xf from those lists -

sudo yum install xfce-desktop-profile
sudo yum install xfce-mcs-manager
sudo yum install xfce-mcs-plugins
sudo yum install xfce-utils
sudo yum install xfce4-acs-plugin
sudo yum install xfce4-dev-tools
sudo yum install xfce4-go-home-plugin
sudo yum install xfce4-icon-theme
sudo yum install xfce4-mixer
sudo yum install xfce4-panel
sudo yum install xfce4-session
sudo yum install xfce4-volstatus-icon
sudo yum install xfce4-xkb-plugin
sudo yum install xfwm4

Once you’re done installing things… run:

sudo yum update

to make sure everything is the latest version.

I think I’ve found it… see here:

It looks like what was removed when he uninstalled firefox was -

Jul 15 18:41:12 Erased: ame
Jul 15 18:41:13 Erased: smanager
Jul 15 18:41:15 Erased: Thunar
Jul 15 18:41:22 Erased: yelp
Jul 15 18:41:23 Erased: thunar-volman
Jul 15 18:41:24 Erased: firefox
Jul 15 18:41:26 Erased: xfdesktop
Jul 15 18:41:27 Erased: xfdesktop-acer


DON’T[/b] run the following command yet… read this posting first:


So this command should reinstall them:

sudo yum install firefox xfdesktop xfdesktop-acer ame smanager Thunar yelp thunar-volman


sudo yum update

then reboot.

You might want to get yum to list all installed packages first, and check if they are missing:

yum list installed | more

or export them to a file in your home folder:

yum list installed > ~/yum-list.txt

it would also be a good idea to see what was uninstalled around the same time as firefox, by looking through the yum.log:

cat /var/log/yum.log | more

I have a feeling the Thunar in that command may need a lower case T, so keep an eye out for any messages about that package not existing, and replace with thunar if necessary.

If that gets you back up and running… DO NOT uninstall Firefox 2 again… follow these instructions to install Firefox 4:

Can you please let me know if this works, so I can pass the info on to others that may have the same issue… Thanks.


Sorry I haven’t been online for a few days. Looking at the yum.log shows I did indeed erase exactly the same stuff as you listed. (ame, smanager, yelp, thunar-volman, Thunar, firefox, xfdesktop, xfdesktop-acer, though I then reinstalled firefox 2- but not the others).

I get command line access to the AA1 by pressing ctrl-c as it starts up until a command prompt appears. I can do most things from here, but it does not connect to any networks (ethernet or wireless) so I can’t install stuff via yum, the network connections only start when the graphical desktop does. I can however look for rpms on a different computer and move the files over using a usb stick, as I did for the libstdc++ files.

I can’t find any way to get a terminal when I allow it to start up as far as the broken graphical interface- it connects to networks, firefox 2 runs from the search bar and I can do a desktop search, but there doesn’t seem to be a way to open a terminal window (likely because the desktop is missing the above files).

Any advice on getting net connection/yum working from the command prompt, or shall I just try to find the relevant files and put them on a usb stick?

Thanks very much.

Edit to add: I made a USB rescue disk as suggested, haven’t used it as overwriting the machine is obviously the last resort. Probably all the necessary files are on there, it’s a case of knowing which ones to copy over!

Can you post the contents of the /etc/inittab fie … use the Mint LiveUSB to access it if necessary.

inittab This file describes how the INIT process should set up

the system in a certain run-level.

Author: Miquel van Smoorenburg,

Modified for RHS Linux by Marc Ewing and Donnie Barnes

Default runlevel. The runlevels used by RHS are:

0 - halt (Do NOT set initdefault to this)

1 - Single User mode

2 - MultiUser, without NFS (The same as 3, if you do not have networking)

3 - Full multiUser mode

4 - unused

5 - X11

6 - reboot (Do NOT set initdefault to this)


System initialization


10:0:wait:/etc/rc.d/rc 0
11:1:wait:/etc/rc.d/rc 1
12:2:wait:/etc/rc.d/rc 2
13:3:wait:/etc/rc.d/rc 3
14:4:wait:/etc/rc.d/rc 4
15:5:wait:/etc/rc.d/rc.5 5
16:6:wait:/etc/rc.d/rc 6


ca::ctrlaltdel:/sbin/shutdown -t3 -r now

When our UPS tells us power has failed, assume we have a few minutes

of power left. Schedule a shutdown for 2 minutes from now.

This does, of course, assume you have powerd installed and your

UPS connected and working correctly.

pf::powerfail:/sbin/shutdown -f -h +2 “Power Failure; System Shutting Down”

If power was restored before the shutdown kicked in, cancel it.

pr::12345:powerokwait:/sbin/shutdown -c “Power Restored; Shutdown Cancelled”

Run gettys in standard runlevels

1:2345:respawn:/sbin/mingetty --autologin user tty1
#2:2345:respawn:/sbin/mingetty tty2
#3:2345:respawn:/sbin/mingetty tty3
#4:2345:respawn:/sbin/mingetty tty4
#5:2345:respawn:/sbin/mingetty tty5
#6:2345:respawn:/sbin/mingetty tty6

Run xdm in runlevel 5

#x:5:respawn:/etc/X11/prefdm -nodaemon

OK, in the /etc/inittab file, find this section:

# Run gettys in standard runlevels 1:2345:respawn:/sbin/mingetty --autologin user tty1 #2:2345:respawn:/sbin/mingetty tty2 #3:2345:respawn:/sbin/mingetty tty3 #4:2345:respawn:/sbin/mingetty tty4 #5:2345:respawn:/sbin/mingetty tty5 #6:2345:respawn:/sbin/mingetty tty6

and uncomment the tty2 through tty6 lines, so it looks like this -

# Run gettys in standard runlevels 1:2345:respawn:/sbin/mingetty --autologin user tty1 2:2345:respawn:/sbin/mingetty tty2 3:2345:respawn:/sbin/mingetty tty3 4:2345:respawn:/sbin/mingetty tty4 5:2345:respawn:/sbin/mingetty tty5 6:2345:respawn:/sbin/mingetty tty6

Now SAVE the file.

Now in the /etc/X11/xorg.conf file, find these 2 options:

Option “DontZap” “yes” Option “DontVTSwitch” “yes”

And change the options from “yes” to “no”, so they read:

Option “DontZap” “no” Option “DontVTSwitch” “no”

Now SAVE the file.

Now reboot the way you normally would (the way that gives you internet access).

Now when you press Crtl+Alt+F2 or F3 through F6, you should be taken to a Virtual Terminal (command prompt)… you’ll may be prompted to log on… if you are, I’m hoping the logon credentials are:
Username = user
password =