Firefox 42 problem (SOLVED)

Hi All - I hope someone can help with this…!

In previous versions of Firefox, if I needed to access my ‘preferences’, I simply clicked on Edit>Preferences and a tabbed box appeared which gave access to all the relevant settings etc. Now, a browser page appears and shows the ‘General’ page only, but no buttons are active upon it, so no information can be accessed or changed. ???

Typing ‘about:preferences#Security’ in the address bar brings up that page, but again, no active buttons… ::slight_smile:

In previous versions, typing in a new page address bar ‘about:config’, then ‘pref’, in the search field brought up the string ‘browser.preferences.inContent’ showing (user set>boolean>false). Double-clicking on this string changed the value to ‘true’ and upon restarting Firefox the old preferences box was restored. This no longer happens in v42 and a web search says the feature is no longer supported.

Is there a way of getting this feature back? Even if it means reverting to an old FF version?

Alternatively, if the new ‘style’ is what we must put up with (crap, IMHO, as it makes things more difficult!) then how do I get the buttons on said pages to work?

This is a real bummer for me as I have a lot of different passwords for different sites and it is nigh-on impossible to keep track of them all! Having access to my preferences is an easy way to check on the password for a site I haven’t visited for a while and this new ‘feature’ well and truly puts the mockers on that! >:(

Thanks, as always


Edit: Mint 17 Cinnamon, if it helps?

Just as a matter of interest, what happens if you (with FF closed) run:

mv ~/.mozilla ~/.mozilla-old

then start FF ?

Hi Mark - and thanks! What I’ve done so far:

On my main pc (Mint 17) as a precaution, I transferred all bookmarks and saved passwords to Palemoon before doing anything in Ffx and that m/c is still as it was.

I tried your instruction on my laptop (running Tahrpup 6 and with Firefox 42 installed also) and where the same problem existed. Firefox has loaded a fresh version (or has returned to factory default) where all add-ons and themes, bookmarks/passwords have gone. (Not a problem btw)

Changing the string in about:config had no effect on the prefs box (as before) but, the ‘new style’ pages now have active buttons! This I can live with but I’m reluctant to change Firefox in Mint if it means reloading all the bits and bobs one by one. Bookmarks and passwords are easy enough but there’s a fair bit of formatting and themes etc. Is there a way to retain all of these settings and redo them in one ‘hit’ as it were?



I’ve done some further digging and found the reason why the ‘new’ preferences page was frozen - an addon theme in Firefox.

Removing the theme has allowed the preferences page to load correctly and the passwords are now visible on demand. Just have to fiddle around for a new theme…!

Thanks for the help :wink:


You can always go back to using the original .mozilla directory if you wish … then just remove your theme
(we didn’t delete it, we just renamed it … so a new ‘fresh’ profile was created, but the old one is still there)

To go back to the old profile … with FF closed, run:

mv ~/.mozilla ~/.mozilla-new


mv ~/.mozilla-old ~/.mozilla

Then start FF

Ok! Thanks Mark, that’s great! :wink: