Firefox 6 on Acer Aspire One very slow or crashing

I have an Acer Aspire One, running Linpus Lite. My Firefox upgraded itself to v6, worked once and then refused to open again.

I found your instructions on installing Firefox 6 , followed them and then disabled automatic upgrades. It seemed to work, but after being started up a couple of times it became very slow (10 minutes to scroll down?) and sometimes stopped working altogether. It also failed to close down correctly and left my netbook unusable for a bit till I had used the power button a few times to power it down.

Several times Firefox had given me an error message about an Unresponsive Script. The latest one said “resource://gre/modules/XPCOMUtils.jsm:282”. It did work better for about 5 minutes after I told it to kill the script but then it slowed right down again.

I have been able to power up my netbook and get a terminal window so I thought I would go back to Firefox version 4, hoping it would overwrite anything terrible the later version has done to my system. It had worked OK when I installed it in May following Macles’ instructions, but the library file now seems to be unavailable at the web address he gave and has obviously been overwritten by the upgrades on my netbook.

Help! Any suggestions please?

OK, the missing library that was on macles was (probably) the same as this one:

macles version probably contained 2 files (the “actual file” and a shortcut to it)… this file only contains a single file (the “actual file”, renamed to what the shortcut was called)… but it should be the same version, so just unpack the archive, and drop the libstdc++so.6 file into the Firefox 4 directory.

Or see the instructions here:

Though FF6 shouldn’t be any slower than FF4… have you tried disabling all add-ons, and updating the flashplayer ?

Try starting Firefox in safe mode, and disabling the add-ons … to start Firefox is safe mode, open a terminal and run:

firefox -safe-mode

Put a tick in Disable all add-ons and click Continue in safe mode.

If that solves the issue, it’s obviously an errant add-on

Flashplayer upgrade instructions here:

You might also want to check available free space on your hard drive/SSD and the inode usage
What is the output from

df -i


df -h

I perservered and managed to upgrade a AA1 (2008 vintage) to Firefox 7.0.1. It has TOTALLY transformed the AA1. Now very fast, including looking at the NY Times website. A miracle seemingly but achievable by mere mortals. Very satisfying and saves $$$ buying a new netbook!

I recommend all AA1 Linux O/S owners to do the same.

Hi linuxtky, and welcome to the forum :slight_smile:

Any chance of a HOW TO, or pointer to which instructions you followed so I can type them up for others ?

I’m not 100% sure that advising AA1 (Linpus Lite) users to upgrade to Firefox 7.0.1 without providing instructions or at least warning them NOT to uninstall Firefox 2 first is a good idea… but I’m glad to hear you managed to get it working :slight_smile: