Firefox high CPU


I’m trying to install an OS on an older desktop that is relatively simple and quick, but I’m having trouble installing anything. When I load any of the Linux distros from the CDs (or USBs) they all seem to take an age to load up and the CPU maxes out when Firefox is running. I initially tried to install Win10 but the low memory gave me a massive problem. One of the lighter distros, though, seemed to be a reasonable alternative. However, I’ve tried Ubuntu, Lite, Mint and Puppy (which I couldn’t get installed). (I also tried other OSs including Haiku, Bodhi, DSL and Kolibri). With the Linux distros, the CPU was high for a minute then returned to a more moderate level, but after Firefox was started, the CPU rose to around 95% or higher, often maxing out for several minutes leaving the system unresponsive. Once Ff closed down the CPU returned to normal(ish). In almost all versions of any OS I tried, the boot up time was significantly longer than I have experienced for other computers. Even ones with a lower spec.

Specs for the problem desktop:

Dell Dimension 2400, originally installed with XP.

Proc: Intel Celeron 2.60GHz
Mem: 768MB
Drives are currently disabled. (Actually removed.)
Displ: Currently hooked up to a 1440 x 900 screen running directly off the mother board.

If necessary, for your info from PartedMagic on the Hirens CD, (means nothing to me):
CPU Blowfish: 20.58
CPU Cryptohash: 33.86
CPU Fibonacci: 5.63
CPU N-Queens: 10.70


Hi Matt.

In my experience Windows hogs disk space even after it’s been removed, leaving you with not enough to run Linux, and you may need to reformat the drive.
First of all, try entering in a terminal:

sudo fdisk -l

This will output lots of info - look for something like this (from my laptop):

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 996167679 996165632 475G 83 Linux
/dev/sda2 996169726 1000214527 4044802 2G 5 Extended
/dev/sda5 996169728 1000214527 4044800 2G 82 Linux swap / Solaris
This should tell you what partitions you have and how much has been left to you for installing Linux.

Would you please show that part of the output in your next post.


This was running in trial mode with no HDD attached. However, I have tried to install Mint on a drive on this computer having cleaned the drive. This makes no difference.

No difference to what, I wonder?
If you can install any Linux operating system on the PC, then please perform the action suggested in my previous post. It doesn’t matter if the computer is very slow.

My apologies. I often moan about people not reading my post properly before replying, and her am I doing exactly that.

Device Boot Start End Sectors Size Id Type /dev/sda1 * 2048 14743551 14741504 7G 83 Linux /dev/sda2 14745598 16840703 2095106 1023M 5 Extended /dev/sda5 14745600 16840703 2095104 1023M 82 Linux swap / Solaris

How’s this?


According to the output, your hard drive has just 9GB allocated to Linux. I think it might struggle a bit!
If this is a dual boot machine, with both Linux and Windows, then Windows has hogged almost everything.

Or are you still running Linux from a Live USB? If you have installed Linux then please install inxi:

sudo apt install inxi


inxi -Fx | grep ID-

and report the output. If you can’t do that, what size HDD is in this computer

Is this your only machine? Are you willing to delete Windows (after backing up your files) and install Linux?


The system I used to get this information is a Linux Mint Live CD (USB version). The disc is the second one I tried to install it on as I was uncertain whether the first one was the issue. This second one is only 8.6GB. When I installed it I set the up to use the whole disc and erase all previous data. It should total the full 8.6(ish)GB.

Running up the previous disk which is 20GB The details there are:

Device Boot Start End Sectors Size Id Type /dev/sda1 * 2048 39178239 39176192 18.7G 83 Linux

Despite only having one partition, the system is Linux Mint. Again the install was set for LM install only, using the entire disc.


ID-1: /dev/sda vendor: Samsung model: SP2001H size 18.68 GiB temp: 13 C ID-1: / size: 18.26GB used: 14.17 GiB (77.6%) fs: ext4 dev: /dev/sda1

Not sure why there is 14GB used. All I did at the time was install the system updates.

Also, the process ‘mate-system-monitor’, which I assume is just the “task manager”, is running at around 18% CPU. Compare this to my Windows version running ‘Task Manager’ at 0.2% CPU. When starting Firefox, the monitor boosts to around 30%, Ff hits nearly 60%, plus various ‘web content’ tasks running a total of often over 10%.


I’ve been getting confused by “discs” and “installing”. One doesn’t really install an OS on a DVD (although there are exceptions) one merely creates a “live DVD” which is used for installing the OS on a hard-drive or SSD.
So if I understand: You have a “Mint Live Disc” on a DVD of ~8GB which you used to install Mint onto your Dell computer that is fitted with a 20GB hard drive. OK?
And your first fdisk -l command was issued when running from the Live Disc. Yes?
And now you have just booted from your hard drive and issued the fdisk command again. Yes?

A fresh installation of Mint on your HDD ought not to occupy 14GB. Have you added any files of your own?
While running from the installed OS, please issue the following command:

du -sch Documents Music Pictures | tail -n 1

and report the output.


My apologies. I put disc when I meant disk. I used a USB installation medium to install the OS onto the HDD.

No sweat. “HDD” is better - because I’m a bit dim.

And the du command?

Less dim than me, I suspect.

No, the fdisk command was run through the installation.

du = 12k

Incidentally, I have recently installed LM on VirtualBox. The VM was 2048MB mem and 20GB ‘HDD’. With full updates, the total used was 6.8GB. The host machine showed that the VDI file expanded to a total of 8.5GB. This I guess should be the maximum disk space required without further installing anything. So the 8GB disk would have been a problem, but the 20Gb should have only had 7-9GB used.


Yeah. Interesting. I’ll have a think.

You could check disk usage with ‘df’:

df -h

look for disk usage in / and /home
for example Linux Mint XFCE:
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 30G 20G 8.1G 71% /
/dev/sda6 46G 38G 6.0G 87% /home

your bottleneck is low memory and slow HDD
Check memory usage (example with 32gb memory):

free -m
                total        used        free      shared  buff/cache   available

Mem: 32025 1971 26822 116 3231 29483
Swap: 30516 0 30516

It appears that the installed 768mb memory is shared with graphics (128mb in your case)
Leaving you with 640mb useable memory which is not much.
Firefox is not light and need to load into memory a huge ammount of data.
If the 20gb HDD is slow (which I suspect it is) the cpu usage you see is more than likely associated with
IO (reading and writing to disk).

You can check cpu & memory usage with ‘top’ (exit with q):
Look for firefox


1.3 2.0 3:33.67 firefox

or check disk access with ‘iotop’ (exit with q):
install with

sudo apt install iotop

again look for firefox

sudo iotop

You can check disk read (speed) with ‘hdparm’:
You may need installing

sudo apt install hdparm


sudo hdparm -tT /dev/sda

for example
Timing cached reads: 23440 MB in 1.99 seconds = 11775.92 MB/sec
Timing buffered disk reads: 1554 MB in 3.00 seconds = 517.42 MB/sec

The second line is the actual disk read (the first is read from memory)